Skip to main content
Jump to: navigation, search

Difference between revisions of "PTP/photran/installation"

< PTP‎ | photran
m
m
 
(13 intermediate revisions by 2 users not shown)
Line 1: Line 1:
== System Requirements ==
+
You are here: [[PTP]] > [[PTP/photran/ | Photran]] > [[PTP/photran/installation | Installation Instructions]]
  
To install Photran 4.0 beta 5,
+
== Installation Instructions ==
# you must have '''Eclipse 3.4 (Ganymede)''' installed,
+
{|
# you must have the '''C/C++ Development Tools (CDT) 5.0''' installed,
+
|-
# Eclipse must be running on a '''Java 1.5 or later JVM''' (to get reasonable performance, we recommend Sun [http://java.sun.com/] or IBM's [http://wiki.eclipse.org/index.php/J9] JVM), and
+
| '''[[PTP/photran/documentation/photran5 | Photran 5.0]]'''
# if you want to compile and build Fortran applications, you must have a '''make utility and a Fortran compiler''' in your system path.  Many Linux/Unix systems include these; details on installing them in Windows are below.
+
| '''requires Eclipse 3.5 (Galileo) and CDT 6.0'''
 +
|-
 +
| [[PTP/photran/installation/photran4 | Photran 4.0]]
 +
| requires Eclipse 3.4 (Ganymede) and CDT 5.0
 +
|}
  
== Installation Procedure ==
+
[[Category:Photran]]
 
+
To install Photran, start Eclipse 3.4, then...
+
 
+
# Download the latest Photran zip file from [http://wiki.eclipse.org/PTP/builds/photran/4.0]
+
# Click on Help > Software Updates...
+
# Click on the "Available Software" tab
+
# Click on "Add Site..."
+
# Click Archive...
+
# Choose the zip file you downloaded from [http://wiki.eclipse.org/PTP/builds/photran/4.0]
+
# Click OK to close the Add Site dialog
+
# The zip file should appear in the list as jar:file:/path/to/photran-master-4.0.5-something. Expand it.
+
# Expand "Photran (Eclipse Fortran Development Tools)" and check the box next to "Photran (Eclipse Fortran Development Tools) (Eclipse Technology Incubation)"
+
# If you have Intel Fortran installed on Linux or IBM XLF installed on Mac, then expand "Photran Compiler Support" and select the appropriate compiler as well.
+
# Click on the "Install..." button in the ''upper-right corner'' of the dialog box.
+
 
+
== Additional Instructions for Windows Users ==
+
 
+
To compile and run Fortran programs in Photran, you will need to have a Fortran compiler and make utility installed.  Most Linux/Unix distributions include these; [[http://gcc.gnu.org/fortran/|gfortran]] is commonly used (and free).  Under Windows, you will need to
+
# Install Cygwin [http://www.cygwin.com/]; be sure to include the Development packages (in particular, gcc, make, and gfortran)
+
# Add the Cygwin directories to your Windows PATH.  Under Windows XP, the process is as follows:
+
## Make sure you are logged in under an administrator account.
+
## Open the Control Panel.
+
## Double-click the System icon.
+
## Switch to the Advanced tab.
+
## Click the Environment Variables button.
+
## Under System Variables, find the variable "Path" in the list, and click on it.
+
## Click Edit.
+
## At the end of the "Variable Value" text, add <pre>;C:\Cygwin\bin;C:\Cygwin\usr\bin;C:\Cygwin\usr\local\bin;C:\Cygwin\lib;C:\Cygwin\usr\lib</pre>
+
## Click OK, click OK, click OK, and close the Control Panel.
+
## Close and re-open Photran.  Windows should now search C:\Cygwin\bin, C:\Cygwin\usr\bin, etc. when it's looking for executables (including make.exe, gcc.exe, and gfortran.exe).
+

Latest revision as of 16:34, 12 October 2009

You are here: PTP > Photran > Installation Instructions

Installation Instructions

Photran 5.0 requires Eclipse 3.5 (Galileo) and CDT 6.0
Photran 4.0 requires Eclipse 3.4 (Ganymede) and CDT 5.0

Back to the top