Jump to: navigation, search

PTP/installjava

Installing Java for use with Eclipse

  • Eclipse needs at least a Java Runtime Engine (JRE) to function.
    • You need the Sun or IBM versions of Java (not Linux's GCJ)
    • Java 1.6 or higher is needed. (Note that "Java 1.6" is the same as "JRE 6.0")
    • See Eclipse installation FAQ under "Installing Java" for more information.
    • Quick link: JRE 6.0 will probably work fine.


Ensure that a Java Runtime Environment (JRE) version 1.6 or higher is installed. This can be done with the command:

   java -version

An IBM, Sun, or equivalent JRE is required; The gcj-based Java shipped with most Linux distributions does not work with Eclipse. If in doubt, run the above command and check if there is a reference to gcj. If you are using the Linux operating system, download and install either the Sun Java Runtime Environment or the IBM Java Runtime Environment.

OpenJDK has not been tested extensively but it should work.

  • We have at least one report that Eclipse 3.7 (the previous 2011 version of Eclipse, a.k.a. Indigo) works with OpenJDK 1.6.0_22 successfully