Jump to: navigation, search

PTP/environment setup 60

Setup for development of PTP 6.0

PTP now uses the git repository at dev.eclipse.org and the CVS repository is now locked for writing.

Git reference info: Links to Git info

These instructions describe using the master branch of the repository. Please let us know (e.g. on ptp-dev mailing list) if these instructions need updating.

PTP 6.0 needs Java 1.6, Eclipse 4.2/Juno (or Eclipse 3.8/Juno), CDT supported by Juno (8.1), and RSE 3.3 (at least)

Install CDT, RSE, Git, etc. into Eclipse.

  1. In Eclipse, click Help > Install New Software...
  2. In the "Work with:" combo box, choose "Juno - http://download.eclipse.org/releases/juno"
  3. Under "Collaboration", check the checkbox next to "Eclipse EGit"
  4. Under "General Purpose Tools", check
    1. "Remote System Explorer End-User Runtime" (RSE)
    2. (Optional) "Parallel Tools Platform (PTP) End-User Runtime" - while you will probably check out source to override this, having it installed in the workbench can avert later build problems.
  5. Under "Programming Languages", check all of the following:
    1. C/C++ Development Tools SDK
    2. Fortran Development Tools (Photran)
    3. Unified Parallel C Support (this includes CDT's LR parser)
    4. XL C/C++ Compiler Support
  6. (Optional) Under "Web, XML, JavaEE...", check
    1. "Eclipse XML Editors and Tools" (this is useful for editing XML files, e.g. creating resource manager configurations)
    2. "Eclipse Web Developer Tools" (useful for editing HTML files)
  7. Click the "Next >" button, and complete the installation wizard. Restart Eclipse when prompted.

JAXB shouldn't be needed to install into Juno, JAXB is part of the Java 1.6 libraries

Set an API baseline.

In these steps, you will download the previous release of PTP. Eclipse's API Tooling will compare the current API with the API from the previous release to check for breaking changes.

  1. Download the PTP 5.0.0 master archive: ptp-master-5.0.0-I201106140904.zip
  2. Unzip it into some directory (e.g. ptp-baseline-5.0.0)
  3. Open the Eclipse workbench preferences dialog. (On Windows or Linux, click Window > Preferences; on Mac OS X, click Eclipse > Preferences)
  4. Expand the "Plug-in Development" category, and choose "API Baselines"
  5. Click "Add Baseline..." In the dialog, enter "Default" for the name, choose the directory from step 2 for the location, click "Reset", and then click "Finish" to close the New API Baseline dialog.
  6. Click OK to close the Preferences dialog. (If a message dialog appears asking whether you want to perform a full build, click Yes.)

Checking out PTP projects

  1. File>Import ... then use the 'Git>Projects from Git' import wizard.
  2. Select "URI" and click Next >
  3. If you haven't yet cloned the repository to your machine:
    • Under Location: URI: enter the repository URI and click Next >:
    • Choose the branches you want to clone (usually ptp_5_0 and master==HEAD) and click Next >.
      • Note: all workspaces on your machine that talk to this local clone of the repository will all use the same branch at a time. You may want separate clones of the repo (one for each release/branch) for this reason. If so, the last page of the wizard lets you specify a different directory for this clone and you don't have to use same name as remote repo name for your directory.
        • One convention for this: Make two clones of the git repo, one for master (Juno work) and one for the ptp_5_0 branch (Indigo work). You can put both branches in each clone.
          • One set of suggested names of the repos:
          1. Set of repos where 'master' is the (default) branch used - for Juno work (that is, name the repo the same as the remote repo name)
            • org.eclipse.ptp.git
            • org.eclipse.photran.git
            • org.eclipse.ptp.master.git (this is the aggregated build project for eclipse hudson build server. Most developers won't need to clone this.)
          2. Set of repos where 'ptp_5_0' is the (default) branch used - for Indigo work
            • org.eclipse.ptp.git-ptp50
            • org.eclipse.photran.git-ptp50
            • org.eclipse.ptp.master.git-ptp50 (this is the aggregated build project for eclipse hudson build server. Most developers won't need to clone this.)
    • Click Next> to choose where you want the repository located locally. It can be anywhere. See suggested names above if you don't have a better idea.
    • Click Finish. The repository should be downloaded.
    • Once the repository has downloaded you should see it in the list. Select it.
  4. If you have already cloned the repository, and it isn't shown in the list (e.g. Clone done from another workspace)
    • Select Add... and add it.
    • You should now see it in the list. Select it.
  5. Click Next> then Next> again and you should see a list of all the projects.
  6. Select all of the projects except org.eclipse.ptp.rm.smoa.core and org.eclipse.ptp.rm.smoa.ui, and click Finish.

Repeat the steps to import another repository (e.g. photran). The photran URI is ssh://userid@git.eclipse.org/gitroot/ptp/org.eclipse.photran.git

It is also necessary to set Git options to ensure that updates are done correctly.

ONCE ONLY: (Git settings are saved on disk, so shared across workspaces and Eclipse installations.)

  • Open Window>Preferences>Team>Git>Configuration
  • Select the "User Settings" tab
  • Click "New Entry"
  • For "Key", enter branch.autosetuprebase
  • For "Value", enter always
  • Click "OK"

FOR EACH REPOSITORY YOU HAVE CLONED:

  • Open Preferences>Team>Git>Configuration if it's not already open
  • Select the "Repository Settings" tab
  • Select the repository from the "Repository" dropdown
  • Click "New Entry"
  • For "Key", enter branch.master.rebase
  • For "Value", enter true
  • Click "OK"
  • If you are working on the ptp_5_0 branch (or other branches)
    • Do the same thing, but use key branch.ptp_X_Y.rebase

Updating

  1. Right-click on a project and use Team>Pull - this updates the entire local repository, and the current branch in your workspace

Platform Git workflows wiki page has more detail here (including splitting Pull into its two actual steps of Fetch and Merge]

Note:

  • Make sure you have set branch.autosetuprebase=always and branch.<name>.rebase=true as described above
  • This causes a Pull (analogous to a 'cvs update') to do the following:
    • Fetch
    • Rebase (It undoes all local commits, fast-forwards the local version to the remote one, and then reapplies the local commits)
  • Otherwise a Pull only does a Fetch/Merge which causes a spaghetti like history

Committing to remote repository

There are two steps to getting code changes in the remote repository at git.eclipse.org. (This was a single commit step in CVS.)

  1. Commit to your local repository - this can be on single files or groups/whole project
    • right-click on your project and use Team>Commit
  2. Push to copy it to the remote repository - do it on project, e.g. from Project Explorer; all commits in your local repository (including other projects) get pushed up to git.eclipse.org
    • right-click on your project and use Team>Push to Upstream

Platform Git workflows wiki page is helpful here.

Here are the steps:

  • Checkout the branch you want to commit changes, for example local:master -> remote:master
  • If it is already checked out, Pull to make sure it is in sync
  • Make changes / Apply patch
  • Commit. Specify Author - contributor of the patch, and yourself as Committer
  • Push.
    • If push failed, you may not be having latest version. Rerun pull.

In history view you should see

[master][origin/master][HEAD] Bug xxx - your fix

API baseline and code formatter

Building runtime binary

To e.g. run with a resource manager, you may have to build some platform-specific binary/proxy code. For example, to run with OpenMPI locally on MACOSX, cd to the org.eclipse.ptp.macosx.x86 project in a terminal window, and execute

  • sh BUILD

This should build the executable 'sdm' in the bin/ directory. Do not be alarmed if you see "LoadLeveler not installed, skipping..." etc - if you do not have these IBM components installed on your system, there is no need for it to build those binaries.

Copy Remote Tools Dstore server jar

If you are using Remote Tools ... you may see the error "Unable to locate payload "rdt-server.jar" in bundle "org.eclipse.ptp.rdt.server.dstore" " when you launch a runtime workspace and make a remote project.

So you must do the following (Until we can build rdt server jar here) ... From a PTP (end-user) installation, unzip eclipse/plugins/org.eclipse.ptp.rdt.server.dstore_xxx.jar into a directory. Then from the unzipped contents move rdt-server.jar to your development workspace project: org.eclipse.ptp.rdt.server.dstore

(This is the file that will be moved up to the remote host location when you create a remote project. Remote Tools installs this jar on the server automatically and starts it for you.)

If you don't, you will see the error popup "Unable to locate payload "rdt-server.jar" in bundle "org.eclipse.ptp.rdt.server.dstore"

Launching a runtime workbench running the code you checked out into your workspace

  1. Run > Debug Configurations ...
  2. Double-click on 'Eclipse Application' - or click and click on the 'new' icon
  3. Defaults are probably ok to run with all the plugin projects in your workspace; hit 'Debug' in lower right corner


Compiling XML Schema (XSD) into Java classes using the JAXB compiler (xjc)

Should there be a need to alter the provided schemas for the JAXB Resource Manager (or any other such JAXB tooling), follow these steps to set up compilation:

  1. Download jaxb-ri (xjc); e.g., from JAXB Project (Note: Mac OS X already has xjc installed)
  2. Install it somewhere on your local machine
  3. In your project workspace, create an External Tools Configuration. The following is an example based on org.eclipse.ptp.rm.jaxb.core, which has the .xsd in the data directory:
    1. Location: {jaxb-ri directory}/bin/xjc.sh or /usr/bin/xjc
    2. Working Directory: ${workspace_loc:/org.eclipse.ptp.rm.jaxb.core}
    3. Arguments: data/resource_manager_type.xsd -p org.eclipse.ptp.rm.jaxb.core.data -d src

Each time you run this, all the source files generated from the schema will be overwritten.