Difference between revisions of "PTP/environment setup 50"

From Eclipsepedia

< PTP
Jump to: navigation, search
(Compiling XML Schema (XSD) into Java classes using the JAXB compiler (xjc))
 
Line 83: Line 83:
  
 
Each time you run this, all the source files generated from the schema will be overwritten.
 
Each time you run this, all the source files generated from the schema will be overwritten.
 
== Configuration Issues ==
 
*[[PTP/PTP_Configuration_Issues|PTP Configuration Issues]]
 

Latest revision as of 21:15, 6 February 2012

Contents

[edit] Setup for development of PTP 5.0

These instructions describe using the ptp_5_0 branch of the Git repository. Please let us know (e.g. on ptp-dev mailing list) if these instructions need updating.

PTP 5.0 needs Eclipse 3.7/Indigo, CDT 8.0, and RSE 3.3 (at least)

  • Download Eclipse 3.7 (Indigo) here: http://eclipse.org/downloads/ for your platform. "Eclipse Classic" is a good choice.
  • Note: RSE is optional if you are not doing any remote development work.

Install RSE 3.3 End-User Runtime, and CDT 8.0.0, in your eclipse installation

  1. Help > Install New Software...
  2. In the "Work With" drop-down list at the top select: "Indigo - http://download.eclipse.org/release/indigo" or equivalent
  3. Open "Programming Languages" and select "C/C++ Development Tools SDK"
    • If you are building PLDT (i.e., all of PTP) you will also need the CDT feature "Unified Parallel C Support"
  4. Open "General Purpose Tools" and select "Remote System Explorer End-User Runtime"
  5. Open "Collaboration" and select "Eclipse JGit" and "Eclipse EGit"
  6. Optional: Open "Web, XML, JavaEE..." and select "Eclipse XML Editors and Tools" (needed on to create RM configurations)
  7. Click Next> > Next> > Select "I accept..." > Finish
  8. Help > Install New Software...
  9. Add "http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository" as a software site
    • Make sure "Show only latest version..." checkbox is disabled and "Group by category" checkbox is enabled
    • Open "All Orbit Bundles" and select "Java Architecture for XML Binding (JAXB) Implementation Plug-in" and "XML Binding for Java" both version 2.1.9
  10. Next> > Finish

[edit] To check out PTP projects:

Needs to be updated to Git. See Environment setup for 6.0 for now but use ptp_5_0 branch; will adapt for here later.

[edit] old info

In CVS, check out org.eclipse.ptp/releng/ptp_project_sets as follows:

  1. Window > Open Perspective > Other...,
  2. Choose "CVS Repository Exploring"
  3. Right-click in CVS Repositories view, choose New > Repository Location
    • Host: dev.eclipse.org
    • Repository path: /cvsroot/tools
    • User: anonymous
    • If you have a committer id on dev.eclipse.org, use that, enter the password, and change the Connection type to extssh
  4. Expand that repository and expand HEAD. Scroll down to org.eclipse.ptp and expand it
  5. Expand releng, and check out ptp_project_sets

Now switch to the Plug-in development Perspective

  1. In the ptp_project_sets project in your workspace, right-click on anonymous/ptp-HEAD-all-anonymous.psf and select "Import project set"
    • If you have committer access, use committer/ptp-HEAD-all-committer.psf
    • Alternatively, you can check out ptp-5.0-all-*.psf (committer or anonymous)

[edit] PTP developer: API baseline and code formatter

[edit] Building runtime binary

To e.g. run with a resource manager, you may have to build some platform-specific binary/proxy code. For example, to run with OpenMPI locally on MACOSX, cd to the org.eclipse.ptp.macosx.x86 project in a terminal window, and execute

  • sh BUILD

This should build the executable 'sdm' in the bin/ directory. Do not be alarmed if you see "LoadLeveler not installed, skipping..." etc - if you do not have these IBM components installed on your system, there is no need for it to build those binaries.

[edit] Copy Remote Tools Dstore server jar

If you are using Remote Tools ... you may see the error "Unable to locate payload "rdt-server.jar" in bundle "org.eclipse.ptp.rdt.server.dstore" " when you launch a runtime workspace and make a remote project.

So you must do the following (Until we can build rdt server jar here) ... From a PTP (end-user) installation, unzip eclipse/plugins/org.eclipse.ptp.rdt.server.dstore_xxx.jar into a directory. Then from the unzipped contents move rdt-server.jar to your development workspace project: org.eclipse.ptp.rdt.server.dstore

(This is the file that will be moved up to the remote host location when you create a remote project. Remote Tools installs this jar on the server automatically and starts it for you.)

If you don't, you will see the error popup "Unable to locate payload "rdt-server.jar" in bundle "org.eclipse.ptp.rdt.server.dstore"

[edit] Launching a runtime workbench running the code you checked out into your workspace

  1. Run > Debug Configurations ...
  2. Double-click on 'Eclipse Application' - or click and click on the 'new' icon
  3. Defaults are probably ok to run with all the plugin projects in your workspace; hit 'Debug' in lower right corner


[edit] Compiling XML Schema (XSD) into Java classes using the JAXB compiler (xjc)

Should there be a need to alter the provided schemas for the JAXB Resource Manager (or any other such JAXB tooling), follow these steps to set up compilation:

  1. Download jaxb-ri (xjc); e.g., from JAXB Project (Note: Mac OS X already has xjc installed)
  2. Install it somewhere on your local machine
  3. In your project workspace, create an External Tools Configuration. The following is an example based on org.eclipse.ptp.rm.jaxb.core, which has the .xsd in the data directory:
    1. Location: {jaxb-ri directory}/bin/xjc.sh or xjc.bat
    2. Working Directory: ${workspace_loc:/org.eclipse.ptp.rm.jaxb.core}
    3. Arguments: data/resource_manager_type.xsd -p org.eclipse.ptp.rm.jaxb.core.data -d src

Each time you run this, all the source files generated from the schema will be overwritten.