PTP/environment setup 40

From Eclipsepedia

< PTP
Revision as of 09:47, 3 September 2010 by Tibbitts.us.ibm.com (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Setup for development of PTP 4.0

These instructions describe using the HEAD version of the CVS repository. Please let us know (e.g. on ptp-dev mailing list) if these instructions need updating.

PTP 4.0 needs Eclipse 3.6/Helios, CDT 7.0, and RSE 3.1 (at least)

  • Download Eclipse 3.6 (Helios) here: http://eclipse.org/downloads/for your platform. "Eclipse Classic" is a good choice.
  • Note: RSE is optional if you are not doing any remote development work.

For offline installation of pre-reqs, download the following archived update sites:

  1. RSE 3.2 - download the RSE-SDK-3.2.zip file and unzip in your eclipse/dropins dir, then restart with -clean
  2. CDT 7.0.0 - get the final release build

Install RSE 3.2 End-User Runtime, and CDT 7.0.0, in your eclipse installation

  • Help > Install New Software.. .and add both the above downloaded archives
    • Note that now you can also install RSE from the Helios Update site
    • It is assumed that you have an internet connection while installing; if there are pre-reqs missing, it will attempt to fetch them.
  • To see just the local archives and install all at once, select, under "Work with:", "--Only Local Sites--"
  • For RSE: Under TM and RSE 3.2, install the "Remote System Explorer End-Use Runtime"
  • For CDT: Install all "CDT Main Features" - development tools and SDK
  • Next, Next, accept license terms, Finish


See http://wiki.eclipse.org/PTP/environment_setup_30 for background information and instructions on setup for the previous release; may be useful.

To check out PTP projects:

  • In CVS, check out org.eclipse.ptp/releng/ptp_project_sets as follows:
    • Window > Open Perspective > Other..., CVS Repository Exploring
    • Rightmouse in CVS Repositories view, New > Repository Location
      • Host: dev.eclipse.org, Repository path: /cvsroot/tools, User: anonymous
        • If you have a committer id on dev.eclipse.org, use that, enter the password, and change the Connection type to extssh
    • Expand that repository and expand HEAD. Scroll down to org.eclipse.ptp and expand it
    • Under releng, check out ptp_project_sets
  • Return to the Plug-in development Perspective
  • In the ptp_project_sets project in your workspace, rightMouse on anonymous/ptp-HEAD-all-anonymous.psf and select "Import project set"
    • If you have committer access, use committer/ptp-HEAD-all-committer.psf
  • It should check out everything you need.



Below this line, has not been updated from 3.0 version (but is probably the same or similar...)

Building runtime binary

To e.g. run with a resource manager, you may have to build some platform-specific binary/proxy code. For example, to run with OpenMPI locally on MACOSX, cd to the org.eclipse.ptp.macosx.x86 project in a terminal window, and execute

  • sh BUILD

This should build the executable 'sdm' in the bin/ directory. Do not be alarmed if you see "LoadLeveler not installed, skipping..." etc - if you do not have these IBM components installed on your system, there is no need for it to build those binaries.

Copy Remote Tools Dstore server jar

If you are using Remote Tools ... (Until we can build rdt server jar here) ... From a PTP (end-user) installation, unzip eclipse/plugins/org.eclipse.ptp.rdt.server.dstore_xxx.jar into a directory. Then from the unzipped contents move rdt-server.jar to your development workspace project: org.eclipse.ptp.rdt.server.dstore

(This is the file that will be moved up to the remote host location when you create a remote project. Remote Tools installs this jar on the server automatically and starts it for you.)

If you don't, you will see the error popup "Unable to locate payload "rdt-server.jar" in bundle "org.eclipse.ptp.rdt.server.dstore"

Launching a runtime workbench running the code you checked out into your workspace

  1. Run > Debug Configurations ...
  2. Double-click on 'Eclipse Application' - or click and click on the 'new' icon
  3. Defaults are probably ok to run with all the plugin projects in your workspace; hit 'Debug' in lower right corner
  4. Eclipse comes up. Switch to C/C++ perspective if needed
  5. For details on creating an MPI or OpenMP project, see Help > Help Contents ...