Jump to: navigation, search

PTP/environment setup 21

< PTP
Revision as of 09:15, 25 November 2009 by Tibbitts.us.ibm.com (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Prerequisites

  1. Eclipse 3.4 (Ganymede)
  2. CDT 5.0.2
  3. To run full PTP parallel application monitoring/debugging: Linux or Mac OS X, and OpenMPI or MPICH2
  4. To run/debug remote applications, and/or run only PLDT analysis, OpenMPI isn't required, and all should work on Windows

Install steps

Install Eclipse

  1. Install Eclipse Ganymede from http://download.eclipse.org/eclipse/downloads/
    • Choose 3.4, latest version, full SDK
  2. Download the latest build of CDT 5.0.x (currently 5.0.2) from http://download.eclipse.org/tools/cdt/builds
    • Save the cdt-master-5.0.x-IYYYYMMDDHHMM.zip file, to use in software update steps below
  3. Unpack and launch Eclipse
  4. Install RSE from the Ganymede update site using the update manager:
    1. Help > Software Updates ...
    2. Make sure 'Available Software' is selected at the top
    3. Open Ganymede Update Site
    4. Open Remote Access and Device Development
    5. Select Remote System Explorer End-User Runtime
    6. Click Install ... Next, Accept, Finish
  5. Install CDT from the master file you downloaded in step 2:
    1. Help > Software Updates ...
    2. Make sure 'Available Software' is selected at the top
    3. Click Add site, archive, and locate the CDT master ZIP file you downloaded above; hit OK
    4. Select at least the 3 items under CDT Main features (make sure they are checked)
    5. Click Install ... Next, Accept, Finish

Configure CVS Access

  1. Switch to the CVS perspective and create a new repository location:
    • Host: dev.eclipse.org
    • Repository path: /cvsroot/tools
    • User: <yourCommitterID> or anonymous
    • Password: <yourPW> or empty for anonymous access
    • Connection type: extssh for committer access, or pserver for anonymous access
  2. After creating the repository location, expand it and expand HEAD.

All the PTP content is under org.eclipse.ptp.

To check out PTP projects:

  • In CVS, check out org.eclipse.ptp/releng/ptp_project_sets as follows:
    • Window > Open Perspective > Other..., CVS Repository Exploring
    • Rightmouse in CVS Repositories view, New > Repository Location
      • Host: dev.eclipse.org, Repository path: /cvsroot/tools, User: anonymous
        • If you have a committer id on dev.eclipse.org, use that, enter the password, and change the Connection type to extssh
      • Hit Finish
    • Expand that repository and expand HEAD. Scroll down to org.eclipse.ptp and expand it
    • Under releng, check out ptp_project_sets
  • Return to the Plug-in development Perspective
  • In the ptp_project_sets project in your workspace, rightMouse on anonymous/ptp-2.1-all-anonymous.psf and select "Import project set"
    • If you have a committer id then use the psf file under committer/
  • It should check out everything you need.

These project set files will check out ALL the plugins currently in PTP. If you want to only work on a selection, you'll need to remove uneeded plugins from your workspace.

Launching a runtime workbench running the code you checked out into your workspace

  1. Run > Debug Configurations ...
  2. Double-click on 'Eclipse Application' - or click and click on the 'new' icon
  3. Defaults are probably ok to run with all the plugin projects in your workspace; hit 'Debug' in lower right corner
  4. Eclipse comes up. Switch to C/C++ perspective if needed
  5. For details on creating an MPI or OpenMP project, see Help > Help Contents ...