Jump to: navigation, search

Difference between revisions of "PTP/builds/5.0.1"

< PTP‎ | builds
(New page: This page contains pre-release builds of PTP 5.0.1. For installation details see PTP/release_notes/5.0. '''NOTE: This build may require [http://download.eclipse.org/eclipse/downloads ...)
 
 
Line 1: Line 1:
 
This page contains pre-release builds of PTP 5.0.1. For installation details see [[PTP/release_notes/5.0]].
 
This page contains pre-release builds of PTP 5.0.1. For installation details see [[PTP/release_notes/5.0]].
  
'''NOTE: This build may require [http://download.eclipse.org/eclipse/downloads Eclipse 3.7], [http://download.eclipse.org/tools/cdt/builds/8.0.0/index.html CDT 8.0.0] and RSE 3.2 or later.'''
+
'''NOTE: This build may require [http://archive.eclipse.org/eclipse/downloads Eclipse 3.7], [http://archive.eclipse.org/tools/cdt/builds/8.0.0/index.html CDT 8.0.0] and RSE 3.2 or later.'''
 
<br>So far (12 Oct 2010) it still works with Eclipse Helios (3.6) as well.  However CDT 8.0 is required as API changes have already occurred there since 7.0.x
 
<br>So far (12 Oct 2010) it still works with Eclipse Helios (3.6) as well.  However CDT 8.0 is required as API changes have already occurred there since 7.0.x
  
 
CDT does not support Windows 64bit. Use Windows 32bit of Eclipse.
 
CDT does not support Windows 64bit. Use Windows 32bit of Eclipse.
  
'''Current PTP 5.0.1 builds are available by following [http://download.eclipse.org/tools/ptp/builds/5.0.1/index.html this link]'''
+
'''Current PTP 5.0.1 builds are available by following [http://archive.eclipse.org/tools/ptp/builds/5.0.1/index.html this link]'''
  
 
==PTP and Photran ==
 
==PTP and Photran ==

Latest revision as of 12:37, 3 June 2013

This page contains pre-release builds of PTP 5.0.1. For installation details see PTP/release_notes/5.0.

NOTE: This build may require Eclipse 3.7, CDT 8.0.0 and RSE 3.2 or later.
So far (12 Oct 2010) it still works with Eclipse Helios (3.6) as well. However CDT 8.0 is required as API changes have already occurred there since 7.0.x

CDT does not support Windows 64bit. Use Windows 32bit of Eclipse.

Current PTP 5.0.1 builds are available by following this link

PTP and Photran

A build can be installed by downloading a master update site archive file from the above link. Once you have downloaded the zip file, use the update manager (Help > Install New Software...) to add a new Archive Site. You will then be able to browse the contents of the site to install the required components.

The PTP proxy source code is available as a separate download to make installation easier on the remote system.

RDT (Remote Development Tools)

The RDT plugins are available from the PTP master update site archive.

When using RDT with RSE, server components specific to the remote operating system must be downloaded and installed manually. The server components are available as separate downloads by following the above link.

Note: The new spawner miner is included in AIX, Linux PPC and Linux x86 server packages. For more information, see bug 318480


See RDT planning page and RDT setup info for more information.