Jump to: navigation, search

OSEE/TipsTricks

OSEE Application - How do I...

navigate the OSEE specific perspectives

OSEE has a number of perspectives based on the included applications. All perspectives can be accessed through Window pulldown > Open Perspective. To easily navigate through OSEE developed perspectives, select the OSEE pulldown and select your desired perspective.

Artifact Explorer - How do I...

show more information, like attribute values, on each artifact?

You can show artifact types, versions and even valid attributes next to the name of the artifacts on a branch in Artifact Explorer. Simply use the white pulldown to select items you want to show. If you want to save these selections for future Artifact Explorers, just select "Store Label Settings".

ArtifactExplorer showMoreInfo.PNG

quickly open a new Artifact Explorer?

You can open a new Artifact Explorer using the "Open Artifact Explorer" button on the top right of the Artifact Explorer. It will open the new Explorer to the same branch as the one open.

ArtifactExplorer openNewExplorer.PNG

open the Action associated to the selected branch?

For branches that were created from an ATS Action, the "Open Associated Action" button will open those Actions in ATS. If a branch was created manually by a user, it will show a dialog of the user that created the branch.

ArtifactExplorer openAssociatedAction.PNG

open the selected artifact in another branch?

There is an easy way to open the selected artifact on another branch. Select that artifact > right-click > Reveal on Another Branch. This will open another Branch Manager and reveal the artifact on that branch.

ArtifactExplorer revealOnAnotherBranch.PNG

quickly search the currently selected branch?

Select the "Open Quick Search View" button. This will open the Quick Search view, set the selected branch to the same as the Artifact Explorer and place your cursor in the Search text box.

ArtifactExplorer Quick Search.PNG

ATS - How do I...

configure to automatically add new Actions to a Goal

Goal artifacts are used as an ordered list of Actions, Reviews and Tasks. If you want Actions written against an Actionable Item (AI) or Team Definition to be automatically be added to your Goal: Open an Artifact Explorer > Select to Common Branch > Open "Action Tracking System" > Expand down to find your AI or Team Definition > Open your Goal artifact in the ATS Editor > Select the "Workflow" tab > Expand the "Relations" section > Drag your AI or Team Definition to the "AutoAddActionToGoal" relation. > Save

ATS Auto Add Action To Goal.PNG

visit recently opened ATS Actions

Write or open an Action, Review or other ATS object and can't find it? Select "My Recently Visited" in the ATS Navigator to view all ATS objects viewed in the current OSEE session. This list gets cleared after restart.

ATS World and Task Editors - How do I...

filter out completed/cancelled items

Select the pulldown-menu next to the gear and select "Filter Out Completed/Cancelled". You can also use the Ctrl-F hotkey.

ATS filterCanceledCompletedAssignee.PNG

only show items assigned to you

Select the pulldown-menu next to the gear and select "Filter My Assignee". You can also use the Ctrl-G hotkey.

ATS filterAssignee.PNG

open selected ATS items in a new ATS World or Task View

You can easily open selected items in a World or Task View by selecting the World or Task icons in the top right of the editor. You can also right-click > Open With > and select the desired editor for the selected items.

ATS openSelectedInNewWorldEditor.PNG

ATS openSelectedInNewTaskEditor.PNG

Review - How do I...

show all review defects in readable format

The Defect table of a Peer Review only shows 5 lines by default which makes reading the defects difficult. In addition, the Description and Location columns are too narrow to see all the text. There are a few things you can do to help view this data easier.

  1. Make any column wider. Select the line between columns in header > drag the columns out to make it wider
  2. Make the table larger. Select the gray line under the table and drag down to show more rows.
Peer make table larger.jpg
  1. View the entire table with wrapped columns. Right-click anywhere in the table > select "View Table Report". This shows in an HTML format that wraps all the columns.
Peer show defects.jpg

Java Editor - How do I...

incrementally search a Java file

Open Java File > Ctrl-F (search) > Select "Incremental" checkbox > Enter text to search. This will highlight the first occurrence of what you type as you type.

JavaEditor Incremental Search.jpg

XViewer - Advanced Tree/Table Widget - How do I

The XViewer is an advanced and dynamic Tree/Table Viewer that has the filtering and sorting the capabilities of a spreadsheet while providing the users the ability to customize their table to suit their current needs and save/restore these customizations for future use by individual or group.

OSEE has used this widget in many of it's views and editors including: Branch Manager, Results Editor, ATS World Editor, ATS Task Editor, Change Report Viewer, Commit Manager, Merge Manager etc...

There are many advanced features of the XViewer that will help organize and manipulate your view of whatever you're looking at.

email, export to csv and print the contents

Select any item inside the table > right-click > View Table Report. This will open an HTML view of the data. The top left options allow for emailing, printing and exporting to csv. The export to csv will write the file to disk and open whatever application is configure to view comma separated value files, like Excel or Open Office.

XViewer viewTableReport.PNG

Editors - How do I...

restore changes or deleted files from local history

OSEE stores versions of most text files as changes are made. You can access these versions to restore these changes. This includes a file or directory that was deleted. Select the file or folder in the Package Explorer > right-click > Restore from local history.

Editor restore from local history.jpg

prevent multiple editors from cluttering up your workbench

OSEE will show the '>>' indicator after 4 to 8 files are opened. You can configure your workbench to automatically close editors automatically. Select Window pulldown menu > Preferences > General > Editors > select "Close editors automatically" > enter number of editors open before auto-close.

Editor close editors automatically.jpg

Workbench - How do I...

show and open current workspace

After selecting one or more of the OSEE views and editors, you will notice that the current workspace is shown at the bottom of the workbench. You can see the full workspace path by placing your cursor over. This will open a tooltip. If you double-click this label, it will open an explorer window (OS Specific) to that location.

Workbench workspaceLocation.PNG

remove old workspaces from startup selection

If you start OSEE with multiple different workspaces, it will remember the last 5. To clear these you can go to Window > Preferences > General > Startup and Shutdown > Workspaces. You can also change the number of workspaces to remember.

Workbench workspaceHistory.PNG

learn the basics of the workbench

One of the best things a new user of OSEE can do is learn how to navigate the workbench. Switching perspectives, moving editors and views and restoring default are a critical part the efficient use of OSEE.

Select Help pulldown > Help Contents > Workbench User Guide > Getting Started

Workbench basicsOfWorkbench.PNG

go deeper into Eclipse usage

OSEE is built on the open source eclipse.org integrated extensible development environment. Learn more about Eclipse through this Eclipse IDE Tutorial