Jump to: navigation, search

Difference between revisions of "OSEE/TipsTricks"

(search ATS Workflows, Tasks, Reviews and Goals)
(17 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
= OSEE Application - How do I...=
 
= OSEE Application - How do I...=
 +
 +
== open, close and customize perspectives ==
 +
http://www.tutorialspoint.com/eclipse/eclipse_perspectives.htm
 +
 
== navigate the OSEE specific perspectives ==
 
== navigate the OSEE specific perspectives ==
 
OSEE has a number of perspectives based on the included applications.  All perspectives can be accessed through Window pulldown > Open Perspective.  To easily navigate through OSEE developed perspectives, select the OSEE pulldown and select your desired perspective.
 
OSEE has a number of perspectives based on the included applications.  All perspectives can be accessed through Window pulldown > Open Perspective.  To easily navigate through OSEE developed perspectives, select the OSEE pulldown and select your desired perspective.
Line 25: Line 29:
  
 
= Branch Manager - How do I... =
 
= Branch Manager - How do I... =
 +
 +
== show artifact / action related to selected branch ==
 +
Branch Manager > Select Branch > Open Associated Artifact > This will either open the Action or show the User that created the branch.
 +
 +
== quickly open an Artifact Explorer from selected branch ==
 +
Branch Manager > Double-click branch > This opens an Artifact Explorer to the branch selected
  
 
== show baseline branches first ==
 
== show baseline branches first ==
Line 69: Line 79:
  
 
[http://wiki.eclipse.org/OSEE/ATS/Users_Guide/Intro#Terms Read more about ATS Objects]
 
[http://wiki.eclipse.org/OSEE/ATS/Users_Guide/Intro#Terms Read more about ATS Objects]
 +
 +
== configure to automatically add new Actions to a Goal ==
 +
 +
Goal artifacts are used as an ordered list of Actions, Reviews and Tasks.  If you want Actions written against an Actionable Item (AI) or Team Definition to be automatically be added to your Goal:  Open an Artifact Explorer > Select to Common Branch > Open "Action Tracking System" > Expand down to find your AI or Team Definition > Open your Goal artifact in the ATS Editor > Select the "Workflow" tab > Expand the "Relations" section > Drag your AI or Team Definition to the "AutoAddActionToGoal" relation.  > Save
 +
 +
[[Image:ATS_Auto_Add_Action_To_Goal.PNG|center|frame]]
 +
 +
== visit recently opened ATS Actions ==
 +
Write or open an Action, Review or other ATS object and can't find it?  Select "My Recently Visited" in the ATS Navigator to view all ATS objects viewed in the current OSEE session.  This list gets cleared after restart.
 +
 +
= ATS Searching - How do I...=
 +
 +
== search ATS for Workflows, Tasks, Reviews and Goals ==
 +
There are a number of ways to search ATS for what your looking for.  Searching by Id includes ATS Id, GUID (system generated unique id) or Legacy PCR Id.  Using specific searches in Navigator gives more detailed search options.
 +
 +
[[Image:ATS_Searching.PNG|frame|center]]
  
 
== quickly search open ATS actions ==
 
== quickly search open ATS actions ==
Line 79: Line 105:
 
[[Image:ATS_quickSearch.PNG|center|frame]]
 
[[Image:ATS_quickSearch.PNG|center|frame]]
  
== configure to automatically add new Actions to a Goal ==
+
== find Actions that I originated ==
 +
The ATS User Search provides more searching criteria that would allow you to easily find an Action that was written by a user.  Once common case is finding an Action that you originated.
  
Goal artifacts are used as an ordered list of Actions, Reviews and Tasks.  If you want Actions written against an Actionable Item (AI) or Team Definition to be automatically be added to your Goal:  Open an Artifact Explorer > Select to Common Branch > Open "Action Tracking System" > Expand down to find your AI or Team Definition > Open your Goal artifact in the ATS Editor > Select the "Workflow" tab > Expand the "Relations" section > Drag your AI or Team Definition to the "AutoAddActionToGoal" relation.  > Save
+
OSEE > ATS Perspective > ATS Navigator > Select "User Search" > Select User > Select "Originator" checkbox and un-select "Assigned" > Check objects you want to search for, Workflows, Reviews or Tasks > Select Team that Action was written against, if desired > Select Search
  
[[Image:ATS_Auto_Add_Action_To_Goal.PNG|center|frame]]
+
As with any search, the more fined grained the criteria, the faster it will return and the closer to the answer you'll get.
  
== visit recently opened ATS Actions ==
+
You can also widen your search and use the advanced filtering, searching that ATS World provides to narrow in on what you're looking for.
Write or open an Action, Review or other ATS object and can't find it? Select "My Recently Visited" in the ATS Navigator to view all ATS objects viewed in the current OSEE sessionThis list gets cleared after restart.
+
 
 +
[[Image:ATS_user_search.PNG|center|frame]]
 +
 
 +
== find Actions targeted for a version ==
 +
There is an easy way to show all Actions that were targeted for a version associated with a team.
 +
 
 +
OSEE > ATS Perspective > ATS Navigator > Expand "Versions" > Select "Workflows Targeted-For Version > Select your Team > Select your version.
 +
 
 +
This will open an ATS World to show all the Workflows in that version.
 +
 
 +
= ATS Navigator - How do I... =
 +
== show open ATS objects you are assigned to ==
 +
Select the world icon or select "My World" in the list to show all workflows, tasks and reviews you are assigned to.
 +
 
 +
== show ATS objects that you have marked as your favorites ==
 +
In the ATS Editor, you can select the yellow star in the menu bar and in ATS World, you can select items > right-click > Add to Favorites. This will mark these items as your favorites.
 +
 
 +
In the ATS Navigator, you can select the yellow star in the toolbar or "My Favorites" in the list.  This will open an ATS World view of all items you have marked.
 +
 
 +
== show a Change Report managed by an ATS workflow ==
 +
If you have created a branch or committed changes via ATS, you can easily open a Change Report by selecting the "Open Change Report by ID" > enter in ATS Id.  Change Report for that ATS Workflow will open.
 +
 
 +
You can also select the "Open Change Report(s) by ID(s)" in the list to perform the same operation.
 +
 
 +
== open all ATS objects related to the entered ATS Id ==
 +
Select the "ID" toolbar icon > Enter in an ATS Id or a Legacy PCR Id or a guid.  All items matching that id will be opened in ATS World.  You can also open multiple items by entering in a comma delimited list of Ids.
 +
 
 +
= ATS Emailing - How do I... =
 +
 
 +
== email team leads / members ==
 +
ATS Team Definitions are configured with Team Leads, who automatically get assigned an Action when it's created, and Team Members, who have have extra configurations and permissions to operate on Team Workflows.
 +
 
 +
In addition, ATS has a feature that enables you to easily email Team Members, Team Leads or both.
 +
 
 +
Open OSEE > ATS Perspective > ATS Navigator > type "email" in filter box > You will see "Email Team Leads/Members", "Email Team Leads" and "Email Team Members".  Select one of these > Select Team > Select "Include all children Team Definition Actions" if you wish > select "ok" > OSEE will open your configured mailtool with the appropriate email addresses based on your selection.
 +
 
 +
== email groups of users ==
 +
OSEE has a User Group artifact type with a Users relationCreate this artifact on the common branch and drag in User artifacts to this relation.  Then, from ATS, Select "Email User Groups" and select the appropriate group.  Osee will open your configured mail tool with the related User's email addresses.
 +
 
 +
== email message to a set of workflow assignees or originator ==
 +
Select "Email Message to Action(s) Assigness or Originator from the ATS Navigator > Drag in the Team Workflows, Tasks or Reviews into the "ATS Workflows" box > enter a subject > select the recipient (Assignees or Originator) > Enter the body of the message > Select Run.
 +
 
 +
The appropriate users will receive an email with your subject and message and the list of workflows that you selected which the user is an assignee or originator.
  
= Action View - How do I... =  
+
= ATS Action View - How do I... =  
  
 
== show a graphical representation of Action, Workflows, Tasks and Reviews ==
 
== show a graphical representation of Action, Workflows, Tasks and Reviews ==
Line 95: Line 164:
 
[[Image:ATS_actionViewIcon.PNG|center|frame]] [[Image:ATS_actionView.PNG|center|frame]]
 
[[Image:ATS_actionViewIcon.PNG|center|frame]] [[Image:ATS_actionView.PNG|center|frame]]
  
= ATS Workflow Editor =  
+
= ATS Workflow Editor - How do I...=  
  
 
== add a new impact/Team Workflow to an action ==
 
== add a new impact/Team Workflow to an action ==
Line 162: Line 231:
  
 
= Editors - How do I...=
 
= Editors - How do I...=
 +
 +
== easily maximize and minimize the current editor or view ==
 +
Within the current editor or view, select Ctrl-M to maximize.  Select again to minimize.
 +
 +
== switch to different open editor ==
 +
Ctrl-Shift-E shows a dialog of all open editors with editor name and file path, if applicable.  Options to select editor to open, close all editors and save selected editors.
  
 
== restore changes or deleted files from local history ==
 
== restore changes or deleted files from local history ==

Revision as of 17:58, 5 February 2014

Contents

OSEE Application - How do I...

open, close and customize perspectives

http://www.tutorialspoint.com/eclipse/eclipse_perspectives.htm

navigate the OSEE specific perspectives

OSEE has a number of perspectives based on the included applications. All perspectives can be accessed through Window pulldown > Open Perspective. To easily navigate through OSEE developed perspectives, select the OSEE pulldown and select your desired perspective.

change OSEE icon in toolbar based on which workspace is open

Once you have gotten used to running one OSEE, you'll realize that you can run 2 or more. Or, if your a developer of OSEE applications, then you could have one for development, another for run-time testing and another for production use. It can get confusing to figure out which to switch to in a windowing environment.

OSEE provides the ability to override the icon shown in the Windows toolbar.

OSEE > ATS or Define Perspective > Enter "icon" in the navigator > Select "Set Workbench Override Icon". > This opens an editor where you can select a 32x32 image to use as the application icon. > Select Run.

You'll now see that icon in the top left of your workbench and in the windowing toolbar.

Here are a few that you can use

Osee 32.png
Osee 32 dev.gif
Osee 32 dev run.gif
Osee 32 rc.gif
Osee 32 rc run.gif
Osee 32 rel.gif
Osee 32 rel run.gif
Osee 32 src.gif
Osee 32 src run.gif

Branch Manager - How do I...

show artifact / action related to selected branch

Branch Manager > Select Branch > Open Associated Artifact > This will either open the Action or show the User that created the branch.

quickly open an Artifact Explorer from selected branch

Branch Manager > Double-click branch > This opens an Artifact Explorer to the branch selected

show baseline branches first

When OSEE starts collecting many Baseline and Working branches, it may be nice to see the Baseline branches first before all the Working branches. By creating a Table Customization from the branch manager, this view and any branch selection dialog will sort/filter based on your saved and defaulted selection.

Sort and filter Branch Manager as you wish > Select Table Customization > Select Save Customization > Enter in customization name eg "Baseline First" > Select saved customization on left > select "Set as Default" > Select Ok in dialog.

BranchManager baselineBranchFirst.PNG

Artifact Explorer - How do I...

show more information, like attribute values, on each artifact?

You can show artifact types, versions and even valid attributes next to the name of the artifacts on a branch in Artifact Explorer. Simply use the white pulldown to select items you want to show. If you want to save these selections for future Artifact Explorers, just select "Store Label Settings".

ArtifactExplorer showMoreInfo.PNG

quickly open a new Artifact Explorer?

You can open a new Artifact Explorer using the "Open Artifact Explorer" button on the top right of the Artifact Explorer. It will open the new Explorer to the same branch as the one open.

ArtifactExplorer openNewExplorer.PNG

open the Action associated to the selected branch?

For branches that were created from an ATS Action, the "Open Associated Action" button will open those Actions in ATS. If a branch was created manually by a user, it will show a dialog of the user that created the branch.

ArtifactExplorer openAssociatedAction.PNG

open the selected artifact in another branch?

There is an easy way to open the selected artifact on another branch. Select that artifact > right-click > Reveal on Another Branch. This will open another Branch Manager and reveal the artifact on that branch.

ArtifactExplorer revealOnAnotherBranch.PNG

quickly search the currently selected branch?

Select the "Open Quick Search View" button. This will open the Quick Search view, set the selected branch to the same as the Artifact Explorer and place your cursor in the Search text box.

ArtifactExplorer Quick Search.PNG

ATS - How do I...

understand the difference between an action and workflow

ATS was designed to be 100+ PCRs systems in one. You can write an action against one thing, and then add new workflows as you learn all the teams and products that are impacted for that action.

The "Action" is the top object that groups all the "Team Workflows (workflow)" that have work to be done.

A good example is a bug found in a software product. You can write an action against the "code" and you will get the "action" object and the "team workflow" object created. The "Team Workflow" is where the work is done by the Code Team. Now, let's say the coder determines that the problem isn't a code issue, but a requirements one. You can add a new "Team Workflow" to the existing action against the "requirements". You now have one "action" object and 2 "Team Workflows". You can then cancel the Code workflow with a note that it's a requirements issue. Now, the requirements are changing which requires a test fix. You can add a Test "Team Workflow". And, you realize that some tool changes will be needed, so you can add a Tool "Team Workflow". You now have 4 teams doing work to fix the single "bug" that was found. Each team workflow is going through it's own flow of work to complete the task.

Read more about ATS Objects

configure to automatically add new Actions to a Goal

Goal artifacts are used as an ordered list of Actions, Reviews and Tasks. If you want Actions written against an Actionable Item (AI) or Team Definition to be automatically be added to your Goal: Open an Artifact Explorer > Select to Common Branch > Open "Action Tracking System" > Expand down to find your AI or Team Definition > Open your Goal artifact in the ATS Editor > Select the "Workflow" tab > Expand the "Relations" section > Drag your AI or Team Definition to the "AutoAddActionToGoal" relation. > Save

ATS Auto Add Action To Goal.PNG

visit recently opened ATS Actions

Write or open an Action, Review or other ATS object and can't find it? Select "My Recently Visited" in the ATS Navigator to view all ATS objects viewed in the current OSEE session. This list gets cleared after restart.

ATS Searching - How do I...

search ATS for Workflows, Tasks, Reviews and Goals

There are a number of ways to search ATS for what your looking for. Searching by Id includes ATS Id, GUID (system generated unique id) or Legacy PCR Id. Using specific searches in Navigator gives more detailed search options.

ATS Searching.PNG

quickly search open ATS actions

The ATS Navigator has a quick search field to quickly find open actions. This field will not only work for text, but also ATS ids (eg ATS10001) and system ids, like guids (A61fqvlZOGa83OyWbCQA) or artifact ids (12453).

The IC checkbox stands for "Include Completed/Cancelled" (cursor over to see tooltip notation). This will include completed and cancelled actions in the search.

Remember, as with any search you want to try to limit the result set that comes back.

ATS quickSearch.PNG

find Actions that I originated

The ATS User Search provides more searching criteria that would allow you to easily find an Action that was written by a user. Once common case is finding an Action that you originated.

OSEE > ATS Perspective > ATS Navigator > Select "User Search" > Select User > Select "Originator" checkbox and un-select "Assigned" > Check objects you want to search for, Workflows, Reviews or Tasks > Select Team that Action was written against, if desired > Select Search

As with any search, the more fined grained the criteria, the faster it will return and the closer to the answer you'll get.

You can also widen your search and use the advanced filtering, searching that ATS World provides to narrow in on what you're looking for.

ATS user search.PNG

find Actions targeted for a version

There is an easy way to show all Actions that were targeted for a version associated with a team.

OSEE > ATS Perspective > ATS Navigator > Expand "Versions" > Select "Workflows Targeted-For Version > Select your Team > Select your version.

This will open an ATS World to show all the Workflows in that version.

ATS Navigator - How do I...

show open ATS objects you are assigned to

Select the world icon or select "My World" in the list to show all workflows, tasks and reviews you are assigned to.

show ATS objects that you have marked as your favorites

In the ATS Editor, you can select the yellow star in the menu bar and in ATS World, you can select items > right-click > Add to Favorites. This will mark these items as your favorites.

In the ATS Navigator, you can select the yellow star in the toolbar or "My Favorites" in the list. This will open an ATS World view of all items you have marked.

show a Change Report managed by an ATS workflow

If you have created a branch or committed changes via ATS, you can easily open a Change Report by selecting the "Open Change Report by ID" > enter in ATS Id. Change Report for that ATS Workflow will open.

You can also select the "Open Change Report(s) by ID(s)" in the list to perform the same operation.

open all ATS objects related to the entered ATS Id

Select the "ID" toolbar icon > Enter in an ATS Id or a Legacy PCR Id or a guid. All items matching that id will be opened in ATS World. You can also open multiple items by entering in a comma delimited list of Ids.

ATS Emailing - How do I...

email team leads / members

ATS Team Definitions are configured with Team Leads, who automatically get assigned an Action when it's created, and Team Members, who have have extra configurations and permissions to operate on Team Workflows.

In addition, ATS has a feature that enables you to easily email Team Members, Team Leads or both.

Open OSEE > ATS Perspective > ATS Navigator > type "email" in filter box > You will see "Email Team Leads/Members", "Email Team Leads" and "Email Team Members". Select one of these > Select Team > Select "Include all children Team Definition Actions" if you wish > select "ok" > OSEE will open your configured mailtool with the appropriate email addresses based on your selection.

email groups of users

OSEE has a User Group artifact type with a Users relation. Create this artifact on the common branch and drag in User artifacts to this relation. Then, from ATS, Select "Email User Groups" and select the appropriate group. Osee will open your configured mail tool with the related User's email addresses.

email message to a set of workflow assignees or originator

Select "Email Message to Action(s) Assigness or Originator from the ATS Navigator > Drag in the Team Workflows, Tasks or Reviews into the "ATS Workflows" box > enter a subject > select the recipient (Assignees or Originator) > Enter the body of the message > Select Run.

The appropriate users will receive an email with your subject and message and the list of workflows that you selected which the user is an assignee or originator.

ATS Action View - How do I...

show a graphical representation of Action, Workflows, Tasks and Reviews

In the ATS Workflow Editor, select the "Action View" icon at the top of the editor. This will open a graphical representation of the "Action", "Team Workflows", "Reviews" and "Tasks"

ATS actionViewIcon.PNG
ATS actionView.PNG

ATS Workflow Editor - How do I...

add a new impact/Team Workflow to an action

To add a new Team Workflow to an action, select the "Actionable Items" hyperlink at the top of the ATS Editor. On the right pane, select the other Actionable Items that are impacted. New Team Workflows will be created as needed.

ATS actionableItemsHyperlink.PNG

show a hierarchical representation of Action, Workflows, Tasks and Reviews

In the ATS Editor, select the "Open in World Editor". This will open the object starting at the "Action". Expand-all will show all items in the hierarchy.

ATS openWorldButton.PNG
ATS showHierarchical.PNG

ATS World and Task Editors - How do I...

filter out completed/cancelled items

Select the pulldown-menu next to the gear and select "Filter Out Completed/Cancelled". You can also use the Ctrl-F hotkey.

ATS filterCanceledCompletedAssignee.PNG

only show items assigned to you

Select the pulldown-menu next to the gear and select "Filter My Assignee". You can also use the Ctrl-G hotkey.

ATS filterAssignee.PNG

open selected ATS items in a new ATS World or Task View

You can easily open selected items in a World or Task View by selecting the World or Task icons in the top right of the editor. You can also right-click > Open With > and select the desired editor for the selected items.

ATS openSelectedInNewWorldEditor.PNG

ATS openSelectedInNewTaskEditor.PNG

Review - How do I...

show all review defects in readable format

The Defect table of a Peer Review only shows 5 lines by default which makes reading the defects difficult. In addition, the Description and Location columns are too narrow to see all the text. There are a few things you can do to help view this data easier.

  1. Make any column wider. Select the line between columns in header > drag the columns out to make it wider
  2. Make the table larger. Select the gray line under the table and drag down to show more rows.
Peer make table larger.jpg
  1. View the entire table with wrapped columns. Right-click anywhere in the table > select "View Table Report". This shows in an HTML format that wraps all the columns.
Peer show defects.jpg

Java Editor - How do I...

incrementally search a Java file

Open Java File > Ctrl-F (search) > Select "Incremental" checkbox > Enter text to search. This will highlight the first occurrence of what you type as you type.

JavaEditor Incremental Search.jpg

XViewer - Advanced Tree/Table Widget - How do I

The XViewer is an advanced and dynamic Tree/Table Viewer that has the filtering and sorting the capabilities of a spreadsheet while providing the users the ability to customize their table to suit their current needs and save/restore these customizations for future use by individual or group.

OSEE has used this widget in many of it's views and editors including: Branch Manager, Results Editor, ATS World Editor, ATS Task Editor, Change Report Viewer, Commit Manager, Merge Manager etc...

There are many advanced features of the XViewer that will help organize and manipulate your view of whatever you're looking at.

email, export to csv and print the contents

Select any item inside the table > right-click > View Table Report. This will open an HTML view of the data. The top left options allow for emailing, printing and exporting to csv. The export to csv will write the file to disk and open whatever application is configure to view comma separated value files, like Excel or Open Office.

XViewer viewTableReport.PNG

Editors - How do I...

easily maximize and minimize the current editor or view

Within the current editor or view, select Ctrl-M to maximize. Select again to minimize.

switch to different open editor

Ctrl-Shift-E shows a dialog of all open editors with editor name and file path, if applicable. Options to select editor to open, close all editors and save selected editors.

restore changes or deleted files from local history

OSEE stores versions of most text files as changes are made. You can access these versions to restore these changes. This includes a file or directory that was deleted. Select the file or folder in the Package Explorer > right-click > Restore from local history.

Editor restore from local history.jpg

prevent multiple editors from cluttering up your workbench

OSEE will show the '>>' indicator after 4 to 8 files are opened. You can configure your workbench to automatically close editors automatically. Select Window pulldown menu > Preferences > General > Editors > select "Close editors automatically" > enter number of editors open before auto-close.

Editor close editors automatically.jpg

Workbench - How do I...

show and open current workspace

After selecting one or more of the OSEE views and editors, you will notice that the current workspace is shown at the bottom of the workbench. You can see the full workspace path by placing your cursor over. This will open a tooltip. If you double-click this label, it will open an explorer window (OS Specific) to that location.

Workbench workspaceLocation.PNG

remove old workspaces from startup selection

If you start OSEE with multiple different workspaces, it will remember the last 5. To clear these you can go to Window > Preferences > General > Startup and Shutdown > Workspaces. You can also change the number of workspaces to remember.

Workbench workspaceHistory.PNG

learn the basics of the workbench

One of the best things a new user of OSEE can do is learn how to navigate the workbench. Switching perspectives, moving editors and views and restoring default are a critical part the efficient use of OSEE.

Select Help pulldown > Help Contents > Workbench User Guide > Getting Started

Workbench basicsOfWorkbench.PNG

go deeper into Eclipse usage

OSEE is built on the open source eclipse.org integrated extensible development environment. Learn more about Eclipse through this Eclipse IDE Tutorial