Jump to: navigation, search

Difference between revisions of "Mylyn/JIRA Connector"

 
 
(37 intermediate revisions by 8 users not shown)
Line 1: Line 1:
to come...
+
[[Category:Mylyn]]
 +
 
 +
The [http://wiki.eclipse.org/index.php/Mylyn_FAQ#What_happened_to_the_Mylyn_JIRA_Connector.3F Mylyn JIRA Connector has moved to Atlassian].
 +
 
 +
== Information for Integrators ==
 +
 
 +
The Atlassian update site distributes a feature and plug-in that with the same bundle ids as the Mylyn JIRA Connector (org.eclipse.mylyn.jira_feature) but with a higher version (3.4.0) than the latest available release of the Mylyn JIRA Connector. The stubs do not contain classes or extension points and effectively disable the Mylyn JIRA Connector.
 +
 
 +
Extensions that integrate with the Mylyn JIRA Connector need to specifiy the following version constraints in the manifest:
 +
 
 +
Require-Bundle:  org.eclipse.mylyn.jira.core;bundle-version="[3.3.2,3.4.0)",
 +
  org.eclipse.mylyn.jira.ui;bundle-version="[3.3.2,3.4.0)"
 +
 
 +
Features should specify an equivalent version match:
 +
 
 +
<import feature="org.eclipse.mylyn_feature" version="3.3.2" match="equivalent"/>
 +
 
 +
The latest release of the Mylyn JIRA Connector is available from this archive update site: download.eclipse.org/tools/mylyn/update-archive/3.3.2/v20100222-0100/extras

Latest revision as of 07:34, 26 February 2010


The Mylyn JIRA Connector has moved to Atlassian.

Information for Integrators

The Atlassian update site distributes a feature and plug-in that with the same bundle ids as the Mylyn JIRA Connector (org.eclipse.mylyn.jira_feature) but with a higher version (3.4.0) than the latest available release of the Mylyn JIRA Connector. The stubs do not contain classes or extension points and effectively disable the Mylyn JIRA Connector.

Extensions that integrate with the Mylyn JIRA Connector need to specifiy the following version constraints in the manifest:

Require-Bundle:  org.eclipse.mylyn.jira.core;bundle-version="[3.3.2,3.4.0)",
 org.eclipse.mylyn.jira.ui;bundle-version="[3.3.2,3.4.0)"

Features should specify an equivalent version match:

<import feature="org.eclipse.mylyn_feature" version="3.3.2" match="equivalent"/>

The latest release of the Mylyn JIRA Connector is available from this archive update site: download.eclipse.org/tools/mylyn/update-archive/3.3.2/v20100222-0100/extras