Skip to main content
Jump to: navigation, search

Difference between revisions of "Mylyn/FAQ"

(Eclipse support)
(Eclipse support)
Line 17: Line 17:
 
* Eclipse 3.2 and 3.3M1: partially supported.  The automatic context test suite will not work, but there should be no other limitations.
 
* Eclipse 3.2 and 3.3M1: partially supported.  The automatic context test suite will not work, but there should be no other limitations.
  
'''Older versions of Eclipse'''
 
 
'''Why doesn't the Package Explorer show hierarchy?'''
 
'''Why doesn't the Package Explorer show hierarchy?'''
  
This should only be a problem with Eclipse 3.1.  The Hierarchical layout is not supported in the Package Explorer. In the Package Explorer menu, select ''Layout -> Flat''.
+
This should only be a problem with Eclipse 3.1.  The Hierarchical layout is not supported in the Package Explorer. In the ''Package Explorer'' menu, select ''Layout -> Flat''.
  
'''When I click on a <code>.java</code> file, the right editor doesn't open!  What do I do?'''
+
'''When I click on a <code>.java</code> file, the right editor doesn't open.'''
  
 
This sometimes happens when using Eclipse 3.1.  Reset the Java editor to be default for <code>.java</code> again via: ''Preferences -> General -> Editors -> File Associations''.  Upgrading to 3.2 will also eliminate the problem.
 
This sometimes happens when using Eclipse 3.1.  Reset the Java editor to be default for <code>.java</code> again via: ''Preferences -> General -> Editors -> File Associations''.  Upgrading to 3.2 will also eliminate the problem.

Revision as of 18:19, 11 December 2006


Mylar User Guide, Mylar Home, Log in to edit

Contents

Setup

For instructions on downloading installing and configuring Mylar, see the Mylar User Guide

Eclipse support

What versions of Eclipse does Mylar work with?

While Mylar dev builds are built against the 3.3 stream of Eclipse, we will try to maintain as much compatibility with Eclipse 3.2 for as long as possible. The current compatibility status is:

  • Eclipse 3.3M2 and 3.3M3: fully supported.
  • Eclipse 3.2 and 3.3M1: partially supported. The automatic context test suite will not work, but there should be no other limitations.

Why doesn't the Package Explorer show hierarchy?

This should only be a problem with Eclipse 3.1. The Hierarchical layout is not supported in the Package Explorer. In the Package Explorer menu, select Layout -> Flat.

When I click on a .java file, the right editor doesn't open.

This sometimes happens when using Eclipse 3.1. Reset the Java editor to be default for .java again via: Preferences -> General -> Editors -> File Associations. Upgrading to 3.2 will also eliminate the problem.

Java Support

Mylar needs the Java 5 virtual machine. (You do not need to compile with the 1.5 compiler, just to run with the 1.5 VM.)

To check the version of the Java virtual machine that Eclipse was launched with to to Help -> About Eclipse SDK -> Configuration Details and verify that the java.vm.version is 1.5.

Mac users should refer to the last comment on bug 1163477 for instructions on how to change the 1.4 default.

  • If you do not have Java 5, you can download it from Sun's web site.
  • If you have more than one VM, you need to specify that Eclipse should use the JDK1.5 VM.

In Unix, set the environment variable JAVA_HOME to the root of the JDK1.5 installation and/or set the PATH variable to put the JDK1.5 executable directory before any other VM executable directories. For example, under bash in Unix:

export JAVA_HOME="(location of JDK1.5 root)"
export PATH=$JAVA_HOME/bin:$PATH


We do not recommend using JDK 1.6 on Eclipse 3.1. (It works fine with Eclipse 3.2 or 3.3.) To use JDK 1.6 on Eclipse 3.1, you must add the following line to your config.ini file:

   org.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSGi/Minimum-1.1,JRE-1.1,J2SE-1.2,
   J2SE-1.3,J2SE-1.4,J2SE-1.5,JavaSE-1.6

Web Browser Support

You need a web browser that works with the Standard Widget Toolkit; Windows and MacOS users are fine, but Linux users might have to download another browser. See the SWT Browser guide for which browsers will work. See installing browser on Linux for installation instructions.

Installation and Configuration

Installation FAQ

I downloaded the source following the directions given on the Mylar Contributor Reference, and Eclipse says that there are errors. What do I do?

There are several possible things wrong:

  1. You don't have the latest milestone of Eclipse; download the latest stable version from Eclipse downloads. Note that the downloads page that is easiest to find will show you the latest releases, not the latest milestones.
  2. You don't have JRE 1.5 associated with this workspace. Go to Window -> Preferences -> Java -> Installed JREs -> Execution Environments and make sure that the 1.5 checkbox is checked.
  3. You don't have Jira installed, but do have the org.eclipse.mylar.tests installed. That is a separate download. See Mylar_Contributor_Reference#Workspace_setup.
  4. You have Jira installed but don't have Subclipse installed. See Mylar_Contributor_Reference#Workspace_setup.


I've downloaded Mylar; why can't I see anything different?

The two most likely possibilities are:

  1. You don't have any Mylar views open. Select Window -> Show View -> Other, then select Mylar and you should see the available Mylar Views.
  2. If you still don't see anything, then perhaps you aren't using the JDK1.5 VM (or later). See configuring Java.


What does the error "Network connection problems encountered during search" mean?

If you get that message while trying to download Mylar, it means that Eclipse couldn't find the location you entered. This might be because you copied something incorrectly (watch for extra characters -- even extra spaces can cause errors), or because the site went down. You may be able to see if the site is up or down by copying the URL into your Web browser.

What does the "Update manager failure" message mean?

It means that Eclipse could not access the update site, or that it got confused about the configuration state of your Eclipse. First try updating again to see if the update site is accessible.

If you are trying to update the JIRA connector you can also try de-selecting that feature in case the Tigris.org update site is not accessible. Using Search for new features to install.. when installing can help to avoid this problem. If that does not work see the feature configuration troubleshooting below.

What does "Could not create Browser page: No more handles (java.lang.UnsatisfiedLinkError: ...)" mean?

It probably means that you are running Linux and don't have Eclipse and a Web browser configured to work together. See installing a browser on Linux.

When downloading, why do I get a warning that the feature was unsigned? Signing plugins requires extra administrative details which most plug-in programmers seek to avoid.

What does "Root exception: java.lang.UnsupportedClassVersionError: org/eclipse/mylar/tasklist/MylarTasklistPlugin (Unsupported major.minor version 49.0)" mean?

It probably means that the virtual machine is JDK1.4 or lower. See download and configure Java.

Why am I getting messages in my <workspace>/.metadata/.log or my Mylar view that say things like "java.lang.NoSuchMethodError: org.eclipse.ui.internal.dialogs.FilteredTree.getFilterControl()" and "The activator org.eclipse.mylar.java.MylarJavaPlugin for bundle org.eclipse.mylar.java is invalid"?

This probably means that your Mylar download version didn't match your Eclipse download version. Note that the download site has different downloads for Eclipse 3.1 and Eclipse 3.2.

To fix this problem, see the uninstallation guide, then re-install from the correct download site.

What does "Could not create Bugzilla editor input" and "java.io.IOException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found" mean?

It probably means that you are on MacOS, and for some reason are missing Xerces from the Mac JDK1.5. You will probably need to add it to your default classpath. Please refer to and comment on bug 144287 if you see this problem.

To ensure that you are using the 1.5 VM refer to the last comment on bug 1163477 for instructions on how to change the 1.4 default.

Installation Troubleshooting

Download/install/update failures can include:


Mylar 0.7.0 load failure with BEA JVM (CoreException, BundleException)

There is a known problem using Mylar 0.7.0 with the BEA JVM JRocket (R26.4.0-63). Use the Sun JVM or Mylar 0.6.2 as a work-around until this can be resolved. See [bug #159706] for the current status of this issue.


Incompatible VM (e.g. JDK 1.4)

If you are using the wrong VM, you'll see errors like the following in your log file.

   Root exception: java.lang.UnsupportedClassVersionError:
   org/eclipse/mylar/tasklist/MylarTasklistPlugin (Unsupported major.minor version 49.0)

See Configure Java to fix this problem.

Incompatible version of Eclipse

Separate versions and update sites exist for Eclipse 3.1 and 3.2), in which case you may see errors like the following in your <workspace>/.metadata/.log file or in a Mylar view:

   java.lang.NoSuchMethodError: org.eclipse.ui.internal.dialogs.FilteredTree.getFilterControl()
   The activator org.eclipse.mylar.java.MylarJavaPlugin for bundle org.eclipse.mylar.java is invalid

Mylar feature configuration problem

If the above do not address the issue, the easiest thing to do is uninstall any old versions and update to the latest Mylar. Your tasks won't be lost, because by default they are stored in the <workspace>/.mylar/tasklist.xml file which will be read next time Mylar starts correctly.

  • First, uninstall the old version of Mylar using Help -> Software Updates -> Manage Configuration.
  • You need to Disable all Mylar features by right-clicking them.
  • Allow Eclipse to restart after the last is disabled.
  • After restart, ensure that the 3rd toolbar button is pressed (figure below) so that you see the disabled features to uninstall.
  • Uninstall all the disabled features using the popup menu.

If you don't uninstall, the the Update Manager will think that you have the latest and tell you that there are no updates.

Note: manually removing the plug-ins and features can lead to Eclipse configuration errors!

After uninstalling, update Eclipse by adding the correct update site specified at on the download page, and after that automatically or manually updating will install the correct version.

Mylar-eclipse-manage-configuration.gif

What do I need to do in installation to be able to use Mylar task management features with bug/task/issue trackers?

When you install, make sure that you select a connector for your bug/task/issue tracking software. For example, to use Bugzilla, you have to install the Bugzilla connector component.

Uninstall troubleshooting

On Eclipse 3.1: you may need to reset the Java editor to be default for .java again via: Preferences -> General -> Editors -> File Associations

On Eclipse 3.2: if after uninstalling content assist proposals no longer appear you need to ensure that the Java Completions and Java Types proposal categories are included in the default proposals via: Preferences -> Java -> Editor -> Content Assist -> Advanced -> Restore Defaults. Also see: Mylar FAQ#Content assist troubleshooting. This bug has been fixed in Eclipse 3.2.1.


Configuration Troubleshooting

How can I change the number of editors left open before Mylar starts closing editors?

Turn off or increase the number of editors to leave open using Preferences -> General -> Editors -> Number of opened editors before closing. Since Mylar will manage the open editors with task activation, this number can be set higher or you can disable automatic closing entirely.

Do I need the Outline View when running Mylar?

No, not really. The Package Explorer and folded signatures should provide enough context for you. If, at some point, you really need to see an Outline View, you can always enter (Ctrl+O) to show the in-place Outline View.

What does the message "content assist proposals no longer appear" mean?

This usually happens when uninstalling when using Eclipse 3.2. Make sure that the "Java Completions" and "Java Types" proposal categories are included in the default proposals via: Preferences -> Java -> Editor -> Content Assist -> Advanced -> Restore Defaults. Also see: content assist troubleshooting. This bug has been fixed in Eclipse 3.2.1.

Why do I get errors like "HTTP Response Code 407" or "Proxy Authentication Error" when accessing repositories through a proxy server?

It is likely that you need to configure these proxy server settings. Select Window -> Preferences -> Install/Update, and update the section in the "Proxy settings" section of the form.

I can't use Ctrl+Alt+Shift+Arrow Up for Mark as Landmark. What do I do?

This is usually a Linux/GNOME problem, where the Gnome keyboard shortcuts are interfering with the Eclipse shortcuts. Go to the Keyboard shortcuts (which might be something like Desktop -> Control Centre -> Keyboard Shortcuts or System -> Preferences -> Keyboard Shortcuts) and disable both of these shortcuts:

  • Move one workspace up
  • Move one workspace down

See also: keyboard mappings on Linux.

How do I turn on spell checking?

See spell checking.

Compatability

Development builds

Compatibility:

  • Eclipse 3.3 latest Milestone: full support.
  • Eclipse 3.2 and 3.3M1-M2 are partially supported and missing:
    • Type history management. Open Type list will be have the default workspace-wide rankings).
    • Automatic context test suite. If invoked an exception will appear in the log and it will not run.

Support for Eclipse Milestone and Integration builds:

  • Monday prior to Eclipse SDK milestone release: we migrate to the latest integration build and make a dev build available when done.
  • Eclipse SDK milestone release day: a Mylar dev build officially supporting the milestone is released.
  • 1 week after Eclipse SDK milestone release: a Mylar dev build supporting the milestone is released.

Dev build release schedule

Development builds are released weekly, usually on Friday, and should be used by all Mylar developers and contributors not using Mylar straight from CVS.

Integration

What about performance effects?

The goal is for Mylar to have no noticeable effect on Eclipse's speed or memory usage. You do not need to increase the amount of memory Eclipse runs with to use Mylar. Any performance issue should be reported as a bug.

The current Performance Profile is:

  1. Mylar only runs if a task is active, and has no impact on Eclipse if no task is active.
  2. Task context models have negligible memory overhead.
  3. When a task is active, additional view refresh is required to update the views based on interest model changes. This should not be noticeable on Windows where refresh is very quick, but could be more noticeable on other platforms.
  4. The time to activate a task context is dominated by the time it takes Eclipse to open the editors in the context. You can set the preference for how many editors to open in the Mylar preference page (e.g. setting to 1 will dramatically reduce activation time, but also remove the benefit of having open editors correspond to the task context). You can also turn off editor management entirely in the Mylar Tasks view pull-down.
  5. Eclipse startup is slowed down by (4) if a task is active when Eclipse is shut down.
  6. The low priority background searches that the Active Search view runs can be noticeable on slower machines.

Does the Task List replace the Eclipse Tasks view?

The SDK's Tasks view is used for showing markers such as 'todo' tags which indicate a local problem with a resource, similar to a compiler warning. As such, these 'tasks' are at a much lower level of granularity than than Mylar's tasks, and one task could involve cleaning up multiple todos. In order to make working with only the markers in a particular task context, e.g. for clean-up before committing, the Apply Mylar filter is available for both the Problems and the Tasks views.

I am seeing java.lang.OutOfMemoryError: PermGen space errors, what's wrong?

This is not a Mylar problem, but a general Eclipse problem that is often triggered on Eclipse 3.2 and later, if you have many plug-ins installed and are using a Sun JVM.

To fix it add the following to your launch arguments. This is usually to your shortcut, or to the eclipse/configuration/config.ini file:

   -XX:MaxPermSize=128M

If you are using a large number of plug-ins (e.g. WTP) you may need to increase the number to more than 128M.

Details of the problem are on Platform bug 92250.

Task Repository Connectors

What is a Connector?

A connector is code that connects a task repository (like Bugzilla, JIRA, or Trac) to Mylar. To create a connector, see Creating Mylar Connectors.

How do I encourage someone to make a connector for my repository?

First, do a search of the open repository connector requests and vote for the corresponding bug if your tracker is there, or create a new bug.

There isn't a connector for the repository I use: is there a workaround?

Yes. See unsupported repositories.

Bugzilla Connector troubleshooting

  • Bugzilla 2.18.6 is the lowest version of Bugzilla supported. If you are getting errors that indicate failure to update attributes this may be an indication that the Bugzilla server is not supported (< 2.18.6).
  • Error upon submit: unable to make any match for name/email entered. If your bugzilla is configured for user names rather than full email address the QA Contact field will cause the submit to fail (bug# 166555). Current work around is to remove the @address from the user name and submit.
  • If tasks fail to submit with credentials error, but the repository validates fine, make sure that you've correctly setup your account's username and password and are not using the HTTP authentication fields instead.
  • Sites protected by http digest authentication will fail to load bug reports (repository credential validation works). We are awaiting approval for httpclient 3.0.1 which resolves this issue (bug# 165907)
  • The times that appear in the Bugzilla bug editor (ie. created, modified) are local to the server hosting the Bugzilla repository, not your local machine's time zone.
  • We recommend using the latest release of Bugzilla.
  • If attributes are missing options in the bug editor (ie. missing a recently added milestone, bug# 155431):
    • Update attributes by choosing Update Attributes from the context menu in the Task Repositories view
    • Synchronize the task in the tasklist
    • Reopen the task - new options should be available.
  • If queries are not working correctly ensure that you have the right Bugzilla server version selected for the corresponding repository: Task Repositories (View) -> right+click the repository -> Properties. For supported versions see the download page. If the repository is still not functioning it may be due to authentication or connectivity problems. If that does not resolve the problem please post a message to the newsgroup or submit a bug.
  • If reports are failing to submit or you're missing products or components to submit to try updating the attributes for the repository via New -> New Repository Task -> select Bugzilla repository -> Update Products from Repository. Currently our support for retrieving the products/components etc. available on the server relies on the information from <your-repository-url>/config.cgi?ctype=rdf. If you are unable to access this url with your web browser then this is likely the source of problems related to missing products/configuration.
  • If reports fail to load or reports fail to synchronize (task description remains italic), check the error log for a "File not found" error pointing to bugzilla.dtd or a "Failed to retrieve products from server" error message - these result when the urlbase parameter is not set on the bugzilla server, or your bugzilla installation is missing the bugzilla.dtd file. See: bug#161759
  • If upon opening a bug, the Bugzilla tab only displays a warning "Could not download task data, possibly due to timeout or connectivity problem. Please check connection and try again.", ensure that your repository is returning xml data by pointing your browser to <your-repository-url>/show_bug.cgi?id=1&ctype=xml to show the contents of bug 1 in xml form. The Bugzilla client requires that bugs be accessible in xml form. If the repository doesn't support xml then it is likely that the repository is too old (Mylar currently supports Bugzilla 2.18 and up).
  • If attachments are failing to submit and you see that after processing the attachment, the bugzilla bug shows a size of "bytes" (no numbers), your database may be dropping the packet sending the file. On MySQL, check the max_allowed_packet directive. You may see errors like: DBD::mysql::st execute failed: Got a packet bigger than 'max_allowed_packet' bytes [for Statement "INSERT INTO attach_data (id, thedata) VALUES (38, ?)"] at /path/to/bugzilla/attachment.cgi line 993. Also, check the maximum attachment size in Bugzilla Parameters -> Attachments.
  • If you are using Bugzilla 2.18 and are getting mid-air collisions this is likely due to incorrectly formatted timestamp field in the underlying bugs database table (bug 149513). This can be resolved by upgrading to Bugzilla 2.20 or later.

JIRA Connector troubleshooting

JIRA isn't working for me.

To use JIRA, you need to install both the core and the connector. Make sure that you did that during the installation process.

Note: the JIRA SOAP/RPC services have to be running on the server. For additional details, see the Requirements on the JIRA Dashboard page. For supported versions, see the download page.

Proxy support

  • Proxy configuration will be based on the normal Java HTTP system properties, which can be configured either by launching Eclipse with -vmargs and using the following settings, or by putting these settings into the or by putting the following into the eclipse/configuration/config.ini file:
   -Dhttp.proxyHost=<host> 
   -Dhttp.proxyPort=<port>
  • Make sure that when using these settings you do not enable the proxy settings on the Install/Update preference page, since they may override these settings.
  • If you are using SSL, you will also need to set the https.proxyHost and https.proxyPort.
  • Authentication is configured with the http.proxyUser and http.proxyPassword system properties (also for SSL)

Troubleshooting

  • If you get a 503 error code verify that the SOAP/RPC interface is enabled.
  • If you get a 403 error code verify that the SOAP/RPC interface is enabled, and also check your authentication mechanism. If the server is using NTLM authentication, see bug 156937 for diagnosis steps.
  • If you see an "unrecognized priority" message in the Error Log, the problem is that the JIRA Connector does not support customized priorities so the priority value specified in that message will not correspond to the priority icons visible in the Task List.
  • If you are being prompted for your log-in credentials by the Browser tab of the task editor or the new task editor, this is because without rich editor support the connector is using the web-based UI instead of logging in on your behalf as is done with a rich task editor (bug 142869).

Known limitations

Trac Connector troubleshooting

The Trac connector offers two access methods:

  • Trac 0.9 and later: In this mode the standard Trac web interface is used for repository access. Tickets may be created and edited through a web browser.
  • XML-RPC Plugin (Trac 0.10 and later): This requires the XmlRpcPlugin (revision 1175) for Trac to be enabled for the accessed repository. The XmlRpcPlugin provides a remote interface to the Trac repository and is distributed separately from Trac (see #217). See these install instructions for requirements and documentation.

Known Problems

  • Trac 0.10.1 does not work with XML-RPC Plugin. See bug 164272 for details.

Generic Web Repository Connector troubleshooting

Generally it should work for repositories we have templates for. But for some server configurations or when creating new template it could necessary to investigate why Web Repository Connector is unable to fetch or parse query results. The easiest ways is to use wget tool (on Windows it available as a standalone command line tool and also included with Cygwin).

Run the following command:

wget -v -d -o query.log -O query.html "http://your.query.url"

Then open file query.html in the web browser and check if it show list of issues you need to fetch from the web server. If it does have correct list, then there could be a problem with query pattern used for parsing.

A popular mistake is an unmasked '?' that separates request parameters in the url). For example:

<a href="show_bug.cgi\?id\=(.+?)">.+?<span class="summary">(.+?)</span>

If query.html does not show expected list of issues you can check query.log for server responses and try to identify if server require authentication, redirecting your requests somewhere or issue any other errors.

Known Problems

  • In Mylar 1.0: if a web server responds by requesting a redirect to an absolute URL while fetching a resource, the connector falsely prepends "/" to the URL and the request will fail. The workaround is to use final url where redirect is pointing to (you can find it as describe above). See bug 167282 for details.

What if Mylar doesn't support my task/bug/issue/ticket repository?

Unsupported task repositories

If your repository does not have rich connector, all is not necessarily lost. If it has a Web interface, then you can link local task with the web page in web-based repository via the Mylar Web integration.

To see support for your repository faster, do a search of the open repository connector requests and vote for the corresponding bug if your tracker is there, or create a new bug.

In the meantime, you can work with reports via the web integration (but not with queries).

To create a task from any web-based repository:

  • Drag the URL from the address bar of the browser, or from a hyperlink in a bug listing to the Mylar Tasks view. This will create a task for the bug, link it to the page, and populate the description with the title of the corresponding page. In Mozilla: simply drag the URL. In Internet Explorer: you must have Ctrl pressed in order for Eclipse to recognize the drop.
  • Alternatively, you can copy the URL, press the New Task button on the Mylar Tasks view. This has the same effect as above but you can edit the description after retrieving it.
  • Opening the task will now open the corresponding issue. You can also right+click the task and select Open in External Browser.

Mylar-tasklist-weblink-editor.gif

Also see Generic Repository Connector

Authentication Troubleshooting

You must ensure repository credentials are filled out correctly. Refer to the diagram below:

AuthTr.png
    1. Repository Server URL and a Label for your use
    2. Credential Validation
      • usually email address and password
      • some sites, such as dev.eclipse.org, use anonymous logon with password left blank
    3. Http Authentication (optional)
      • some sites use this, requiring UserID and Password
      • there are two kinds: basic, which we support; and digest, which we currently do not support due to licencing issues
    4. Proxy Server Configuration (optional)
      • does the proxy require authentication? If so, check the box and fill in credentials.
      • if you are experiencing connection problems, by default Mylar uses the Install/Update settings you have provided to the Eclipse platform; ensure these details are filled in correctly, otherwise Mylar will use that proxy and be unable to make a connection
      • Mylar supports only HTTP proxy servers, not SOCKS
    5. Validate Settings
      • use this button to confirm settings before leaving this configuration page


Network and proxy server troubleshooting

For accessing repositories via a proxy server, Mylar uses the settings under Preferences -> Install/Update. If you are seeing errors like "HTTP Response Code 407" or "Proxy Authentication Error" it is likely that you need to configure these proxy server settings.

If your sever uses a certificate and fails to connect, e.g. you see exceptions sun.security.validator.ValidatorException: PKIX path building failed then you need to point Eclipse at your certificate, see the instructions on this blog.

Task Focused UI

Why do files disappear from Focused views when I close them?

By default Mylar automatically manages the set of open files to match the task context, so that you don't have to. This ensures that the editor list (viewable via mechanisms like Ctrl+E) corresponds to what you in views like the Package Explorer when they are in Focused mode. When you close a file manually, you express that it is uninteresting, and as such it will be removed from the task context. It will also disappear from the corresponding automatically managed change sets for the same reason. This behavior can be turned off via Preferences -> Mylar -> Context -> Manage open editors to match task context. However, it is highly recommended since Mylar will prevent the number of editors from bloating by automatically closing editors for elements that have decayed in interest, and always keep the editors for interesting elements open.

Why did all my editor tabs disappear?

When you deactivate a task, all editors will be closed, and then when you reactivate the task all the windows will be open again. Try it, it's fun.

Mylar actively manages your open editors with task context. It takes some getting used to, but enables switching between tasks when you are multitasking without cluttering your editor tabs. This editor management can be disabled via Window -> Preferences -> Mylar -> Context. However, before disabling it consider reading the "Managing open editors..." section of Task-focused programming with Mylar.

What does the "Add to Task List root" checkbox do on the new repository task editor?

Newly submitted tasks may not be caught by the Queries in your Task List.

This option allows you to specify that the newly created Task be placed in the root of the Task List, thus making it immediately visible. Otherwise, it may only reside in the Task List archive.

Why won't the Archive category disappear?

The Archive category will automatically appear if a task needs to be shown, but is not in any query or category. In order to ensure that you do not miss reminders or notifications the following tasks will always be shown in the Task List, even if they have been removed from a category or a query:

  • Tasks scheduled for this week or overdue. Remove these by using the Schedule pop-up menu option to defer them to a future week or to clear the schedule.
  • Repository tasks that have incoming changes, such as comments. Remove these by reading them or marking them as "read" via the Mark -> Read pop-up menu.

How do I prevent long-running tasks from adding to the progress bar?

If you have many long-running or recurring tasks scheduled for this week, they can affect the Task List weekly progress bar. This can be misleading as they may never be completed. The current work-around to prevent long-running tasks from being included in the weekly progress bar is to schedule their estimated time to be 0 (zero). Alternatively, you can schedule only the amount of time you plan on spending on that task this week.

Which Focused UI features can I turn off?

All of them. When no task is active neither are any of Mylar's features. When working with task contexts Mylar's Focused UI features are all optional and in general configurable.

The following table summarizes how the key features can be toggled:

UI Mechanism Example/description Toggle using
Interest filtering Package Explorer Apply Mylar button on view toolbar
Interest decoration Bolding of landmark elements Preferences -> General -> Appearance -> Label Decoration
Content assist Ranking of interesting elements Eclipse 3.2: Java -> Editor -> Content Assist -> Work in Progress -> turn off Mylar, turn on Java

Eclipse 3.1: set the Java editor to be default for .java, not the Mylar Java editor

Active change sets Grouping of changes by tasks Preferences -> Mylar -> Team
Editor management Auto opening/closing of editors Preferences -> Mylar -> Editor Management
Active views Active Search and Hierarchy Only on if view is active


For additional configuration options see the Mylar and General -> Appearance preference pages.

Java Development

Content assist troubleshooting

In Eclipse 3.2, Mylar uses extended Content Assist processors in order to rank and separate the elements in the current task context. To see proposals ranked according to interest you must have only the Type Proposals (Mylar) kinds checkbox enabled in the list below, otherwise you will see duplicates. If you do not see any proposals, check this list to ensure that either the Mylar or the plain proposals are enabled. To do this automatically, run New -> Mylar -> Recommended Preferences. Or you can select them manually as in the preference page below.

Proposals will disappear if a workspace into which Mylar was installed is run without Mylar installed (e.g. as a result of uninstalling or multiple Eclipses using same workspace, see Platform bug 140416).

If after invoking Content Assist you see an error message dialog that states "The extension took too long to return from the 'computeCompletionProposals()' operation", this is most likely due to something interrupting the proposal operation (e.g. garbage collection). Ignore it if it does not recur, increase Eclipse's memory if it does (e.g via -Xmx384M command line argument). See bug 141457 for more details.

Mylar-content-assist-prefs.gif

How can I see proposed content completions ranked according to interest?

To see proposals ranked according to interest you must be running Eclipse 3.2 (or higher) and have only the (Mylar) proposals kinds enabled in Window -> Preferences -> Java -> Editor -> Content Assist -> Advanced, otherwise you will see duplicates.

Why do interesting elements not show in the Project Explorer?

The Package Presentation -> Hierarchical mode is not supported on the Project Explorer view in Eclipse 3.2 through 3.3M3 and possibly later versions (https://bugs.eclipse.org/bugs/show_bug.cgi?id=161362 bug 161362). Use the view menu to set Package Presentation -> Flat as a work-around.

How do I stop declarations from showing in the Package Explorer?

If you don't like Mylar's constant showing of Java members in the Package Explorer, select the drop-down menu, then Filters... and enable the Mylar Java Declarations Filter. It will then stick in the menu in case you want to toggle between modes. Note that this will hide interest information about members that aren't in your current file (e.g. showing you which methods are landmarks) so this mode is not recommended, but can be useful for 1024x768 screen resolutions.

Mylar-java-filtering-declarations.gif

Why does nothing show up in the Active Search or Active Hierarchy?

As you work, elements become Landmarks (bold decoration), and these elements populate the Active Search and Active Hierarchy views. To force an element to populate the views manually, make it a Landmark by right+clicking or hitting Ctrl+Alt+Shift+UpArrow.

Team Support

Why do files disappear from the change set when I close them?

If you have the Preferences -> Mylar -> Context -> Manage open editors to match task context option enabled, Mylar will perform editor management so that you don't have to. Closing a file makes it less interesting, and causes it to disappear from the active task context, and hence from the change set. This option prevents you from having to manage the set of open files, will automatically close editors for files that become uninteresting, and will ensure that the open editors match the task context.

Why is interest lost when I retrieve someone else's context?

To identify elements within a project, Mylar relies on the name of the project being consistent across workspaces. If the project name in the workspace that the context was created with is different than its name in your workspace, the task context will not show elements within that project (bug 164058). The work-around is to use the same project names across your team's workspaces.

The other case where context can be lost is if the elements change names outside of the workspace ( bug 164243).

Integration with other tools

Using Mylar with WTP

Context modeling works at the file level, noting the limitation of bug 144882: interest filter fails on WTP Dynamic Web Project

Maven and other external builders

If an external builder like Maven is producing output files that are being automatically added to your context because they are not being marked "derived" as with Eclipse-based builders. You can explicitly exclude these folders via the Preferences -> Mylar -> Resources page. For example, if the output folder of the builder is "target", you could set this the following way:

Mylar-resource-exclusion.gif

SVN integration via Subversive

Refer to Polarion's Mylar Integration Quick Start

NOTE: For release 0.9.2 and 1.0.0 the a Mylar integration plug-in must be downloaded from the Subversive update site.

SVN integration via Subclipse

For 1.0.0 the a Mylar integration plug-in must be downloaded from the Subclipse update site: http://subclipse.tigris.org/update_1.2.x

How can I contribute to the Mylar project?

See the Mylar Contributor Reference and the Mylar Integrator Reference.

Key Limitations

  • Bug 106678: The Project Explorer's Hierarchical Java package presentation layout is not supported on Eclipse 3.3Mx, and interesting elements will be hidden if enabled. Work-around is to use the default Flat package presentation.

Back to the top