Skip to main content
Jump to: navigation, search

Mylar FAQ2

Revision as of 18:04, 11 December 2006 by Taivo.cs.ubc.ca (Talk | contribs) (Tasks and Repositories)

Mylar User Guide, Mylar Home, Log in to edit








Content assist

Why don't I see any content completion proposals?

Check to make sure that either the Mylar or the plain proposals are enabled. Select Window -> Preferences -> Java -> Editor -> Content Assist -> Advanced and make sure that there is at least one of the boxes is checked in the list labelled "Select the proposal kinds contained in the 'default' content assis list". . (See the images at the end of this section.)

Proposals will also not show up if a workspace into which Mylar was once installed is later run without Mylar installed (e.g. as a result of uninstalling or multiple Eclipses using same workspace. See Platform bug 140416).

Why do I get an error message dialog that says "The extension tool too long to return from the 'computeCompletionProposals()' operation" after invoking content assist?

This is most likely due to something interrupting the proposal operation (e.g. garbage collection). If it doesn't happen again, you can ignore it. If it keeps happening, increase Eclipse's memory (e.g via -Xmx384M command line argument). See bug 141457 for more details.

How can I see proposed content completions ranked according to interest?

To see proposals ranked according to interest you must be running Eclipse 3.2 (or higher) and have only the (Mylar) proposals kinds enabled in Window -> Preferences -> Java -> Editor -> Content Assist -> Advanced, otherwise you will see duplicates.

(Note: the following image has been cropped for space reasons. The actual Preferences panel is much bigger, and has two selection boxes.)

Mylar-content-assist-prefs.gif


Integration with other tools

Mylar relies on Bridges to integrate the context model with the structure and UI features of domain-specific tools. The core set of Bridges supports the Eclipse SDK (i.e. has bridges for Java, JUnit, PDE, Ant and Resources). The Resources Bridge enables a basic level of interoperability with other tools that use files (e.g. .php, .cpp), and enables Mylar filtering to work for generic views that shows those files (i.e. the Project Explorer, Navigator) and any corresponding markers (i.e. the Problems and Tasks views). This is only the most basic context model integration, and does not offer the benefits of a specialized structure bridge, such as making declarations part of the context and providing Active Search facilities. Without a bridge Mylar also can not be applied to tool-specific views.

If you would like to see support for a particular tool, first do a search of the open bridge requests and vote for the corresponding bug if your tool is there, or create a new bug. Also consider adding your experiences to the FAQ sections below.

Contributing

I tried to download the source following the directions given on the Mylar Contributor Reference, and Eclipse says that there are errors. What do I do?

There are several possible things wrong:

  1. You don't have the latest milestone of Eclipse; download the latest stable version from the "all downloads" page. Note that the downloads page that is easiest to find will show you the latest releases, not the latest milestones.
  2. You don't have JRE 1.5 associated with this workspace. Go to Window -> Preferences -> Java -> Installed JREs -> Execution Environments and make sure that the 1.5 checkbox is checked.
  3. You don't have Jira installed, but do have the org.eclipse.mylar.tests installed. That is a separate download. See Mylar_Contributor_Reference#Workspace_setup.
  4. You have Jira installed but don't have Subclipse installed. See Mylar_Contributor_Reference#Workspace_setup.

Key Limitations

What limitations does Mylar have?

Older versions of Eclipse

Why doesn't the Package Explorer show hierarchy?

This should only be a problem with Eclipse 3.1. The Hierarchical layout is not supported in the Package Explorer. In the Package Explorer menu, select Layout -> Flat.

When I click on a .java file, the right editor doesn't open! What do I do?

This sometimes happens when using Eclipse 3.1. Reset the Java editor to be default for ".java" again via: Preferences -> General -> Editors -> File Associations. Upgrading to 3.2 will also eliminate the problem.

Back to the top