Jump to: navigation, search

Difference between revisions of "Modeling Project Releng/Releasing/Update Site Generation/Troubleshooting"

m (How do I fix this?)
m (How do I fix this?)
Line 36: Line 36:
 
===How do I fix this?===
 
===How do I fix this?===
  
* Back out the last site update (you can also use [http://dev.eclipse.org/viewcvs/index.cgi/releng-common/tools/scripts/buildUpdateSiteRollback.sh?root=Modeling_Project&content-type=text%2Fplain&view=co buildUpdateSiteRollback.sh]:
+
* Back out the last site update (you can also use [http://dev.eclipse.org/viewcvs/index.cgi/releng-common/tools/scripts/buildUpdateSiteRollback.sh?root=Modeling_Project&content-type=text%2Fplain&view=co buildUpdateSiteRollback.sh]):
  
 
  ssh '''''you'''''@emft.eclipse.org "
 
  ssh '''''you'''''@emft.eclipse.org "

Revision as of 00:53, 10 May 2008

Question

I just took a look at my promote log, and it seems everything went OK. However, I can't see my jars promoted to http://download.eclipse.org/releases/ganymede/staging/. What happened?

Answer

  • Check the log -- yes, no obvious problems like "permission denied" or "failed" or "could not".
[java] ERROR [0035] : No suitable provider for component (...) was found in searchPath org.eclipse.emft-search-sc
[java] ERROR [0035] : Rejecting provider site.feature(${downloads}/modeling/emft/updates/interim/site-ganymede.xml): 
   No component match was found

... for these missing features:

org.eclipse.emf.search.sdk:site.feature/[0.7.0.v200805020316,0.7.0.v200805020316]#OSGi
org.eclipse.uml2.search:site.feature/[0.7.0.v200805020316,0.7.0.v200805020316]#OSGi
org.eclipse.emf.ecoretools.diagram.search:site.feature/[0.7.0.v200805020316,0.7.0.v200805020316]#OSGi
org.eclipse.uml2.diagram.clazz.search:site.feature/[0.7.0.v200805020316,0.7.0.v200805020316]#OSGi
org.eclipse.emf.search:site.feature/[0.7.0.v200805020316,0.7.0.v200805020316]#OSGi
org.eclipse.emf.search.sdk_0.7.0.HEAD.jar
org.eclipse.uml2.diagram.clazz.search_0.7.0.HEAD.jar
org.eclipse.uml2.search_0.7.0.HEAD.jar
org.eclipse.emf.search.examples_0.7.0.v200805020316.jar
org.eclipse.emf.ecoretools.diagram.search_0.7.0.HEAD.jar
org.eclipse.emf.search_0.7.0.HEAD.jar

If you intend to build from HEAD and have already enabled forceContextQualifier in your buildAll.xml, it looks like the problem is that only ONE feature jar was added. Checking the site.xml, we see that in fact only the examples feature was added.

Why? Because your promoteToEclipse.*.properties file is not using the new signed Master zip as input to the site generation script.

How do I fix this?

ssh you@emft.eclipse.org "
  cd /var/www/html/modeling/emft/updates/interim; 
  rm -fr emft-search-0.7-I_r0; 
  mv emft-search-0.7-I_r1 emft-search-0.7-I_r0; 
  mv emft-search-0.7-I_r2 emft-search-0.7-I_r1;
";
ssh you@dev.eclipse.org "
  cd /home/data/httpd/download.eclipse.org/modeling/emft/updates/interim; 
  rm -fr emft-search-0.7-I_r0; 
  mv emft-search-0.7-I_r1 emft-search-0.7-I_r0; 
  mv emft-search-0.7-I_r2 emft-search-0.7-I_r1;
";
  • Rerun the last site update:
ssh lbigearde@emft.eclipse.org "
  cd /home/www-data/build/modeling/scripts; 
  ./promoteToEclipse.sh -sub search -Q -jarsonly -branch 0.7.0 -buildID I200805020316 -coordsite ganymede
";
http://build.eclipse.org/ganymede/ 
  -> click Cruise Control 
    -> click the "Force Build" icon on the right-hand side of the ganymatic-R3.0-I status line