Difference between revisions of "Modeling Project Releng/Building/Test on 64-Bit"

From Eclipsepedia

Jump to: navigation, search
(New page: As discussed in {{bug|253114}}, here's how to make your Modeling build run on modeling.eclipse.org (a 64-bit SLES 11 virtual server): == Step 1: relengbuildgtk.sh == * First, add smarter...)
 
(Step 1: relengbuildgtk.sh)
 
(One intermediate revision by one user not shown)
Line 3: Line 3:
 
== Step 1: relengbuildgtk.sh ==
 
== Step 1: relengbuildgtk.sh ==
  
* First, add smarter platform arch detection. Replace this:
+
* Add smarter platform arch detection. Replace this:
  
 
  arch=x86
 
  arch=x86
Line 31: Line 31:
 
  exit 1 ;;
 
  exit 1 ;;
 
  esac
 
  esac
 
* Next, replace or add this so that swt jars are on classpath explicitly when running tests
 
 
# add swt jars
 
cpAndMain=`find eclipse/ -name "org.eclipse.swt_*.jar" | sort | head -1`":"$cpAndMain;
 
cpAndMain=`find eclipse/ -name "org.eclipse.swt.gtk.linux.${arch}_*.jar" | sort | head -1`":"$cpAndMain;
 
  
 
== Step 2: build/_common.php ==
 
== Step 2: build/_common.php ==
Line 47: Line 41:
 
== Step 3: build/index.php or start.sh ==
 
== Step 3: build/index.php or start.sh ==
  
* Make sure that as input to the build, you specify the linux-gtk-x86_64 Eclipse SDK, not the linux-gtk.
+
* Make sure that as input to the build, you specify the linux-gtk-x86_64 Eclipse SDK, not the linux-gtk version.

Latest revision as of 17:41, 12 May 2009

As discussed in bug 253114, here's how to make your Modeling build run on modeling.eclipse.org (a 64-bit SLES 11 virtual server):

[edit] Step 1: relengbuildgtk.sh

  • Add smarter platform arch detection. Replace this:
arch=x86

with this:

arch=x86
if uname -m > /dev/null 2>&1; then
	arch=`uname -m`
else
	arch=`uname -p`
fi
# Massage arch for Eclipse-uname differences
case $arch in
	i[0-9]*86)
		arch=x86 ;;
	ia64)
		arch=ia64 ;;
	ppc)
		arch=ppc ;;
	ppc64)
		arch=ppc ;;
	x86_64)
		arch=x86_64 ;;
	*)
	echo "ERROR: Unrecognized architecture:  $arch"
	exit 1 ;;
esac

[edit] Step 2: build/_common.php

  • Set a 5.0 or 6.0 JVM, and ensure your BREEs are correctly set in all your MANIFEST.MF files to avoid accidentally forcing users to need a 5.0 or 6.0 JVM, if you have plugins which can run on an older VM.
      "modeling.eclipse.org=------------,------------",
      "3.5.0=HEAD,/opt/sun-java2-6.0_64",

[edit] Step 3: build/index.php or start.sh

  • Make sure that as input to the build, you specify the linux-gtk-x86_64 Eclipse SDK, not the linux-gtk version.