Jump to: navigation, search

Difference between revisions of "MoDisco/Installation"

(Updating the latest release link.)
(Removed link which is only directing back to the current site)
(30 intermediate revisions by 7 users not shown)
Line 1: Line 1:
<div style="float: right;  
+
<div style="float: right;">[[Image:Egg-incubation.png]]</div>
">[[Image:Egg-incubation.png]]</div>
+
  
= Using Modeling Package  =
+
MoDisco is implemented as a set of plug-ins which have to be installed into an already installed Eclipse SDK.
The Modeling Package (one of the Eclipse pre-packaged distributions) offers a direct access to install MoDisco.
+
<br><br>
+
[[Image:install-modeling.PNG]]
+
<br><br>
+
Follow the [[MoDisco/InstallationModelingPackage|step-by-step instructions]].
+
  
= Using MoDisco Update Site =
+
= Using Eclipse Release Update Site (recommended) =
  
To install the latest MoDisco release, just point your [http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-129.htm Install Manager] to the following site:  
+
To install the latest MoDisco release, just point your [http://help.eclipse.org/indigo/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-129.htm Install Manager] to the pre-defined Eclipse simultaneous release update site: http://download.eclipse.org/releases/__release_name__. For instance:
 +
* in Eclipse 3.6 (Helios), the installation update site is:  http://download.eclipse.org/releases/helios/
 +
* in Eclipse 3.7 (Indigo), the installation update site is:  http://download.eclipse.org/releases/indigo/
 +
* in Eclipse 4.2 (Juno), the installation update site is:  http://download.eclipse.org/releases/juno/
 +
* in Eclipse 4.3 (Kepler), the installation update site is: <span style="font-size:large; padding: 0 5px 0 5px; background-color:#ffbf00; border-color:green">http://download.eclipse.org/releases/kepler/</span>
  
*Location:  <span style="font-size:large; padding: 0 5px 0 5px; background-color:#ffbf00; border-color:green">http://download.eclipse.org/modeling/mdt/modisco/updates/release/</span>
+
Then, you can select the "'''MoDisco SDK'''" feature under the "'''Modeling'''" category.
  
To get more details about the MoDisco update site, please visit the following page: [[MoDisco/Updates]].
+
= Using Modeling Package Installer =
 +
The Modeling Package (one of the [http://www.eclipse.org/downloads/ Eclipse pre-packaged distributions]) offers a direct access to install MoDisco.
 +
<br><br>
 +
[[Image:install-modeling.PNG]]
 +
<br><br>
 +
Follow the [[MoDisco/InstallationModelingPackage|step-by-step instructions]].
  
= Downloading zip  =
+
= Using MoDisco Update Site to get an alternative version =
  
'''Latest release: ''' [http://www.eclipse.org/modeling/download.php?file=/modeling/mdt/modisco/downloads/drops/0.8.1/R201009160321/MODISCO-Update-0.8.1.zip <span style="font-size:large; padding: 0 5px 0 5px; background-color:#ffbf00; border-color:green">MoDisco 0.8.0</span>]
+
To install an alternative MoDisco release, just point your [http://help.eclipse.org/indigo/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-129.htm Install Manager] to one of the following update sites:  
  
To install a zip version of MoDisco, use the [http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-129.htm Install Manager]:
+
* Releases (current and old versions): http://download.eclipse.org/modeling/mdt/modisco/updates/release/
* click "Help > Install New Software"
+
* Milestones for 0.10 : http://download.eclipse.org/modeling/mdt/modisco/updates/milestones/0.10 (Juno)
* click Add...
+
** Aggregated update site containing all the 0.10.0 milestones
* select "Archive..."
+
* Milestones for 0.11 : http://download.eclipse.org/modeling/mdt/modisco/updates/milestones/0.11 (Kepler)
* choose the zip file you have previously downloaded
+
** Aggregated update site containing all the 0.11.0 milestones
  
It is also possible to download zips for other versions of MoDisco from the [http://www.eclipse.org/MoDisco/downloads/ downloads page].
+
/!\ Those update sites contains plug-ins having dependencies to (non SDK) EMF Facet plug-ins. You have to add an [[EMF_Facet]] update site in your available update site list.
  
If you want to try the version 0.9 you may need to install Eclipse 3.7. It is available here:
+
== Update site uses ==
http://download.eclipse.org/eclipse/downloads/
+
  
== Required Configuration  ==
+
The '''release''' update site :
 +
* contains the release (GA) and the service releases (SR1, SR2, etc.)
 +
* should be used by all regular users
  
If you want to download and install MoDisco manually (without using the update manager), the following projects must already be installed inside your Eclipse:
+
The '''milestones''' update sites:
 +
* contain the milestones and release candidates: M1, M2, M3, M4, M5, M6, M7, RC1, RC2, RC3, RC4 (=GA), SR1 RC1, SR1 RC2, SR1 RC3, SR1 RC4 (=SR1), SR2 RC1, SR2 RC2, SR2 RC3, SR2 RC4 (=SR2)
 +
* must be referenced by the builds of other Eclipse projects
 +
* are referenced by the [http://dev.eclipse.org/viewsvn/viewvc.cgi/org.eclipse.indigo.build/mdt-modisco.b3aggrcon?view=markup&root=Callisto Indigo b3aggrcon file] and the [http://dev.eclipse.org/viewsvn/viewvc.cgi/org.eclipse.juno.build/mdt-modisco.b3aggrcon?view=markup&root=Callisto Juno b3aggrcon file].
  
=== 0.8.0  ===
+
The '''nightly''' update sites:
 +
* contain the build of the SVN head (latest SVN revision)
 +
* can be used to test a not-yet-released feature or bug fix
 +
* '''must not be used to build any product release'''
 +
* should be used by ''integration'' builds of the other release train members a few days before the milestones and release candidates to detect bugs or regressions.
  
*Java 5 (or higher) version of the Java virtual machine
+
= Using zip version of update sites (not recommended)=
*[http://www.eclipse.org/helios/ Eclipse "Helios" 3.6]
+
*[http://www.eclipse.org/modeling/emf/downloads/?project=emf EMF 2.6]
+
*[http://www.eclipse.org/modeling/m2t/downloads/?project=acceleo Acceleo 3.0]
+
*[http://www.eclipse.org/modeling/mdt/downloads/?project=uml2 UML2 3.0]
+
*[http://www.eclipse.org/modeling/m2m/downloads/index.php?project=atl ATL 3.1]
+
*[http://www.eclipse.org/modeling/emf/downloads/?project=compare EMF Compare 1.1]
+
*[http://www.eclipse.org/modeling/m2t/downloads/?project=jet JET 1.2]
+
  
=== 0.7.1  ===
+
You can download the archive of the MoDisco updates sites from the [http://www.eclipse.org/MoDisco/downloads/ MoDisco download page] but '''you will have to resolve the dependencies and find the corresponding archived updated sites manually'''. The MoDisco team does not provide the list of archived update sites needed to satisfy the dependencies, because it is too complicated to maintain. That's why '''this kind of installation is not recommended'''.  
  
*Java 5 (or higher) version of the Java virtual machine
+
{{MoDisco}}
*[http://www.eclipse.org/galileo/ Eclipse "Galileo" 3.5]
+
[[Category:MoDisco]]
*[http://www.eclipse.org/modeling/emf/downloads/?project=emf EMF 2.5]  
+
*[http://www.eclipse.org/modeling/mdt/downloads/?project=uml2 UML2 3.0]
+
*[http://www.eclipse.org/modeling/m2m/downloads/index.php?project=atl ATL 3.0]
+
*[http://www.eclipse.org/modeling/emf/downloads/?project=compare EMF Compare 1.0]
+
*[http://www.eclipse.org/modeling/m2t/downloads/?project=jet JET 1.0]
+

Revision as of 05:20, 15 August 2013

Egg-incubation.png

MoDisco is implemented as a set of plug-ins which have to be installed into an already installed Eclipse SDK.

Using Eclipse Release Update Site (recommended)

To install the latest MoDisco release, just point your Install Manager to the pre-defined Eclipse simultaneous release update site: http://download.eclipse.org/releases/__release_name__. For instance:

Then, you can select the "MoDisco SDK" feature under the "Modeling" category.

Using Modeling Package Installer

The Modeling Package (one of the Eclipse pre-packaged distributions) offers a direct access to install MoDisco.

Install-modeling.PNG

Follow the step-by-step instructions.

Using MoDisco Update Site to get an alternative version

To install an alternative MoDisco release, just point your Install Manager to one of the following update sites:

/!\ Those update sites contains plug-ins having dependencies to (non SDK) EMF Facet plug-ins. You have to add an EMF_Facet update site in your available update site list.

Update site uses

The release update site :

  • contains the release (GA) and the service releases (SR1, SR2, etc.)
  • should be used by all regular users

The milestones update sites:

  • contain the milestones and release candidates: M1, M2, M3, M4, M5, M6, M7, RC1, RC2, RC3, RC4 (=GA), SR1 RC1, SR1 RC2, SR1 RC3, SR1 RC4 (=SR1), SR2 RC1, SR2 RC2, SR2 RC3, SR2 RC4 (=SR2)
  • must be referenced by the builds of other Eclipse projects
  • are referenced by the Indigo b3aggrcon file and the Juno b3aggrcon file.

The nightly update sites:

  • contain the build of the SVN head (latest SVN revision)
  • can be used to test a not-yet-released feature or bug fix
  • must not be used to build any product release
  • should be used by integration builds of the other release train members a few days before the milestones and release candidates to detect bugs or regressions.

Using zip version of update sites (not recommended)

You can download the archive of the MoDisco updates sites from the MoDisco download page but you will have to resolve the dependencies and find the corresponding archived updated sites manually. The MoDisco team does not provide the list of archived update sites needed to satisfy the dependencies, because it is too complicated to maintain. That's why this kind of installation is not recommended.


MoDisco
Components Infrastructure: KDM · SMM · GASTM · Model Browser · Discovery Manager · MoDisco Workflow · Query Manager · Facet Manager · Metrics Visualization Builder · KDM Source Extension
Technologies: Java · JEE · EjbJar · WebApp · XML
Use Cases: Simple Transformation Chain · Model Filter
Help Installation · SVN
Project API Policy · Retention Policy · Project Plan · metrics · Accessibility Guidelines · Capabilities Disablement