Skip to main content
Jump to: navigation, search

MoDisco/Components/JeeWebApp/Documentation/0.9

< MoDisco‎ | Components‎ | JeeWebApp
Revision as of 06:51, 27 May 2010 by Nguyomar.sodifrance.fr (Talk | contribs) (Initial Commit)

DEPRECATED use Template:MoDiscoTabs and Template:MoDiscoTab as explain here : Wiki Template for MoDisco

Web Application Deployment Metamodel

web-xml.xml files conform to Sun/Oracle DTD or XSD, depending of the version of the framework : 1.1, 2.0, 2.1, 3.0, 3.1 (see http://java.sun.com/xml/ns/javaee/). MoDisco proposes related ecore definitions and Java implementations for these various descriptions.

Requirements

To use the plug-in you need:

  • JDK 1.5 or above
  • a version of Eclipse 3.3 or above with the following set of plug-ins installed
  • EMF 2.3.0 or higher

Source Repository

All of the source code is stored in a public source repository, which you can access at:

https://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.modisco/plugins/trunk/org.eclipse.gmt.modisco.jee.webapp/

Web Application Deployment Discoverer

Back to the top