Skip to main content
Jump to: navigation, search

Menu Contributions

Revision as of 09:51, 18 October 2006 by Pwebster.ca.ibm.com (Talk | contribs)

Example Matrix

Example Location visible when enabled when defined by placed by handled by comments
File->Exit global menu always always Workbench IDEApplication IDEApplication
Edit->Copy global menu always there is an enabled handler Workbench IDEApplication active part (what about Trim??) enablement determined by handler
Global toolbar->Save global toolbar always the active part needs saving Workbench IDEApplication Workbench
Global toolbar->Open Type global toolbar Java Navigation action set is enabled Java Navigation action set is enabled JDT UI JDT UI JDT UI
Global toolbar->Toggle Mark Occurrences global (editor) toolbar any Java editor is active any Java editor is active all Java Editors all Java Editors active Java Editor push button state is updated based on active editor

File->Exit

Current RCP using ActionBarAdvisor

The ApplicationActionBarAdvisor should add the exit menu.

// create the file menu
MenuManager menu = new MenuManager(IDEWorkbenchMessages.Workbench_file, IWorkbenchActionConstants.M_FILE);
// ...
quitAction = ActionFactory.QUIT.create(window);
register(quitAction);
ActionContributionItem quitItem = new ActionContributionItem(quitAction);
quitItem.setVisible(!"carbon".equals(SWT.getPlatform())); //$NON-NLS-1$
menu.add(quitItem);

Back to the top