Jump to: navigation, search

Difference between revisions of "MemoryAnalyzer/FAQ"

m (java.lang.RuntimeException: No application id has been found.)
m (Problems Starting the Memory Analyzer)
Line 11: Line 11:
  
 
(This error happens, because the MAT plug-in requires a JDK 1.5 via its manifest.mf file and the OSGi runtime dutifully does not activate the plug-in.)
 
(This error happens, because the MAT plug-in requires a JDK 1.5 via its manifest.mf file and the OSGi runtime dutifully does not activate the plug-in.)
 +
 +
=== Out of Memory Error while Running the Memory Analyzer ===
 +
 +
Well, analyzing big heap dumps can also require more heap space. Give it some more memory (possible by running on a 64-bit machine):
 +
 +
<blockquote>MemoryAnalyzer.exe -vmargs -Xmx4g</blockquote>
 +
 +
Alternatively, edit the <code>MemoryAnalyzer.ini</code> to contain:
 +
 +
<blockquote>-vmargs<br/>
 +
-Xmx1024m</blockquote>
 +
 +
For more details, check out the section [http://help.eclipse.org/ganymede/topic/org.eclipse.platform.doc.user/tasks/running_eclipse.htm Running Eclipse] in the Help Center. It also contains more details if you are running on Mac OS X.
  
 
== Problems Getting Heap Dumps ==
 
== Problems Getting Heap Dumps ==

Revision as of 10:40, 19 November 2008

Frequently Asked Questions

MemoryAnalyzer, Home Page, Forum

Problems Starting the Memory Analyzer

java.lang.RuntimeException: No application id has been found.

The Memory Analyzer needs a Java 1.5 VM to run (of course, heap dumps from JDK 1.4.2_12 on are supported). If in doubt, provide the runtime VM on the command line:

MemoryAnalyzer.exe -vm <path to 1.5 vm>

(This error happens, because the MAT plug-in requires a JDK 1.5 via its manifest.mf file and the OSGi runtime dutifully does not activate the plug-in.)

Out of Memory Error while Running the Memory Analyzer

Well, analyzing big heap dumps can also require more heap space. Give it some more memory (possible by running on a 64-bit machine):

MemoryAnalyzer.exe -vmargs -Xmx4g

Alternatively, edit the MemoryAnalyzer.ini to contain:

-vmargs
-Xmx1024m

For more details, check out the section Running Eclipse in the Help Center. It also contains more details if you are running on Mac OS X.

Problems Getting Heap Dumps

Error: Found instance segment but expected class segment

This error indicates an inconsistent heap dump: The data in the heap dump is written in various segments. In this case, an address expected in a class segment is written into a instance segment.

The problem has been reported in heap dumps generated by jmap on Linux and Solaris operation systems and jdk1.5.0_13 and below. Solution: use latest jdk/jmap version or use jconsole to write the heap dump (needs jdk6).

Error: Invalid heap dump file. Unsupported segment type 0 at position XZY

This almost always means the heap dumps has not been written properly by the Virtual Machine. The Memory Analyzer is not able to read the heap dump.

If you are able to read the dump with other tools, please file a bug report.