Jump to: navigation, search

Difference between revisions of "MDT-UML2-Tool-Compatibility"

(List of UML2-compatible UML Tools)
(List of UML2-compatible UML Tools)
Line 83: Line 83:
 
| EPL
 
| EPL
 
| 1.1
 
| 1.1
| 2.1/2.2
+
| 2.2
 
| Uses a textual notation
 
| Uses a textual notation
 
|}
 
|}

Revision as of 01:42, 3 September 2008

This topic is a place to gather information about UML2 compatibility in open source and commercial UML/MDA products.

List of UML2-compatible UML Tools

Tool Native Modeling Code Generation License Tool Version UML2 Version Notes
IBM RSM/RSA No Yes Yes Commercial
Papyrus UML Yes Yes Yes EPL
Obeo Acceleo Yes No Yes EPL 2.2.1 metamodel-driven, not UML specific
openArchitectureWare Yes No Yes EPL metamodel-driven, not UML specific
Eclipse UML2 Tools Yes Yes No EPL
Omondo EclipseUML Yes Yes Yes Commercial
Taylor MDA Yes Yes Yes LGPL
TOPCASED UML Yes Yes Yes EPL
MagicDraw UML No Yes Yes Commercial
Soyatec eUML2 Yes Yes Yes Commercial
MOSKitt Yes Yes No EPL
TextUML Toolkit Yes Yes* No EPL 1.1 2.2 Uses a textual notation
Description of table columns

Follows a description of the less obvious column names:

  • Native - whether the tool uses UML2 as its native format. If UML2 is not natively supported, that means the user has to perform some sort of conversion step (e.g. import/export) in order for the tool to accept/provide UML2-compatible models.
  • Modeling - whether the tool supports modeling.
  • Code generation - whether the tool supports code generation.
  • Tool version - version of the tool when verified. If the tool has not been verified yet, it will be empty.
  • UML2 version - version of UML2 adopted by the tool when verified.
  • Notes - any quirks or comments about UML2 support in the tool.