Difference between revisions of "M2M/QVT Declarative Installation"

From Eclipsepedia

< M2M
Jump to: navigation, search
(Installation of QVTd Development Environment)
(Install QVTd and other Projects)
 
(10 intermediate revisions by one user not shown)
Line 1: Line 1:
 
==Installation of QVTd Editors==
 
==Installation of QVTd Editors==
 +
The following steps establish an Eclipse workspace with
 +
*installed plugins for
 +
**EMF
 +
**UML2
 +
**MDT/OCL and its Examples
 +
**EMF Query
 +
**EMF Transaction
 +
**EMF Validation
 +
**LPG 2 Runtime
 +
**IMP Runtime
 +
**QVT Declarative
 +
Example projects can then be created to demonstrate the editor.
 +
 +
The first few steps may be omitted if you are reusing an existing Eclipse environment.
 +
 +
===Install Java 1.5 or 1.6===
 +
 +
From http://www.java.com/en/download/index.jsp.
 +
 +
===Install Eclipse 3.6 (Helios)===
 +
 +
e.g Extract All from [http://download.eclipse.org/eclipse/downloads/drops/R-3.6-201006080911/index.php eclipse-SDK-3.6-....zip].
 +
 +
===Install QVTd and other Projects===
 +
 +
A ZIPped Update Site is available at [http://www.eclipse.org/modeling/m2m/downloads/index.php?project=qvtd QVTd Download Page]. Download the All-In-One Update Site to your local disk, then use it (by dragging and dropping) that Update into the 'Work with:' location of Help->Install New Software...
 +
 +
Restart Eclipse.
 +
 +
===Create an Example Project===
 +
 +
Invoke New->Project ... from the right button menu within the Package Explorer.
 +
 +
Select e.g. Examples->QVT (Queries, Views and transformation) Projects->Royal and Loyal Example.
 +
 +
Click Finish.
 +
 +
Double click /org.eclipse.qvt.declarative.examples.ocl.royalandloyal/oclsrc/RoyalAndLoyal/RoyalAndLoyal.ocl
  
 
==Installation of QVTd Development Environment==
 
==Installation of QVTd Development Environment==
Line 6: Line 44:
 
**EMF
 
**EMF
 
**UML2
 
**UML2
 +
**EMF Query
 +
**EMF Transaction
 +
**EMF Validation
 +
**MDT/OCL Example Model Registry
 +
**LPG 2 Runtime
 
**Subclipse
 
**Subclipse
 
*checked out projects for
 
*checked out projects for
 
**QVT Declarative
 
**QVT Declarative
 
**MDT/OCL
 
**MDT/OCL
**EMF Query
 
**EMF Transaction
 
**EMF Validation
 
 
**IMP Runtime
 
**IMP Runtime
**LPG 2 Runtime
 
 
A nested Eclipse may then be invoked and Example projects created to demonstrate the editor.
 
A nested Eclipse may then be invoked and Example projects created to demonstrate the editor.
  
Line 23: Line 62:
 
From http://www.java.com/en/download/index.jsp.
 
From http://www.java.com/en/download/index.jsp.
  
===Install Eclipse 3.6M4===
+
===Install Eclipse 3.6 Modeling (Helios) ===
  
e..g Extract All from eclipse-SDK-3.6M4-win32.zip.
+
e.g Extract All from [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools-includes-incubating-components/heliosr Helios Modeling Package].
  
===Install MDT UML2 SDK 3.1.0M4 (and EMF-XSD 2.6.0M4)===
+
Alternatively add EMF Core, EMF Query, EMF Transaction, EMF Validation, OCL, UML2 to an existing Eclipse installation.
  
Window->Install New Software from http://download.eclipse.org/modeling/mdt/updates/milestones/ and select UML2 SDK 3.1M4.
+
===Install MDT UML2 SDK 3.1.0 (and EMF-XSD 2.6.0)===
 +
 
 +
Window->Install New Software from Helios - http://download.eclipse.org/releases/helios/ and select Modeling->UML2 Extender SDK.
  
 
===Install Subclipse===
 
===Install Subclipse===
Line 43: Line 84:
 
Or: Check out HEAD/www/modeling/m2m/qvtd from the /cvsroot/org.eclipse repository on dev.eclipse.org.
 
Or: Check out HEAD/www/modeling/m2m/qvtd from the /cvsroot/org.eclipse repository on dev.eclipse.org.
  
===Import QVTd, MDT/OCL, EMF Query, EMF Transaction, EMF Validation, IMP Runtime, LPG 2 Runtime===
+
===Import QVTd, MDT/OCL Examples Model Registry, IMP Runtime===
  
 
Invoke Import Project Set... from the right button menu of qvtd.psf.
 
Invoke Import Project Set... from the right button menu of qvtd.psf.
Line 63: Line 104:
 
Invoke New->Project ... from the right button menu within the Package Explorer.
 
Invoke New->Project ... from the right button menu within the Package Explorer.
  
Select e.g. Examples->QVT (Queries, Views and transformation) Projects->Royal and Loyal Example.
+
Select e.g. Examples->QVT (Queries, Views and transformation) Projects->Relations To Core Example.
  
 
Click Finish.
 
Click Finish.
  
Double click /org.eclipse.qvt.declarative.examples.ocl.royalandloyal/oclsrc/RoyalAndLoyal/RoyalAndLoyal.ocl
+
Double click /org.eclipse.qvt.declarative.examples.qvtrelation.reltocore/qvtrcsrc/ReToCore.qvtr
 +
 
 +
(there is one error due to a missing definition of CopyOclExpession.)

Latest revision as of 10:50, 10 July 2010

Contents

[edit] Installation of QVTd Editors

The following steps establish an Eclipse workspace with

  • installed plugins for
    • EMF
    • UML2
    • MDT/OCL and its Examples
    • EMF Query
    • EMF Transaction
    • EMF Validation
    • LPG 2 Runtime
    • IMP Runtime
    • QVT Declarative

Example projects can then be created to demonstrate the editor.

The first few steps may be omitted if you are reusing an existing Eclipse environment.

[edit] Install Java 1.5 or 1.6

From http://www.java.com/en/download/index.jsp.

[edit] Install Eclipse 3.6 (Helios)

e.g Extract All from eclipse-SDK-3.6-....zip.

[edit] Install QVTd and other Projects

A ZIPped Update Site is available at QVTd Download Page. Download the All-In-One Update Site to your local disk, then use it (by dragging and dropping) that Update into the 'Work with:' location of Help->Install New Software...

Restart Eclipse.

[edit] Create an Example Project

Invoke New->Project ... from the right button menu within the Package Explorer.

Select e.g. Examples->QVT (Queries, Views and transformation) Projects->Royal and Loyal Example.

Click Finish.

Double click /org.eclipse.qvt.declarative.examples.ocl.royalandloyal/oclsrc/RoyalAndLoyal/RoyalAndLoyal.ocl

[edit] Installation of QVTd Development Environment

The following steps establish an Eclipse workspace with

  • installed plugins for
    • EMF
    • UML2
    • EMF Query
    • EMF Transaction
    • EMF Validation
    • MDT/OCL Example Model Registry
    • LPG 2 Runtime
    • Subclipse
  • checked out projects for
    • QVT Declarative
    • MDT/OCL
    • IMP Runtime

A nested Eclipse may then be invoked and Example projects created to demonstrate the editor.

The first few steps may be omitted if you are reusing an existing Eclipse environment.

[edit] Install Java 1.5 or 1.6

From http://www.java.com/en/download/index.jsp.

[edit] Install Eclipse 3.6 Modeling (Helios)

e.g Extract All from Helios Modeling Package.

Alternatively add EMF Core, EMF Query, EMF Transaction, EMF Validation, OCL, UML2 to an existing Eclipse installation.

[edit] Install MDT UML2 SDK 3.1.0 (and EMF-XSD 2.6.0)

Window->Install New Software from Helios - http://download.eclipse.org/releases/helios/ and select Modeling->UML2 Extender SDK.

[edit] Install Subclipse

(This required to access the IMP SVN repository. If you prefer subversion edit the foot of qvtd.psf after the next step)

Window->Install New Software from http://subclipse.tigris.org/update_1.6.x and select all features. (You may exclude the Mylyn integration to avoid a number of dependent downloads.)

[edit] Get qvtd.psf

Either: Save http://eclipse.org/modeling/m2m/qvtd/resources/qvtd.psf to some temporary file in your workspace.

Or: Check out HEAD/www/modeling/m2m/qvtd from the /cvsroot/org.eclipse repository on dev.eclipse.org.

[edit] Import QVTd, MDT/OCL Examples Model Registry, IMP Runtime

Invoke Import Project Set... from the right button menu of qvtd.psf.

[edit] Build the Examples

Invoke Run As->Ant Build from the right button menu of org.eclipse.qvt.declarative.examples/buildZips.xml.

Invoke Refresh from the right button menu of org.eclipse.qvt.declarative.examples/zips.

[edit] Run a nested Eclipse

Invoke Run As->Eclipse Application from e.g. org.eclipse.qvt.declarative.examples/plugin.xml.

Close the Intro page.

[edit] Create an Example Project

Invoke New->Project ... from the right button menu within the Package Explorer.

Select e.g. Examples->QVT (Queries, Views and transformation) Projects->Relations To Core Example.

Click Finish.

Double click /org.eclipse.qvt.declarative.examples.qvtrelation.reltocore/qvtrcsrc/ReToCore.qvtr

(there is one error due to a missing definition of CopyOclExpession.)