Skip to main content
Jump to: navigation, search

Difference between revisions of "M2E Development Environment"

Line 1: Line 1:
 +
{{M2E}}
 +
 
Download and unpack Eclipse SDK Juno M2 or newer from http://download.eclipse.org/eclipse/downloads/. Both 3.8 and 4.2 builds are expected to work, but 3.8 is probably more stable at this point.
 
Download and unpack Eclipse SDK Juno M2 or newer from http://download.eclipse.org/eclipse/downloads/. Both 3.8 and 4.2 builds are expected to work, but 3.8 is probably more stable at this point.
  

Revision as of 17:37, 5 November 2011

M2E
Website
Download
Community
Mailing ListForumsIRCmattermost
Bugzilla
OpenHelp WantedBug Day
Contribute
Browse Source

Download and unpack Eclipse SDK Juno M2 or newer from http://download.eclipse.org/eclipse/downloads/. Both 3.8 and 4.2 builds are expected to work, but 3.8 is probably more stable at this point.

Install m2e 1.0SR1 from http://download.eclipse.org/technology/m2e/releases/1.0/1.0.100.20110804-1717

Clone m2e-core repository. Committers should use ssh://YOUR_COMMITTERID@git.eclipse.org/gitroot/m2e/m2e-core.git. For read-only access use either git://git.eclipse.org/gitroot/m2e/m2e-core.git or http://git.eclipse.org/gitroot/m2e/m2e-core.git.

Import m2e-core as existing maven project. Follow onscreen instructions, allow m2e to install additional software and restart eclipse when requested.

Clone m2e-core-tests repository. Developers should use git@github.com:sonatype/m2e-core-tests.git. For read-only access use either git://github.com/sonatype/m2e-core-tests.git.

Import m2e-core-tests as existing maven project.

Back to the top