Jump to: navigation, search

Lyo/Licenses

< Lyo
Revision as of 05:09, 28 June 2012 by Olivier.berger.it-sudparis.eu (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

This page is work in progress contributed by OlivierBerger, and not yet endorsed by the Eclipse Lyo project leads. Please do not take information contained here as official, until the present notice is removed.

In Eclipse Lyo, some of the software modules are not always tightly linked to the rest of the Eclipse projects which concern the IDE.

Some contributions are libraries which are meant to be used to glue tools, for instance in scripts that need to communicate with OSLC compatible services, using scripting languages like Perl, for instance.

For such libraries, there is the need to make sure that their license is flexible enough to accomodate most situations. Thus, in addition to the EPL licensing which is common in Eclipse project, such code will be also released under the conditions of the EDL (New BSD style license).

Again, please check with the project leads to make sure that you understand the Lyo licensing conditions, in case of doubt, and don't take this as official statement.