Jump to: navigation, search

Difference between revisions of "Lyo/BuildClient"

< Lyo
Line 7: Line 7:
 
*[http://eclipse.org/downloads Eclipse 3.6 or higher IDE]  
 
*[http://eclipse.org/downloads Eclipse 3.6 or higher IDE]  
 
*[http://eclipse.org/egit/download/ EGit] team provider for git (recommended) or [http://git-scm.com/download git command line package].  
 
*[http://eclipse.org/egit/download/ EGit] team provider for git (recommended) or [http://git-scm.com/download git command line package].  
*[http://www.eclipse.org/m2e/download/m2eclipse] for Maven support in the Eclipse IDE
+
*[http://www.eclipse.org/m2e/download/ m2eclipse] for Maven support in the Eclipse IDE  
 +
*Lyo client requires a Java 1.6 compiler and Java 1.6 runtime. The Eclipse project settings have been set appropriately. If you are building outside of Eclipse, please use Java 1.6.
  
 
== Clone the Lyo Client git repository  ==
 
== Clone the Lyo Client git repository  ==

Revision as of 16:09, 15 October 2012

The Lyo Client provides helpful APIs and sample code that can be used to interact with OSLC Service Providers. It provides an additional layer of functionality on top of Apache HttpClient, Apache Wink, and OSLC4J that can give you a head start on some of the common use cases such as form login, OAuth handling, service discovery, sending queries, and processing query results. It also provides sample code that demonstrates how to use the Lyo client in interesting ways, such as acting as a remote agent for an OSLC Automation service provider.

Building and Running the Lyo Client in Eclipse

Prerequisites

  • Eclipse 3.6 or higher IDE
  • EGit team provider for git (recommended) or git command line package.
  • m2eclipse for Maven support in the Eclipse IDE
  • Lyo client requires a Java 1.6 compiler and Java 1.6 runtime. The Eclipse project settings have been set appropriately. If you are building outside of Eclipse, please use Java 1.6.

Clone the Lyo Client git repository

This example assumes EGit is being used.

  • Open the Git Repositories view in Eclipse and click the Clone Git Repository icon
  • Use git://git.eclipse.org/gitroot/lyo/org.eclipse.lyo.client.git as the URI (browse it also on line). User/Password are not required.
  • On the Branch Selection page, select the master branch
  • On the Local Destination page, specify a location or accept the default and click Finish

The repository should now show up in your Git Repositories view.