Jump to: navigation, search

Difference between revisions of "Libra/Getting Started"

(New page: = Getting Started = == Installation == Currently Libra supports only Eclipse Indigo. As a prerequisite you need to install Eclipse IDE for Java EE Developers. After that install Libra ...)
 
Line 4: Line 4:
  
 
Currently Libra supports only Eclipse Indigo. As a prerequisite you need to install Eclipse IDE for Java EE Developers. After that install Libra from the [https://hudson.eclipse.org/hudson/view/WTP/job/libra/ws/development/org.eclipse.libra.repository/target/site/ update site]
 
Currently Libra supports only Eclipse Indigo. As a prerequisite you need to install Eclipse IDE for Java EE Developers. After that install Libra from the [https://hudson.eclipse.org/hudson/view/WTP/job/libra/ws/development/org.eclipse.libra.repository/target/site/ update site]
 +
 +
The site contains:
 +
* OSGi Facet Feature
 +
* WAR Products Core Feature
  
 
== Usage  ==
 
== Usage  ==
 +
* WAR Products Core Feature provides [http://wiki.eclipse.org/RAP/Equinox_WAR_products WAR deployment for Equinox based applications]<br/>
 +
* OSGi Facet Feature introduces:
 +
*# A new facet "OSGi Bundle" for Dynamic Web, JPA and Utility projects.
 +
*# Wizard for converting WTP standard projects to OSGi Enterprise bundle projects:
 +
*#* Dynamic Web projects to Web Application Bundle projects
 +
*#* JPA projects to Persistent Bundle projects
 +
*#* Utility projects and simple Java projects to OSGi Bundle projects
 +
Both options modify project's MANIFEST.MF in order to become a valid OSGi bundle.
 +
 +
The facet may be enabled during project creation or after that from Properties page of the project.
 +
The wizard is available from project's context menu ''Configure > Convert to OSGi Bundle Projects...''
 +
<pre>Note that you may need to adjust your target platform accordingly.</pre>
  
 
= Obtaining Sources =
 
= Obtaining Sources =
 +
Sources are available in Git repository [http://git.eclipse.org/c/libra/org.eclipse.libra.git/ http://git.eclipse.org/c/libra/org.eclipse.libra.git/]
 +
In order to sync them locally, you may use [http://www.eclipse.org/egit/ EGit]

Revision as of 11:19, 18 February 2011

Getting Started

Installation

Currently Libra supports only Eclipse Indigo. As a prerequisite you need to install Eclipse IDE for Java EE Developers. After that install Libra from the update site

The site contains:

  • OSGi Facet Feature
  • WAR Products Core Feature

Usage

  • WAR Products Core Feature provides WAR deployment for Equinox based applications
  • OSGi Facet Feature introduces:
    1. A new facet "OSGi Bundle" for Dynamic Web, JPA and Utility projects.
    2. Wizard for converting WTP standard projects to OSGi Enterprise bundle projects:
      • Dynamic Web projects to Web Application Bundle projects
      • JPA projects to Persistent Bundle projects
      • Utility projects and simple Java projects to OSGi Bundle projects

Both options modify project's MANIFEST.MF in order to become a valid OSGi bundle.

The facet may be enabled during project creation or after that from Properties page of the project. The wizard is available from project's context menu Configure > Convert to OSGi Bundle Projects...

Note that you may need to adjust your target platform accordingly.

Obtaining Sources

Sources are available in Git repository http://git.eclipse.org/c/libra/org.eclipse.libra.git/ In order to sync them locally, you may use EGit