Java 5 Compatibility

From Eclipsepedia

Revision as of 20:43, 22 July 2013 by Scott.fisher.oracle.com (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Hudson is built with Java 6, but can be run with Java 5. See Maven2 project and JDK5. The Animal Sniffer Maven Plugin is used to enforce Java 5 compatibility.

By default, Hudson plugins can also run under Java 5, but only if the plugin author is careful not to call any of the new Java 6 APIs.

Unless a plugin requires the new Java 6 features, the animal sniffer plugin should be added to the plugin's POM to enforce Java 5 compatibility. See the blog entry compiling-jdk6-and-running-jdk5 for instructions.

It may also be necessary to increase the memory available to Maven. For example, set the MAVEN_OPTS environment variable to Xmx1024m.