Skip to main content
Jump to: navigation, search

Difference between revisions of "JWT Downloads"

(How to get JWT)
Line 6: Line 6:
 
* A detailed list of requirements can be found at [[http://wiki.eclipse.org/JWT_CVS#Requirements]]
 
* A detailed list of requirements can be found at [[http://wiki.eclipse.org/JWT_CVS#Requirements]]
  
=== Using the Update site ===
+
=== Installing using the Update site ===
 
The easiest and preferred way to install JWT is to use the update site mechanism from within Eclipse (in the "Help > Software Update..." menu ). Add the JWT update site at [http://download.eclipse.org/technology/jwt/update-site/] and download and install all JWT plugins and their dependencies automatically.  
 
The easiest and preferred way to install JWT is to use the update site mechanism from within Eclipse (in the "Help > Software Update..." menu ). Add the JWT update site at [http://download.eclipse.org/technology/jwt/update-site/] and download and install all JWT plugins and their dependencies automatically.  
  
Line 14: Line 14:
 
* EMF
 
* EMF
  
== Current Releases ==
+
=== Current Release ===
  
* [[JWT_Downloads#Workflow_Editor_Version_0.5.0 | Workflow Editor 0.5.0]]
+
The current release is the [[JWT_Downloads#Workflow_Editor_Version_0.5.0 | Workflow Editor 0.5.0]].
  
 
For information about the dependencies that must be met in order to run these components, please refer to [[JWT_CVS#Requirements | Requirements]].
 
For information about the dependencies that must be met in order to run these components, please refer to [[JWT_CVS#Requirements | Requirements]].
 +
 +
=== Next Release ===
  
 
What is currently planned for the next release can be seen at [[JWT_Upcoming_Release | Upcoming Release Information]].
 
What is currently planned for the next release can be seen at [[JWT_Upcoming_Release | Upcoming Release Information]].

Revision as of 04:51, 6 November 2008

General Information

Requirements

  • J2SE 5.0 or later
  • Eclipse 3.4 "Ganymede" with EMF and GEF, available in several bundles there.
  • A detailed list of requirements can be found at [[1]]

Installing using the Update site

The easiest and preferred way to install JWT is to use the update site mechanism from within Eclipse (in the "Help > Software Update..." menu ). Add the JWT update site at [2] and download and install all JWT plugins and their dependencies automatically.

Installing the Jars

Alternatively, you can download the plugin jar files below and put them in the plugins directory of your Eclipse installation. In this case, you also have to install (typically using the Ganymede update site) the Ganymede releases of the following required Eclipse plugin dependencies :

  • GEF (which also packs the required draw2d)
  • EMF

Current Release

The current release is the Workflow Editor 0.5.0.

For information about the dependencies that must be met in order to run these components, please refer to Requirements.

Next Release

What is currently planned for the next release can be seen at Upcoming Release Information.

Workflow Editor

Workflow Editor Version 0.6.0

this is the upcoming release (Upcoming Release Information)



Workflow Editor Version 0.5.0

WE
Release Package
Source Package
Workflow Editor
src, javadoc
Tutorial
pdf
-
Example Processes
zip
-
View Creator
bin
src

 

WE Plugins
Release Package
Source Package
Documentation Generator
src
UML Activity Diagram View
src
Action Plugin Example
bin
src
View Plugin Example
bin
src

 

Transformations
Release Package
Source Package
Base
src
JWT to XPDL
src



Workflow Editor Version 0.4.0

WE
Release Package
Source Package
Workflow Editor
Tutorial
-
Example Processes
-
View Creator

 

WE Plugins
Release Package
Source Package
Documentation Generator
Action Plugin Example

See also

Back to the top