Jump to: navigation, search

JET FAQ What does "Error: Feature 'version' not found." mean?

Question

I launched my Jet transformation on an EMF Model and an error occurred : "Error: Feature 'version' not found.". What does it mean ?

Answer

Jet2 loads the EMF model when a transformation is ran. The version feature refers to xmi:version on top node of your model.

<... xmi:version="2.0" ...>

It is likely that if you launch your transformation in its workspace, this error does not happen. But if you run the Jet transformation in a runtime workspace, you'll have to precise Jet which model loader it should use for making a memory representation of your model.

For that :

1.Open plugin.xml in your Jet project

2.Open org.eclipse.jet.transform extension point

3.Edit transform element and set modelLoader to org.eclipse.jet.emf

By default, the model loader is configured for plain XML.


Back to the M2T-JET-FAQ