Jump to: navigation, search

Difference between revisions of "Installing Buckminster"

(Installation)
(Option 2: Buckminster with Subversive integration)
Line 62: Line 62:
 
#*Alternatively, you can enter the update sites individually by choosing '''''New Remote Site ...''''' and then add:
 
#*Alternatively, you can enter the update sites individually by choosing '''''New Remote Site ...''''' and then add:
 
#*#Buckminster update site: '''[http://download.eclipse.org/technology/buckminster/updates http://download.eclipse.org/technology/buckminster/updates]'''
 
#*#Buckminster update site: '''[http://download.eclipse.org/technology/buckminster/updates http://download.eclipse.org/technology/buckminster/updates]'''
#*#Subclipse update site: '''[http://subclipse.tigris.org/update_1.2.x http://subclipse.tigris.org/update_1.2.x]''' (more information on Subclipse is available [http://subclipse.tigris.org/ here])
+
#*#Subversive integration requires two update site:
#Make sure both update sites are selected and then press '''''Finish'''''.   
+
#*#*Subversive client: '''[http://download.eclipse.org/technology/subversive/0.7/update-site/ http://download.eclipse.org/technology/subversive/0.7/update-site/]''' (more information on Subversive is available [http://www.eclipse.org/subversive/index.php here])
 +
#*#*Subversive SVN Connectors: '''[http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/ http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/]'''
 +
#Make sure all three update sites are selected and then press '''''Finish'''''.   
 
#Eclipse may throw up a window entitled '''''Update Site Mirrors'''''. Pick the most appropriate. For '''''Buckminster Update Site''''' we advise that you pick the main Buckminster Update Site as occasionally a mirror site is not always in synchronization with the master site and Buckminster is frequently updated.
 
#Eclipse may throw up a window entitled '''''Update Site Mirrors'''''. Pick the most appropriate. For '''''Buckminster Update Site''''' we advise that you pick the main Buckminster Update Site as occasionally a mirror site is not always in synchronization with the master site and Buckminster is frequently updated.
#Eclipse will then display a window entitled '''''Search Results''''' which should include the specified Buckminster and Subclipse upate sites.
+
#Eclipse will then display a window entitled '''''Search Results''''' which should include the specified Buckminster and Subversive/SVN Connector upate sites.
 
#*For Buckminster:
 
#*For Buckminster:
 
#*#Select all core Buckminster features.
 
#*#Select all core Buckminster features.
#*#Select the Subclipse integration and typically all other optional features
+
#*#Select the Subversive integration and typically all other optional features
#*#BUT DO NOT SELECT the Subversive integration feature.
+
#*#BUT DO NOT SELECT the Subclipse integration feature.
#*For Subclipse:
+
#*For Subversive:
#*#Select the core Subclipse features.
+
#*#Select the core Subversive Team provider features.
#*#Select the Subclipse Buckminster integration feature.
+
#*#There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
#*#There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
+
#*For SVN Connectors:
 +
#*#Select the all core SVN Connector features.
 +
#*#There may be other optional features but they are not required for Buckminster.
 
# Proceed with '''''Finish'''''. Eclipse will then display a '''''Feature License''''' window,  and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Next'''''.
 
# Proceed with '''''Finish'''''. Eclipse will then display a '''''Feature License''''' window,  and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Next'''''.
 
# Eclipse will then display the '''''Installation''''' window  for the selected features.  Accept the default folder locations and select '''''Finish'''''.
 
# Eclipse will then display the '''''Installation''''' window  for the selected features.  Accept the default folder locations and select '''''Finish'''''.
 
#The '''''Update Manager''''' will indicate the download progress and display a '''''Feature Verification''''' window upon completion. If you are happy to proceed,  select the '''''Install''''' or simply '''''Install All'''''.
 
#The '''''Update Manager''''' will indicate the download progress and display a '''''Feature Verification''''' window upon completion. If you are happy to proceed,  select the '''''Install''''' or simply '''''Install All'''''.
 
#The installation should be finished with a restart of Eclipse.
 
#The installation should be finished with a restart of Eclipse.
 
  
 
==Wrapping up==
 
==Wrapping up==

Revision as of 05:43, 25 January 2008

< To: Buckminster Project

Installation

Buckminster is available as a plugin to the Eclipse IDE. There is also a stand alone “headless” version for command line usage, which if you ever need it, is described later below.

These steps describe a typical Buckminster installation for use in Eclipse IDE. Note that the Subclipse plug-in is also typically used (see below): Subclipse is an Eclipse Team Provider plug-in which provides support for the Subversion version control system within the Eclipse IDE.

Make sure you are using Eclipse 3.3 or later

At the time of writing you will have to make sure you have Eclipse 3.3 or later with PDE bundles installed.

  • If you are starting from scratch it is it is recommended that you choose either the '"Eclipse Classic" or the '"Eclipse for RCP/Plug-in Developers" package. They both contain the PDE bundles required by Buckminster, otherwise those will have to be obtained separately.
    1. Download either of the suggested packages from http://www.eclipse.org/downloads/.
  • Or if Eclipse is installed make sure it is the correct version:
    1. Select Help > About Eclipse SDK and check the Version number.
    2. Currently, the Buckminster plugins do not check for a minimum Eclipse version. If you install the plugins on an earlier Eclipse version, the installation may succeed, but you will probably however encounter many errors as you start using Buckminster.

Make sure you are using Java 5.0 or later

You can do that in Eclipse by:

  1. Select Help > About Eclipse SDK > Configuration Details. Scroll down to the parameter java.runtime.version - it should start with 1.5 or later (as an example the line may look like this java.runtime.version=1.6.0_01-b016)
  2. If it does not start with at least 1.5, you need to update your java environment first: you should find a version for your operating system here.


Download Buckminster with the Eclipse Update Manager

Buckminster comes with a number of optional features. In order to obtain SVN support and allow Buckminster to communicate with SVN providers you have a choice to either use the Buckminster Subclipse OR Subversive integration. NOTE that those to features are mutually exclusive.

The sections below describe the complete update steps for both choices.

Option 1: Buckminster with Subclipse integration

  1. Select Help > Software Updates > Find and Install in the Eclipse IDE.
  2. Select Search for new features to install and then the Next button.
  3. Provide the update manager with the required information for the Buckminster and Subclipse update sites:
    • The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
      1. Download this Buckminster and Subclipse Update Manager Bookmarks XML file, and store it somewhere convenient(e.g. in a file called bookmarks.xml). This file tells the Eclipse Update Manager about both Buckminster and the Subclipse plugins required by Buckminster.
      2. Select Import Sites... and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
    • Alternatively, you can enter the update sites individually by choosing New Remote Site ... and then add:
      1. Buckminster update site: http://download.eclipse.org/technology/buckminster/updates
      2. Subclipse update site: http://subclipse.tigris.org/update_1.2.x (more information on Subclipse is available here)
  4. Make sure both update sites are selected and then press Finish.
  5. Eclipse may throw up a window entitled Update Site Mirrors. Pick the most appropriate. For Buckminster Update Site we advise that you pick the main Buckminster Update Site as occasionally a mirror site is not always in synchronization with the master site and Buckminster is frequently updated.
  6. Eclipse will then display a window entitled Search Results which should include the specified Buckminster and Subclipse upate sites.
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the Subclipse integration and typically all other optional features
      3. BUT DO NOT SELECT the Subversive integration feature.
    • For Subclipse:
      1. Select the core Subclipse features.
      2. Select the Subclipse Buckminster integration feature.
      3. There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
  7. Proceed with Finish. Eclipse will then display a Feature License window, and if you are happy with the terms of the license as displayed, accept them, and then do Next.
  8. Eclipse will then display the Installation window for the selected features. Accept the default folder locations and select Finish.
  9. The Update Manager will indicate the download progress and display a Feature Verification window upon completion. If you are happy to proceed, select the Install or simply Install All.
  10. The installation should be finished with a restart of Eclipse.


Option 2: Buckminster with Subversive integration

  1. Select Help > Software Updates > Find and Install in the Eclipse IDE.
  2. Select Search for new features to install and then the Next button.
  3. Provide the update manager with the required information for the Buckminster and Subversive/SVN update sites:
  4. Make sure all three update sites are selected and then press Finish.
  5. Eclipse may throw up a window entitled Update Site Mirrors. Pick the most appropriate. For Buckminster Update Site we advise that you pick the main Buckminster Update Site as occasionally a mirror site is not always in synchronization with the master site and Buckminster is frequently updated.
  6. Eclipse will then display a window entitled Search Results which should include the specified Buckminster and Subversive/SVN Connector upate sites.
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the Subversive integration and typically all other optional features
      3. BUT DO NOT SELECT the Subclipse integration feature.
    • For Subversive:
      1. Select the core Subversive Team provider features.
      2. There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
    • For SVN Connectors:
      1. Select the all core SVN Connector features.
      2. There may be other optional features but they are not required for Buckminster.
  7. Proceed with Finish. Eclipse will then display a Feature License window, and if you are happy with the terms of the license as displayed, accept them, and then do Next.
  8. Eclipse will then display the Installation window for the selected features. Accept the default folder locations and select Finish.
  9. The Update Manager will indicate the download progress and display a Feature Verification window upon completion. If you are happy to proceed, select the Install or simply Install All.
  10. The installation should be finished with a restart of Eclipse.

Wrapping up

To confirm that Buckminster has now been installed, check that the File > New > Other > has an entry for the Buckminster wizards; expanding the Buckminster box should show a number of available Buckminster wizards.

Hopefully your installation has proceeded smoothly. However, here are some thoughts if things don't work out:

  • At the time of writing, the Eclipse Update Manager (in general, not just for Buckminster) is IMHO far from perfect, and is currently being subject to revision. Hopefully before the end of 2007, there should be a better version.
  • If you have previously installed Buckminster, you may need to un-install it before re-installing it as above - otherwise the re-install may fail. The safest way to do this is to find the Eclipse installation directory on your machine, and remove anything that has buckminster in its name below the two folders plugins and features. Then restart your Eclipse IDE again and proceed to re-install Buckminster.
  • In step 3.5 above, it may be prudent of you to select all the sites which are displayed to you to include in your search: this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).

After the Installation

We suggest the next places you might want to take a look at are:

  • The Why Buckminster ? document gives a high level overview of the motivation for, and concepts in, Buckminster, without getting into details of any (XML) code fragments.
  • The Hello XML World Example (Buckminster) which illustrates in detail how a materialization can be done, and uses different types of components - Eclipse plugins and stand alone files.
  • The Introduction to Buckminster which gives some common usage scenarios, explaining how to materialize and consume software components; how to publish components to your colleagues and the wider community; and how to prepare virtual distributions ("distros") using Buckminster.

Installing the Headless Buckminster

Buckminster is also packaged in a so called 'Headless' command line oriented version suitable for running on remote servers, be invoked from scripts etc. The Headless version is based on Eclipse but only includes what is needed to run as a command line tool. The footprint of the headless version is thus much smaller than for the complete Eclipse IDE.

The Headless version as it is delivered today requires configuration before use. The downloadable version only contains the Buckminster core - i.e. it does not contain any of the optional plugins. They are easy to add, but it requires some work on your part.

You can read about the details and get step by step instruction on the Buckminster Packaging page.

How can I Stay Updated?

The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager.

For the Headless version, you need to read more on the Buckminster Packaging (and subsequent) pages as there are different options how to do this.