Difference between revisions of "Installing Buckminster"

From Eclipsepedia

Jump to: navigation, search
(After the Installation)
(Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4): Added the update site for Eclipse 3.7)
 
(48 intermediate revisions by 6 users not shown)
Line 1: Line 1:
 
{{Backlink|Buckminster Project}}
 
{{Backlink|Buckminster Project}}
=Installation=
 
  
Buckminster is available as a plugin to the Eclipse IDE.   There is also a stand alone “headless” version for command line usage,  which if you ever need it, is described [[#Installing the Headless Buckminster| later below]].
+
=Installation for Buckminster users=
 +
Buckminster is available as a plugin to the Eclipse IDE. There is also a stand alone “headless” version for command line usage,  which  is described in [[Installing Headless Buckminster]].
  
 
These steps describe a typical Buckminster installation for use in Eclipse IDE.  Note that the [http://subclipse.tigris.org/ Subclipse] plug-in is also typically used (see below):  Subclipse is an Eclipse Team Provider plug-in which provides support for the [http://subversion.tigris.org/ Subversion] version control system within the Eclipse IDE.
 
These steps describe a typical Buckminster installation for use in Eclipse IDE.  Note that the [http://subclipse.tigris.org/ Subclipse] plug-in is also typically used (see below):  Subclipse is an Eclipse Team Provider plug-in which provides support for the [http://subversion.tigris.org/ Subversion] version control system within the Eclipse IDE.
  
# Make sure you have Eclipse 3.2 or later installed.  Install it from [http://www.eclipse.org/downloads/ here] if you do not yet have it.
+
==Make sure you are using Eclipse 3.3 or later==
## Select <tt>Help > About Eclipse SDK</tt> and check the Version number.
+
*If you are starting from scratch it is it is recommended that you choose either the ''''''"Eclipse Classic"''''' or the ''''''"Eclipse for RCP/Plug-in Developers"''''' package. They both contain the PDE bundles required when Buckminster is working with features and plug-ins, otherwise those will have to be obtained separately.
## Currently, the Buckminster plugins do not check for a minimum Eclipse version. If you install the plugins on an earlier Eclipse version than 3.2, the installation may succeed, but you will probably however encounter many errors as you start using Buckminster.
+
*#Download either of the suggested packages from [http://www.eclipse.org/downloads/ http://www.eclipse.org/downloads/].
# Make sure you are using Java 5.0 or later. You can do that in Eclipse by:
+
*'''Or''' if Eclipse is installed make sure it is the correct version:
## Select <tt>Help > About Eclipse SDK  > Configuration Details</tt>.  Scroll down to the parameter <tt>java.runtime.version</tt> - it should start with 1.5 or later (as an example the line may look like this <tt>java.runtime.version=1.6.0_01-b016</tt>)
+
*#Select <tt>Help > About Eclipse SDK</tt> and check the Version number.
## If it does not start with at least 1.5, you need to update your java environment first:  you should find a version for your operating system [http://www.java.com/en/download/manual.jsp here].
+
# You will now use the ''Eclipse Update Manager'' to download Buckminster (and the subeclipse) plugin:
+
## Download this [http://wiki.eclipse.org/Buckminster_Update_Manager_Bookmarks Buckminster Update Manager Bookmarks] XML file,  and store it somewhere convenient on your computer (e.g. in a file called <tt>Bookmark.xml</tt>).  This file tells the Eclipse Update Manager about both Buckminster and the Subeclipse plugins.
+
## Select <tt>Help > Software Updates > Find and Install</tt> in the Java SDK.
+
## Select <tt>Search for new features to install</tt> and then the <tt>Next</tt> button.
+
## Select <tt>Import Sites...</tt> and browse your computer’s file system to select the Bookmarks file you saved at step 1. above. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
+
## Select <tt>Finish</tt>.  Eclipse will then display a window entitled <tt>Update Sites to Visit</tt> and will include the <tt>Buckminster Update Site</tt>,  and the <tt>Subclipse upate for 1.0</tt> amongst these:  make sure that both are selected.
+
## Eclipse may throw up a window entitled <tt>Update Site Mirrors</tt> for the <tt>Buckminster Update Site</tt>.  In this case,  we advise that you scroll down the list of mirror sites and pick the last entry,  ie <tt>Buckminster Update Site</tt> itself.  This is because occasionally a mirror site is not always in synchronization with the master site.
+
## Eclipse will then briefly throw up a window entitled <tt>Update Manager</tt>,  and when it has completed that step,  will automatically throw up another window entitled <tt>Updates with Search Results</tt>.  Select the <tt>Buckminster Update Site</tt> checkbox,  and then the <tt>Next</tt> button.
+
## Eclipse will then display a <tt>Feature License</tt> window,  and if you are happy with the terms of the license as displayed,  select the <tt>I accept</tt> button,  and then the <tt>Next</tt> button.
+
## Eclipse will then display the <tt>Install</tt> window,  for the Buckminster feature.  If you are happy with the default folder location,  select <tt>Finish</tt>.
+
## The <tt>Update Manager</tt>,  with a progress bar,  will display again.
+
## A <tt>Verification</tt> window will then be displayed,  indicating that the Buckminster feature is validly digitally signed.  If you are happy to proceed,  select the <tt>Install All</tt> button.
+
## The <tt>Update Manager</tt> will then briefly re-display,  followed by invitation to restart Eclipse to complete the installation of the plugin.  Select <tt>Yes</tt>.
+
# Eclipse should close down,  and automatically restart.
+
  
To confirm that Buckminster has now been installed,  check that the <tt>File > New > Other ></tt> has an entry for the Buckminster wizards; expanding the Buckminster box should show a number of available Buckminster wizards.
+
==Make sure you are using Java 5.0 or later==
 +
You can do that in Eclipse by:
 +
#Select <tt>Help > About Eclipse SDK  > Configuration Details</tt>.  Scroll down to the parameter <tt>java.runtime.version</tt> - it should start with 1.5 or later (as an example the line may look like this <tt>java.runtime.version=1.6.0_03-b03</tt>)
 +
#If it does not start with at least 1.5, you need to update your java environment first: you should find a version for your operating system [http://www.java.com/en/download/manual.jsp here].
  
  
Hopefully your installation has proceeded smoothly.  However,  here are some thoughts if things don't work out:
+
==Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4)==
* At the time of writing,  the Eclipse Update Manager (in general,  not just for Buckminster) is IMHO far from perfect,  and is currently being subject to revision.  Hopefully before the end of 2007,  there should be a better version.
+
Buckminster comes with a number of optional features. In order to obtain SVN support and allow Buckminster to communicate with SVN providers you have a choice to either use the Buckminster '''''Subversive''''' OR '''''Subclipse''''' integration. '''NOTE''' that those to features are '''mutually exclusive'''.
* If you have previously installed Buckminster,  you may need to un-install it before re-installing it as above - otherwise the re-install may fail. The safest way to do this is to find the Eclipse installation directory on your machine,  and remove anything that has <tt>buckminster</tt> in its name below the two folders <tt>plugins</tt> and <tt>features</tt>.  Then restart your Eclipse IDE again and proceed to re-install Buckminster.
+
* In step 3.5 above,  it may be prudent of you to select all the sites which are displayed to you to include in your search:  this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).
+
  
 +
The sections below describe the complete update steps for both choices.
  
+
===Option 1: Buckminster with Subversive integration===
==After the Installation==
+
#Select '''''Help > Software Updates''''' in the Eclipse IDE.
We suggest the next places you might want to take a look at are:
+
#Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
* The [[Introduction to Buckminster]] which gives some common usage scenariosexplaining how to materialize and consume software components; how to publish components to your colleagues and the wider community;  and how to prepare virtual distributions ("distros") using Buckminster.
+
#*Click on the tab labeled '''''Available Software'''''
* The [[Hello XML World Example (Buckminster)]] which illustrates how a materialization can be done, and uses different types of components - Eclipse plugins and stand alone files.
+
#*The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
 +
#*# Download this [[Buckminster and Subversive Update Manager Bookmarks]] XML file,  and store it somewhere convenient(e.g. in a file called ''bookmarks.xml''). This file tells the Eclipse Update Manager about both Buckminster and the Subversive and SVN plugins required by Buckminster.
 +
#*# Select '''''Manage Sites...'''''
 +
#*# Select '''''Import...''''' and browse the bookmarks file. The update sites for Buckminster and Subversive/Subclipse will then be added to the list of available sites.
 +
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
 +
#*#Buckminster 3.4 update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
 +
#*#Buckminster 3.7 update site: '''[http://download.eclipse.org/tools/buckminster/updates-3.7 http://download.eclipse.org/tools/buckminster/updates-3.7]'''
 +
#*#Subversive integration requires two update sites:
 +
#*#*Subversive client: '''[http://download.eclipse.org/technology/subversive/0.7/update-site/ http://download.eclipse.org/technology/subversive/0.7/update-site/]''' (more information on Subversive is available [http://www.eclipse.org/subversive/index.php here])
 +
#*#*Subversive SVN Connectors: '''[http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/ http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/]'''
 +
#Install the needed features:
 +
#*For Buckminster:
 +
#*#Select all core Buckminster features.
 +
#*#Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found [[Buckminster Optional Features|here]].
 +
#*#In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
 +
#*For Subversive:
 +
#*#Select the core Subversive Team provider features.
 +
#*#There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
 +
#*#Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
 +
# Proceed with '''''Install...'''''. Eclipse will then ask you to '''''Review Licenses''''', and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Finish'''''.
 +
#The '''''Update Manager''''' will indicate the download progress and then recommend that you restart your IDE.
  
=Getting to Know the Concepts=
+
===Option 2: Buckminster with Subclipse integration===
 +
#Select '''''Help > Software Updates''''' in the Eclipse IDE.
 +
#Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
 +
#*Click on the tab labeled '''''Available Software'''''
 +
#*The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
 +
#*# Download this [[Buckminster and Subclipse Update Manager Bookmarks]] XML file,  and store it somewhere convenient(e.g. in a file called ''bookmarks.xml'').  This file tells the Eclipse Update Manager about both Buckminster and the Subclipse plugins required by Buckminster.
 +
#*# Select '''''Import Sites...''''' and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
 +
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
 +
#*#Buckminster 3.4 update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
 +
#*#Buckminster 3.7 update site: '''[http://download.eclipse.org/tools/buckminster/updates-3.7 http://download.eclipse.org/tools/buckminster/updates-3.7]'''
 +
#*#Subclipse update site: '''[http://subclipse.tigris.org/update_1.4.x http://subclipse.tigris.org/update_1.4.x]''' (more information on Subclipse is available [http://subclipse.tigris.org/ here])
 +
#Install the needed features:
 +
#*For Buckminster:
 +
#*#Select all core Buckminster features.
 +
#*#Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found [[Buckminster Optional Features|here]].
 +
#*#In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
 +
#*For Subclipse:
 +
#*#Select the core Subclipse features.
 +
#*#Select the Subclipse Buckminster integration feature.
 +
#*#There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
 +
#*#Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
 +
# Proceed with '''''Install...'''''. Eclipse will then ask you to '''''Review Licenses''''', and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Finish'''''.
 +
#The '''''Update Manager''''' will indicate the download progress and then recommend that you restart your IDE.
  
A first step in starting to use Buckminster is to get to grips with Buckminster concepts and terminology. The [[Introduction to Buckminster]] is a good starting to point to get a basic understanding of Buckminster.
+
==Wrapping up==
 +
To confirm that Buckminster has now been installed,  check that the <tt>File > New > Other ></tt> has an entry for the Buckminster wizards;  expanding the Buckminster box should show a number of available Buckminster wizards.
  
The next thing to get a better understanding of is the [[Buckminster Resource Map|Resource Map]] as this gets you an understanding of from where and how Buckminster gets components. Then you need to look at [[Buckminster Component Type|Component Type]] since a component type is responsible for producing dependency information for a component, and this is done differently depending on the type of component.
+
Hopefully your installation has proceeded smoothly.  However,  here are some thoughts if things don't work out:
 +
* If you have previously installed Buckminster,  you may need to un-install it before re-installing it as above - otherwise the re-install may fail.  The safest way to do this is to find the Eclipse installation directory on your machine,  and remove anything that has ''buckminster'' in its name below the two folders ''plugins'' and ''features''. Then restart your Eclipse IDE again and proceed to re-install Buckminster. (Note that this is required because the Eclipse Update Manager does not always do the right thing. This type of problem will go away with the newer Eclipse p2 based manager - and when using p2, it is a very bad idea to just delete things in the installation).
 +
* In update site selection step described above, it may be prudent of you to select all the sites which are displayed to you to include in your search:  this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).
  
Now you should understand how components can be made, depend on each other in different situations, and how Buckminster use this information to materialize the components into your workspace.
+
=Installation for Buckminster contributors=
 +
As a contributor you will first have to follow the instructions in [[#Installation for Buckminster users|Installation for Buckminster users]]. If you intend to contribute to Buckminster, or plan to extend Buckminster you will want to get hold of the latest Buckminster source. Naturally, you will use Buckminster to get itself and use the following Buckminster CQUERY to obtain it:
  
To make something happen, you need to understand the [[Buckminster Component Query|Component Query]] as that is the starting point of getting something resolved and materialized.
+
*For '''head development''' [http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery]  
 +
*For '''eclipse 3.4.x''' [http://www.eclipse.org/buckminster/samples/queries/buckminster.cquery http://www.eclipse.org/buckminster/samples/queries/buckminster.cquery]
  
==My First Materialization==
+
When resolving this query you MUST ensure that your Eclipse installation is 3.4 and contains the RCP delta pack.
 +
#Go to [http://download.eclipse.org/eclipse/downloads/ http://download.eclipse.org/eclipse/downloads/].
 +
#Select the latest release.
 +
#Navigate to the '''''RCP SDK''''' section where you will find a download link for the ''"RCP delta pack"'' zip.
 +
#Download and unpack into your Eclipse installation directory.
 +
#Restart Eclipse and execute the '''[http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery buckminster-dev.cquery]''' which should now happily resolve and materialize the latest Buckminster source into your workspace.
  
You are probably anxious to try Buckminster in action, but on what? To help you out, there is a [[Sharing a Project (Buckminster)|Sharing a Project]] demo with more detailed explanations in the [[Hello XML World Example (Buckminster)|Hello XML World Example]]. You can materialize this project, just like in the demo. There is also a Buckminster 'dog-fooding' example that the Buckminster team uses to develop Buckminster, so if your are interested, you can materialize the Buckminster project.
 
You can also try to materialize the source of the Eclipse Monkey project as described on the Monkey [http://www.eclipse.org/dash/monkey-help.php?key=source-code Getting and Working with the Source Code] page.
 
  
==Buckminster on Your Projects==
 
  
To run Buckminster on your own projects, there are a few things to think about. How are your components organized? Do you even have components? If everything is in one big project pile (a monolith) - how do you organize it into components?
+
=How can I Stay Updated?=
 +
The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager/p2.
  
Even if your own project is not broken up into individual components, you are perhaps including 3d party components, or indeed components from open source projects.
+
=After the Installation=
 
+
We suggest the next places you might want to take a look at are:
Basically these are the steps you need to take:
+
* The [[Why Buckminster ?]] document gives a high level overview of the motivation for,  and concepts in, Buckminster, without getting into details of any (XML) code fragments.
# Make sure that the components are available for download in the form your intended audience wants (source, binary, etc.), and being in a repository of a type supported by Buckminster (Eclipse update site, CVS, SVN, Maven, etc.).
+
* The [[Hello XML World Example (Buckminster)]] which illustrates in detail how a materialization can be done, and uses different types of components - Eclipse plugins and stand alone files.
## If your component does not contain dependency information, you also need to add a [[Buckminster Component Specification|Component Specification]] describing the dependencies. This can be done by hand, or in Eclipse by 'adding the Buckminster nature' to the project and then editing the .cspec file.
+
* The [[Introduction to Buckminster]] which gives some common usage scenarios,  explaining how to materialize and consume software components;  how to publish components to your colleagues and the wider community;  and how to prepare virtual distributions ("distros") using Buckminster.
## Note that if you do have components that already have dependency information (such as for Eclipse plug-ins, Buckminster uses this information directly, and instead of creating a full component specification, you can extend the specification created from the 'plug-in' (or whatever the source of dependency information was). See [[Component Specification Extension (Buckminster)|Component Specification Extension]].
+
# Create a [[Buckminster Resource Map|Resource Map]] that tells where to find your component(s) and all components they depend on. Make this resource map available to your audience via a URL (i.e. put in up on a website they can reach).
+
# Create a [[Buckminster Component Query|Component Query]] where you enter the URL to the resourcemap, and any other settings as apropriate for the query.
+
# Make the component query file (.cquery) available via a URL and hand this URL out to your audience.
+
## Give them instructions to use "File > Open" and to enter the .cquery URL, and to press "Resolve and Materialize" (here is an instruction example from the [http://www.eclipse.org/dash/monkey-help.php?key=source-code Eclipse-Monkey] project).
+
 
+
As an example, this is the cquery file for the Eclipse Monkey.
+
<pre>
+
<?xml version="1.0" encoding="UTF-8"?>
+
<cq:componentQuery xmlns:cq="http://www.eclipse.org/buckminster/CQuery-1.0" resourceMap="http://www.eclipse.org/dash/monkey/monkey.rmap">
+
    <cq:rootRequest name="org.eclipse.eclipsemonkey-feature" versionType="OSGi"/>
+
</cq:componentQuery>
+
</pre>
+
''CQuery for Eclipse Monkey''
+
 
+
As you see, all it does is pointing at the RMAP URL, and stating that version strings are expressed in OSGi notation.
+
 
+
And here is the RMAP for the Eclipse Monkey.
+
<pre>
+
<?xml version="1.0" encoding="UTF-8"?>
+
<rm:rmap
+
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+
xmlns:rm="http://www.eclipse.org/buckminster/RMap-1.0"
+
xmlns:mp="http://www.eclipse.org/buckminster/MavenProvider-1.0"
+
xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0">
+
 
+
<rm:site name="default">
+
</rm:site>
+
 
+
<rm:searchPath name="dash">
+
<rm:provider readerType="cvs" componentType="eclipse-project" mutable="true" source="true">
+
<rm:uri format=":pserver:anonymous@dev.eclipse.org:/cvsroot/technology,org.eclipse.dash/{0}">
+
<bc:property key="buckminster.component" />
+
</rm:uri>
+
</rm:provider>
+
</rm:searchPath>
+
 
+
<rm:locator searchPathRef="dash" pattern="^org\.eclipse\.eclipsemonkey([\.\-].+)?" />
+
<rm:locator searchPathRef="dash" pattern="^org\.eclipse\.eclipsemonkey-feature" />
+
<rm:locator searchPathRef="dash" pattern="^org\.eclipse\.dash(\..+)?" />
+
<rm:locator searchPathRef="dash" pattern="^org\.mozilla\.rhino" />
+
 
+
</rm:rmap>
+
</pre>
+
''RMAP for Eclipse Monkey''
+
 
+
[[Category:Buckminster]]
+
[[Category:Buckminster Documentation]]
+
 
+
=Installing the Headless Buckminster=
+
Buckminster is also packaged in a so called 'Headless' command line oriented version suitable for running on remote servers, be invoked from scripts etc. The Headless version is based on Eclipse but only includes what is needed to run as a command line tool. The footprint of the headless version is thus much smaller than for the complete Eclipse IDE.
+
 
+
The Headless version as it is delivered today requires configuration before use. The downloadable version only contains the Buckminster core - i.e. it does not contain any of the optional plugins. They are easy to add, but it requires some work on your part.
+
 
+
You can read about the details and get step by step instruction on the [[Buckminster Packaging]] page.
+
+
=How can I Stay Updated?=
+
The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager.
+
  
For the Headless version, you need to read more on the [[Buckminster Packaging]] (and subsequent) pages as there are different options how to do this.
 
  
 
[[Category:Buckminster]]
 
[[Category:Buckminster]]
[[Category:Buckminster Documentation]]
+
[[Category:Buckminster Introduction]]

Latest revision as of 04:11, 1 June 2012

< To: Buckminster Project

Contents

[edit] Installation for Buckminster users

Buckminster is available as a plugin to the Eclipse IDE. There is also a stand alone “headless” version for command line usage, which is described in Installing Headless Buckminster.

These steps describe a typical Buckminster installation for use in Eclipse IDE. Note that the Subclipse plug-in is also typically used (see below): Subclipse is an Eclipse Team Provider plug-in which provides support for the Subversion version control system within the Eclipse IDE.

[edit] Make sure you are using Eclipse 3.3 or later

  • If you are starting from scratch it is it is recommended that you choose either the '"Eclipse Classic" or the '"Eclipse for RCP/Plug-in Developers" package. They both contain the PDE bundles required when Buckminster is working with features and plug-ins, otherwise those will have to be obtained separately.
    1. Download either of the suggested packages from http://www.eclipse.org/downloads/.
  • Or if Eclipse is installed make sure it is the correct version:
    1. Select Help > About Eclipse SDK and check the Version number.

[edit] Make sure you are using Java 5.0 or later

You can do that in Eclipse by:

  1. Select Help > About Eclipse SDK > Configuration Details. Scroll down to the parameter java.runtime.version - it should start with 1.5 or later (as an example the line may look like this java.runtime.version=1.6.0_03-b03)
  2. If it does not start with at least 1.5, you need to update your java environment first: you should find a version for your operating system here.


[edit] Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4)

Buckminster comes with a number of optional features. In order to obtain SVN support and allow Buckminster to communicate with SVN providers you have a choice to either use the Buckminster Subversive OR Subclipse integration. NOTE that those to features are mutually exclusive.

The sections below describe the complete update steps for both choices.

[edit] Option 1: Buckminster with Subversive integration

  1. Select Help > Software Updates in the Eclipse IDE.
  2. Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
  3. Install the needed features:
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found here.
      3. In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
    • For Subversive:
      1. Select the core Subversive Team provider features.
      2. There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
      3. Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
  4. Proceed with Install.... Eclipse will then ask you to Review Licenses, and if you are happy with the terms of the license as displayed, accept them, and then do Finish.
  5. The Update Manager will indicate the download progress and then recommend that you restart your IDE.

[edit] Option 2: Buckminster with Subclipse integration

  1. Select Help > Software Updates in the Eclipse IDE.
  2. Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
    • Click on the tab labeled Available Software
    • The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
      1. Download this Buckminster and Subclipse Update Manager Bookmarks XML file, and store it somewhere convenient(e.g. in a file called bookmarks.xml). This file tells the Eclipse Update Manager about both Buckminster and the Subclipse plugins required by Buckminster.
      2. Select Import Sites... and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
    • Alternatively, you can enter the update sites individually by choosing Add Site ... and then enter a URL. This step has to be repeated for each site that you wish to add.
      1. Buckminster 3.4 update site: http://download.eclipse.org/tools/buckminster/updates
      2. Buckminster 3.7 update site: http://download.eclipse.org/tools/buckminster/updates-3.7
      3. Subclipse update site: http://subclipse.tigris.org/update_1.4.x (more information on Subclipse is available here)
  3. Install the needed features:
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found here.
      3. In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
    • For Subclipse:
      1. Select the core Subclipse features.
      2. Select the Subclipse Buckminster integration feature.
      3. There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
      4. Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
  4. Proceed with Install.... Eclipse will then ask you to Review Licenses, and if you are happy with the terms of the license as displayed, accept them, and then do Finish.
  5. The Update Manager will indicate the download progress and then recommend that you restart your IDE.

[edit] Wrapping up

To confirm that Buckminster has now been installed, check that the File > New > Other > has an entry for the Buckminster wizards; expanding the Buckminster box should show a number of available Buckminster wizards.

Hopefully your installation has proceeded smoothly. However, here are some thoughts if things don't work out:

  • If you have previously installed Buckminster, you may need to un-install it before re-installing it as above - otherwise the re-install may fail. The safest way to do this is to find the Eclipse installation directory on your machine, and remove anything that has buckminster in its name below the two folders plugins and features. Then restart your Eclipse IDE again and proceed to re-install Buckminster. (Note that this is required because the Eclipse Update Manager does not always do the right thing. This type of problem will go away with the newer Eclipse p2 based manager - and when using p2, it is a very bad idea to just delete things in the installation).
  • In update site selection step described above, it may be prudent of you to select all the sites which are displayed to you to include in your search: this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).

[edit] Installation for Buckminster contributors

As a contributor you will first have to follow the instructions in Installation for Buckminster users. If you intend to contribute to Buckminster, or plan to extend Buckminster you will want to get hold of the latest Buckminster source. Naturally, you will use Buckminster to get itself and use the following Buckminster CQUERY to obtain it:

When resolving this query you MUST ensure that your Eclipse installation is 3.4 and contains the RCP delta pack.

  1. Go to http://download.eclipse.org/eclipse/downloads/.
  2. Select the latest release.
  3. Navigate to the RCP SDK section where you will find a download link for the "RCP delta pack" zip.
  4. Download and unpack into your Eclipse installation directory.
  5. Restart Eclipse and execute the buckminster-dev.cquery which should now happily resolve and materialize the latest Buckminster source into your workspace.


[edit] How can I Stay Updated?

The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager/p2.

[edit] After the Installation

We suggest the next places you might want to take a look at are:

  • The Why Buckminster ? document gives a high level overview of the motivation for, and concepts in, Buckminster, without getting into details of any (XML) code fragments.
  • The Hello XML World Example (Buckminster) which illustrates in detail how a materialization can be done, and uses different types of components - Eclipse plugins and stand alone files.
  • The Introduction to Buckminster which gives some common usage scenarios, explaining how to materialize and consume software components; how to publish components to your colleagues and the wider community; and how to prepare virtual distributions ("distros") using Buckminster.