Jump to: navigation, search

Difference between revisions of "Installing Buckminster"

(Installation for Buckminster users)
(Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4): Added the update site for Eclipse 3.7)
 
(4 intermediate revisions by 2 users not shown)
Line 2: Line 2:
  
 
=Installation for Buckminster users=
 
=Installation for Buckminster users=
Buckminster is available as a plugin to the Eclipse IDE.   There is also a stand alone “headless” version for command line usage,  which if you ever need it, is described in [[Installing Headless Buckminster]].
+
Buckminster is available as a plugin to the Eclipse IDE. There is also a stand alone “headless” version for command line usage,  which  is described in [[Installing Headless Buckminster]].
  
 
These steps describe a typical Buckminster installation for use in Eclipse IDE.  Note that the [http://subclipse.tigris.org/ Subclipse] plug-in is also typically used (see below):  Subclipse is an Eclipse Team Provider plug-in which provides support for the [http://subversion.tigris.org/ Subversion] version control system within the Eclipse IDE.
 
These steps describe a typical Buckminster installation for use in Eclipse IDE.  Note that the [http://subclipse.tigris.org/ Subclipse] plug-in is also typically used (see below):  Subclipse is an Eclipse Team Provider plug-in which provides support for the [http://subversion.tigris.org/ Subversion] version control system within the Eclipse IDE.
Line 32: Line 32:
 
#*# Select '''''Import...''''' and browse the bookmarks file. The update sites for Buckminster and Subversive/Subclipse will then be added to the list of available sites.
 
#*# Select '''''Import...''''' and browse the bookmarks file. The update sites for Buckminster and Subversive/Subclipse will then be added to the list of available sites.
 
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
 
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
#*#Buckminster update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
+
#*#Buckminster 3.4 update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
 +
#*#Buckminster 3.7 update site: '''[http://download.eclipse.org/tools/buckminster/updates-3.7 http://download.eclipse.org/tools/buckminster/updates-3.7]'''
 
#*#Subversive integration requires two update sites:  
 
#*#Subversive integration requires two update sites:  
 
#*#*Subversive client: '''[http://download.eclipse.org/technology/subversive/0.7/update-site/ http://download.eclipse.org/technology/subversive/0.7/update-site/]''' (more information on Subversive is available [http://www.eclipse.org/subversive/index.php here])
 
#*#*Subversive client: '''[http://download.eclipse.org/technology/subversive/0.7/update-site/ http://download.eclipse.org/technology/subversive/0.7/update-site/]''' (more information on Subversive is available [http://www.eclipse.org/subversive/index.php here])
Line 56: Line 57:
 
#*# Select '''''Import Sites...''''' and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
 
#*# Select '''''Import Sites...''''' and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
 
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
 
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
#*#Buckminster update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
+
#*#Buckminster 3.4 update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
 +
#*#Buckminster 3.7 update site: '''[http://download.eclipse.org/tools/buckminster/updates-3.7 http://download.eclipse.org/tools/buckminster/updates-3.7]'''
 
#*#Subclipse update site: '''[http://subclipse.tigris.org/update_1.4.x http://subclipse.tigris.org/update_1.4.x]''' (more information on Subclipse is available [http://subclipse.tigris.org/ here])
 
#*#Subclipse update site: '''[http://subclipse.tigris.org/update_1.4.x http://subclipse.tigris.org/update_1.4.x]''' (more information on Subclipse is available [http://subclipse.tigris.org/ here])
 
#Install the needed features:
 
#Install the needed features:
Line 94: Line 96:
  
 
=How can I Stay Updated?=
 
=How can I Stay Updated?=
The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager.
+
The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager/p2.
 
+
For the Headless version, you need to read more on the [[Buckminster Packaging]] (and subsequent) pages as there are different options how to do this.
+
 
+
  
 
=After the Installation=
 
=After the Installation=

Latest revision as of 04:11, 1 June 2012

< To: Buckminster Project

Installation for Buckminster users

Buckminster is available as a plugin to the Eclipse IDE. There is also a stand alone “headless” version for command line usage, which is described in Installing Headless Buckminster.

These steps describe a typical Buckminster installation for use in Eclipse IDE. Note that the Subclipse plug-in is also typically used (see below): Subclipse is an Eclipse Team Provider plug-in which provides support for the Subversion version control system within the Eclipse IDE.

Make sure you are using Eclipse 3.3 or later

  • If you are starting from scratch it is it is recommended that you choose either the '"Eclipse Classic" or the '"Eclipse for RCP/Plug-in Developers" package. They both contain the PDE bundles required when Buckminster is working with features and plug-ins, otherwise those will have to be obtained separately.
    1. Download either of the suggested packages from http://www.eclipse.org/downloads/.
  • Or if Eclipse is installed make sure it is the correct version:
    1. Select Help > About Eclipse SDK and check the Version number.

Make sure you are using Java 5.0 or later

You can do that in Eclipse by:

  1. Select Help > About Eclipse SDK > Configuration Details. Scroll down to the parameter java.runtime.version - it should start with 1.5 or later (as an example the line may look like this java.runtime.version=1.6.0_03-b03)
  2. If it does not start with at least 1.5, you need to update your java environment first: you should find a version for your operating system here.


Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4)

Buckminster comes with a number of optional features. In order to obtain SVN support and allow Buckminster to communicate with SVN providers you have a choice to either use the Buckminster Subversive OR Subclipse integration. NOTE that those to features are mutually exclusive.

The sections below describe the complete update steps for both choices.

Option 1: Buckminster with Subversive integration

  1. Select Help > Software Updates in the Eclipse IDE.
  2. Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
  3. Install the needed features:
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found here.
      3. In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
    • For Subversive:
      1. Select the core Subversive Team provider features.
      2. There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
      3. Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
  4. Proceed with Install.... Eclipse will then ask you to Review Licenses, and if you are happy with the terms of the license as displayed, accept them, and then do Finish.
  5. The Update Manager will indicate the download progress and then recommend that you restart your IDE.

Option 2: Buckminster with Subclipse integration

  1. Select Help > Software Updates in the Eclipse IDE.
  2. Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
    • Click on the tab labeled Available Software
    • The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
      1. Download this Buckminster and Subclipse Update Manager Bookmarks XML file, and store it somewhere convenient(e.g. in a file called bookmarks.xml). This file tells the Eclipse Update Manager about both Buckminster and the Subclipse plugins required by Buckminster.
      2. Select Import Sites... and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
    • Alternatively, you can enter the update sites individually by choosing Add Site ... and then enter a URL. This step has to be repeated for each site that you wish to add.
      1. Buckminster 3.4 update site: http://download.eclipse.org/tools/buckminster/updates
      2. Buckminster 3.7 update site: http://download.eclipse.org/tools/buckminster/updates-3.7
      3. Subclipse update site: http://subclipse.tigris.org/update_1.4.x (more information on Subclipse is available here)
  3. Install the needed features:
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found here.
      3. In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
    • For Subclipse:
      1. Select the core Subclipse features.
      2. Select the Subclipse Buckminster integration feature.
      3. There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
      4. Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
  4. Proceed with Install.... Eclipse will then ask you to Review Licenses, and if you are happy with the terms of the license as displayed, accept them, and then do Finish.
  5. The Update Manager will indicate the download progress and then recommend that you restart your IDE.

Wrapping up

To confirm that Buckminster has now been installed, check that the File > New > Other > has an entry for the Buckminster wizards; expanding the Buckminster box should show a number of available Buckminster wizards.

Hopefully your installation has proceeded smoothly. However, here are some thoughts if things don't work out:

  • If you have previously installed Buckminster, you may need to un-install it before re-installing it as above - otherwise the re-install may fail. The safest way to do this is to find the Eclipse installation directory on your machine, and remove anything that has buckminster in its name below the two folders plugins and features. Then restart your Eclipse IDE again and proceed to re-install Buckminster. (Note that this is required because the Eclipse Update Manager does not always do the right thing. This type of problem will go away with the newer Eclipse p2 based manager - and when using p2, it is a very bad idea to just delete things in the installation).
  • In update site selection step described above, it may be prudent of you to select all the sites which are displayed to you to include in your search: this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).

Installation for Buckminster contributors

As a contributor you will first have to follow the instructions in Installation for Buckminster users. If you intend to contribute to Buckminster, or plan to extend Buckminster you will want to get hold of the latest Buckminster source. Naturally, you will use Buckminster to get itself and use the following Buckminster CQUERY to obtain it:

When resolving this query you MUST ensure that your Eclipse installation is 3.4 and contains the RCP delta pack.

  1. Go to http://download.eclipse.org/eclipse/downloads/.
  2. Select the latest release.
  3. Navigate to the RCP SDK section where you will find a download link for the "RCP delta pack" zip.
  4. Download and unpack into your Eclipse installation directory.
  5. Restart Eclipse and execute the buckminster-dev.cquery which should now happily resolve and materialize the latest Buckminster source into your workspace.


How can I Stay Updated?

The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager/p2.

After the Installation

We suggest the next places you might want to take a look at are:

  • The Why Buckminster ? document gives a high level overview of the motivation for, and concepts in, Buckminster, without getting into details of any (XML) code fragments.
  • The Hello XML World Example (Buckminster) which illustrates in detail how a materialization can be done, and uses different types of components - Eclipse plugins and stand alone files.
  • The Introduction to Buckminster which gives some common usage scenarios, explaining how to materialize and consume software components; how to publish components to your colleagues and the wider community; and how to prepare virtual distributions ("distros") using Buckminster.