Jump to: navigation, search

Difference between revisions of "Installing Buckminster"

(Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4): Added the update site for Eclipse 3.7)
 
(13 intermediate revisions by 4 users not shown)
Line 2: Line 2:
  
 
=Installation for Buckminster users=
 
=Installation for Buckminster users=
Buckminster is available as a plugin to the Eclipse IDE.   There is also a stand alone “headless” version for command line usage,  which if you ever need it, is described [[#Installing the Headless Buckminster| later below]].
+
Buckminster is available as a plugin to the Eclipse IDE. There is also a stand alone “headless” version for command line usage,  which  is described in [[Installing Headless Buckminster]].
  
 
These steps describe a typical Buckminster installation for use in Eclipse IDE.  Note that the [http://subclipse.tigris.org/ Subclipse] plug-in is also typically used (see below):  Subclipse is an Eclipse Team Provider plug-in which provides support for the [http://subversion.tigris.org/ Subversion] version control system within the Eclipse IDE.
 
These steps describe a typical Buckminster installation for use in Eclipse IDE.  Note that the [http://subclipse.tigris.org/ Subclipse] plug-in is also typically used (see below):  Subclipse is an Eclipse Team Provider plug-in which provides support for the [http://subversion.tigris.org/ Subversion] version control system within the Eclipse IDE.
  
 
==Make sure you are using Eclipse 3.3 or later==
 
==Make sure you are using Eclipse 3.3 or later==
At the time of writing you will have to '''make sure you have Eclipse 3.3 or later with PDE bundles installed.''' 
+
*If you are starting from scratch it is it is recommended that you choose either the ''''''"Eclipse Classic"''''' or the ''''''"Eclipse for RCP/Plug-in Developers"''''' package. They both contain the PDE bundles required when Buckminster is working with features and plug-ins, otherwise those will have to be obtained separately.  
 
+
*If you are starting from scratch it is it is recommended that you choose either the ''''''"Eclipse Classic"''''' or the ''''''"Eclipse for RCP/Plug-in Developers"''''' package. They both contain the PDE bundles required by Buckminster, otherwise those will have to be obtained separately.  
+
 
*#Download either of the suggested packages from [http://www.eclipse.org/downloads/ http://www.eclipse.org/downloads/].
 
*#Download either of the suggested packages from [http://www.eclipse.org/downloads/ http://www.eclipse.org/downloads/].
 
*'''Or''' if Eclipse is installed make sure it is the correct version:  
 
*'''Or''' if Eclipse is installed make sure it is the correct version:  
 
*#Select <tt>Help > About Eclipse SDK</tt> and check the Version number.
 
*#Select <tt>Help > About Eclipse SDK</tt> and check the Version number.
*#Currently, the Buckminster plugins do not check for a minimum Eclipse version. If you install the plugins on an earlier Eclipse version, the installation may succeed, but you will probably however encounter many errors as you start using Buckminster.
 
  
 
==Make sure you are using Java 5.0 or later==  
 
==Make sure you are using Java 5.0 or later==  
 
You can do that in Eclipse by:
 
You can do that in Eclipse by:
#Select <tt>Help > About Eclipse SDK  > Configuration Details</tt>.  Scroll down to the parameter <tt>java.runtime.version</tt> - it should start with 1.5 or later (as an example the line may look like this <tt>java.runtime.version=1.6.0_01-b016</tt>)
+
#Select <tt>Help > About Eclipse SDK  > Configuration Details</tt>.  Scroll down to the parameter <tt>java.runtime.version</tt> - it should start with 1.5 or later (as an example the line may look like this <tt>java.runtime.version=1.6.0_03-b03</tt>)
 
#If it does not start with at least 1.5, you need to update your java environment first:  you should find a version for your operating system [http://www.java.com/en/download/manual.jsp here].
 
#If it does not start with at least 1.5, you need to update your java environment first:  you should find a version for your operating system [http://www.java.com/en/download/manual.jsp here].
  
  
==Download Buckminster with the Eclipse Update Manager==
+
==Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4)==
Buckminster comes with a number of optional features. In order to obtain SVN support and allow Buckminster to communicate with SVN providers you have a choice to either use the Buckminster '''''Subclipse''''' OR '''''Subversive''''' integration. '''NOTE''' that those to features are '''mutually exclusive'''.
+
Buckminster comes with a number of optional features. In order to obtain SVN support and allow Buckminster to communicate with SVN providers you have a choice to either use the Buckminster '''''Subversive''''' OR '''''Subclipse''''' integration. '''NOTE''' that those to features are '''mutually exclusive'''.
  
 
The sections below describe the complete update steps for both choices.  
 
The sections below describe the complete update steps for both choices.  
  
 
===Option 1: Buckminster with Subversive integration===
 
===Option 1: Buckminster with Subversive integration===
#Select '''''Help > Software Updates > Find and Install''''' in the Eclipse IDE.
+
#Select '''''Help > Software Updates''''' in the Eclipse IDE.
#Select '''''Search for new features to install''''' and then the '''''Next''''' button.
+
#Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
#Provide the update manager with the required information for the Buckminster and Subversive/SVN update sites:
+
#*Click on the tab labeled '''''Available Software'''''
 
#*The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
 
#*The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
 
#*# Download this [[Buckminster and Subversive Update Manager Bookmarks]] XML file,  and store it somewhere convenient(e.g. in a file called ''bookmarks.xml'').  This file tells the Eclipse Update Manager about both Buckminster and the Subversive and SVN plugins required by Buckminster.  
 
#*# Download this [[Buckminster and Subversive Update Manager Bookmarks]] XML file,  and store it somewhere convenient(e.g. in a file called ''bookmarks.xml'').  This file tells the Eclipse Update Manager about both Buckminster and the Subversive and SVN plugins required by Buckminster.  
#*# Select '''''Import Sites...''''' and browse the bookmarks file. The update sites for Buckminster and Subversive will then be added to the list of available sites.
+
#*# Select '''''Manage Sites...'''''
#*Alternatively, you can enter the update sites individually by choosing '''''New Remote Site ...''''' and then add:
+
#*# Select '''''Import...''''' and browse the bookmarks file. The update sites for Buckminster and Subversive/Subclipse will then be added to the list of available sites.
#*#Buckminster update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
+
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
#*#Subversive integration requires two update site:  
+
#*#Buckminster 3.4 update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
 +
#*#Buckminster 3.7 update site: '''[http://download.eclipse.org/tools/buckminster/updates-3.7 http://download.eclipse.org/tools/buckminster/updates-3.7]'''
 +
#*#Subversive integration requires two update sites:  
 
#*#*Subversive client: '''[http://download.eclipse.org/technology/subversive/0.7/update-site/ http://download.eclipse.org/technology/subversive/0.7/update-site/]''' (more information on Subversive is available [http://www.eclipse.org/subversive/index.php here])
 
#*#*Subversive client: '''[http://download.eclipse.org/technology/subversive/0.7/update-site/ http://download.eclipse.org/technology/subversive/0.7/update-site/]''' (more information on Subversive is available [http://www.eclipse.org/subversive/index.php here])
 
#*#*Subversive SVN Connectors: '''[http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/ http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/]'''
 
#*#*Subversive SVN Connectors: '''[http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/ http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/]'''
#Make sure all three update sites are selected and then press '''''Finish'''''. 
+
#Install the needed features:
#Eclipse may throw up a window entitled '''''Update Site Mirrors'''''. Pick the most appropriate. For '''''Buckminster Update Site''''' we advise that you pick the main Buckminster Update Site as occasionally a mirror site is not always in synchronization with the master site and Buckminster is frequently updated.
+
#Eclipse will then display a window entitled '''''Search Results''''' which should include the specified Buckminster and Subversive/SVN Connector upate sites.
+
 
#*For Buckminster:
 
#*For Buckminster:
 
#*#Select all core Buckminster features.
 
#*#Select all core Buckminster features.
#*#Select the Subversive integration and and other optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found [[Buckminster Optional Features|here]].
+
#*#Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found [[Buckminster Optional Features|here]].
#*#In particular, DO NOT SELECT the Subversive integration feature.
+
#*#In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
 
#*For Subversive:
 
#*For Subversive:
 
#*#Select the core Subversive Team provider features.
 
#*#Select the core Subversive Team provider features.
 
#*#There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
 
#*#There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
#*For SVN Connectors:
+
#*#Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
#*#Select the all core SVN Connector features.
+
# Proceed with '''''Install...'''''. Eclipse will then ask you to '''''Review Licenses''''', and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Finish'''''.
#*#There may be other optional features but they are not required for Buckminster.
+
#The '''''Update Manager''''' will indicate the download progress and then recommend that you restart your IDE.
# Proceed with '''''Finish'''''. Eclipse will then display a '''''Feature License''''' window, and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Next'''''.
+
# Eclipse will then display the '''''Installation''''' window  for the selected features.  Accept the default folder locations and select '''''Finish'''''.
+
#The '''''Update Manager''''' will indicate the download progress and display a '''''Feature Verification''''' window upon completion. If you are happy to proceed,  select the '''''Install''''' or simply '''''Install All'''''.
+
#The installation should be finished with a restart of Eclipse.
+
  
 
===Option 2: Buckminster with Subclipse integration===
 
===Option 2: Buckminster with Subclipse integration===
#Select '''''Help > Software Updates > Find and Install''''' in the Eclipse IDE.
+
#Select '''''Help > Software Updates''''' in the Eclipse IDE.
#Select '''''Search for new features to install''''' and then the '''''Next''''' button.
+
#Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
#Provide the update manager with the required information for the Buckminster and Subclipse update sites:
+
#*Click on the tab labeled '''''Available Software'''''
 
#*The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
 
#*The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
 
#*# Download this [[Buckminster and Subclipse Update Manager Bookmarks]] XML file,  and store it somewhere convenient(e.g. in a file called ''bookmarks.xml'').  This file tells the Eclipse Update Manager about both Buckminster and the Subclipse plugins required by Buckminster.  
 
#*# Download this [[Buckminster and Subclipse Update Manager Bookmarks]] XML file,  and store it somewhere convenient(e.g. in a file called ''bookmarks.xml'').  This file tells the Eclipse Update Manager about both Buckminster and the Subclipse plugins required by Buckminster.  
 
#*# Select '''''Import Sites...''''' and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
 
#*# Select '''''Import Sites...''''' and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
#*Alternatively, you can enter the update sites individually by choosing '''''New Remote Site ...''''' and then add:
+
#*Alternatively, you can enter the update sites individually by choosing '''''Add Site ...''''' and then enter a URL. This step has to be repeated for each site that you wish to add.
#*#Buckminster update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
+
#*#Buckminster 3.4 update site: '''[http://download.eclipse.org/tools/buckminster/updates http://download.eclipse.org/tools/buckminster/updates]'''
 +
#*#Buckminster 3.7 update site: '''[http://download.eclipse.org/tools/buckminster/updates-3.7 http://download.eclipse.org/tools/buckminster/updates-3.7]'''
 
#*#Subclipse update site: '''[http://subclipse.tigris.org/update_1.4.x http://subclipse.tigris.org/update_1.4.x]''' (more information on Subclipse is available [http://subclipse.tigris.org/ here])
 
#*#Subclipse update site: '''[http://subclipse.tigris.org/update_1.4.x http://subclipse.tigris.org/update_1.4.x]''' (more information on Subclipse is available [http://subclipse.tigris.org/ here])
#Make sure both update sites are selected and then press '''''Finish'''''. 
+
#Install the needed features:
#Eclipse may throw up a window entitled '''''Update Site Mirrors'''''. Pick the most appropriate. For '''''Buckminster Update Site''''' we advise that you pick the main Buckminster Update Site as occasionally a mirror site is not always in synchronization with the master site and Buckminster is frequently updated.
+
#Eclipse will then display a window entitled '''''Search Results''''' which should include the specified Buckminster and Subclipse upate sites.
+
 
#*For Buckminster:
 
#*For Buckminster:
 
#*#Select all core Buckminster features.
 
#*#Select all core Buckminster features.
#*#Select the Subclipse integration and other optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found [[Buckminster Optional Features|here]].
+
#*#Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found [[Buckminster Optional Features|here]].
#*#In particular, DO NOT SELECT the Subversive integration feature.
+
#*#In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
 
#*For Subclipse:
 
#*For Subclipse:
 
#*#Select the core Subclipse features.
 
#*#Select the core Subclipse features.
 
#*#Select the Subclipse Buckminster integration feature.
 
#*#Select the Subclipse Buckminster integration feature.
 
#*#There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
 
#*#There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
# Proceed with '''''Finish'''''. Eclipse will then display a '''''Feature License''''' window, and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Next'''''.
+
#*#Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
# Eclipse will then display the '''''Installation''''' window  for the selected features.  Accept the default folder locations and select '''''Finish'''''.
+
# Proceed with '''''Install...'''''. Eclipse will then ask you to '''''Review Licenses''''', and if you are happy with the terms of the license as displayed, accept them,  and then do '''''Finish'''''.
#The '''''Update Manager''''' will indicate the download progress and display a '''''Feature Verification''''' window upon completion. If you are happy to proceed,  select the '''''Install''''' or simply '''''Install All'''''.
+
#The '''''Update Manager''''' will indicate the download progress and then recommend that you restart your IDE.
#The installation should be finished with a restart of Eclipse.
+
  
 
==Wrapping up==
 
==Wrapping up==
Line 86: Line 77:
  
 
Hopefully your installation has proceeded smoothly.  However,  here are some thoughts if things don't work out:
 
Hopefully your installation has proceeded smoothly.  However,  here are some thoughts if things don't work out:
* If you have previously installed Buckminster,  you may need to un-install it before re-installing it as above - otherwise the re-install may fail.  The safest way to do this is to find the Eclipse installation directory on your machine,  and remove anything that has ''buckminster'' in its name below the two folders ''plugins'' and ''features''.  Then restart your Eclipse IDE again and proceed to re-install Buckminster.
+
* If you have previously installed Buckminster,  you may need to un-install it before re-installing it as above - otherwise the re-install may fail.  The safest way to do this is to find the Eclipse installation directory on your machine,  and remove anything that has ''buckminster'' in its name below the two folders ''plugins'' and ''features''.  Then restart your Eclipse IDE again and proceed to re-install Buckminster. (Note that this is required because the Eclipse Update Manager does not always do the right thing. This type of problem will go away with the newer Eclipse p2 based manager - and when using p2, it is a very bad idea to just delete things in the installation).
 
* In update site selection step described above, it may be prudent of you to select all the sites which are displayed to you to include in your search:  this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).
 
* In update site selection step described above, it may be prudent of you to select all the sites which are displayed to you to include in your search:  this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).
 
  
 
=Installation for Buckminster contributors=
 
=Installation for Buckminster contributors=
 
As a contributor you will first have to follow the instructions in [[#Installation for Buckminster users|Installation for Buckminster users]]. If you intend to contribute to Buckminster, or plan to extend Buckminster you will want to get hold of the latest Buckminster source. Naturally, you will use Buckminster to get itself and use the following Buckminster CQUERY to obtain it:
 
As a contributor you will first have to follow the instructions in [[#Installation for Buckminster users|Installation for Buckminster users]]. If you intend to contribute to Buckminster, or plan to extend Buckminster you will want to get hold of the latest Buckminster source. Naturally, you will use Buckminster to get itself and use the following Buckminster CQUERY to obtain it:
  
*[http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery]  
+
*For '''head development''' [http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery]
 +
*For '''eclipse 3.4.x''' [http://www.eclipse.org/buckminster/samples/queries/buckminster.cquery http://www.eclipse.org/buckminster/samples/queries/buckminster.cquery]  
  
When resolving this query you MUST ensure that your Eclipse installation contains the RCP delta pack.  
+
When resolving this query you MUST ensure that your Eclipse installation is 3.4 and contains the RCP delta pack.  
 
#Go to [http://download.eclipse.org/eclipse/downloads/ http://download.eclipse.org/eclipse/downloads/].
 
#Go to [http://download.eclipse.org/eclipse/downloads/ http://download.eclipse.org/eclipse/downloads/].
#Select the latest release (i.e. [http://download.eclipse.org/eclipse/downloads/drops/R-3.3.1.1-200710231652/index.php http://download.eclipse.org/eclipse/downloads/drops/R-3.3.1.1-200710231652/index.php]).
+
#Select the latest release.
 
#Navigate to the '''''RCP SDK''''' section where you will find a download link for the ''"RCP delta pack"'' zip.
 
#Navigate to the '''''RCP SDK''''' section where you will find a download link for the ''"RCP delta pack"'' zip.
 
#Download and unpack into your Eclipse installation directory.
 
#Download and unpack into your Eclipse installation directory.
 
#Restart Eclipse and execute the '''[http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery buckminster-dev.cquery]''' which should now happily resolve and materialize the latest Buckminster source into your workspace.
 
#Restart Eclipse and execute the '''[http://www.eclipse.org/buckminster/samples/queries/buckminster-dev.cquery buckminster-dev.cquery]''' which should now happily resolve and materialize the latest Buckminster source into your workspace.
  
=Installing the Headless Buckminster=
 
Buckminster is also packaged in a so called 'Headless' command line oriented version suitable for running on remote servers, be invoked from scripts etc. The Headless version is based on Eclipse but only includes what is needed to run as a command line tool. The footprint of the headless version is thus much smaller than for the complete Eclipse IDE.
 
  
The Headless version as it is delivered today requires configuration before use. The downloadable version only contains the Buckminster core - i.e. it does not contain any of the optional plugins. They are easy to add, but it requires some work on your part.
 
 
You can read about the details and get step by step instruction on the [[Buckminster Packaging]] page.
 
  
 
=How can I Stay Updated?=
 
=How can I Stay Updated?=
The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager.
+
The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager/p2.
 
+
For the Headless version, you need to read more on the [[Buckminster Packaging]] (and subsequent) pages as there are different options how to do this.
+
 
+
  
 
=After the Installation=
 
=After the Installation=

Latest revision as of 03:11, 1 June 2012

< To: Buckminster Project

Installation for Buckminster users

Buckminster is available as a plugin to the Eclipse IDE. There is also a stand alone “headless” version for command line usage, which is described in Installing Headless Buckminster.

These steps describe a typical Buckminster installation for use in Eclipse IDE. Note that the Subclipse plug-in is also typically used (see below): Subclipse is an Eclipse Team Provider plug-in which provides support for the Subversion version control system within the Eclipse IDE.

Make sure you are using Eclipse 3.3 or later

  • If you are starting from scratch it is it is recommended that you choose either the '"Eclipse Classic" or the '"Eclipse for RCP/Plug-in Developers" package. They both contain the PDE bundles required when Buckminster is working with features and plug-ins, otherwise those will have to be obtained separately.
    1. Download either of the suggested packages from http://www.eclipse.org/downloads/.
  • Or if Eclipse is installed make sure it is the correct version:
    1. Select Help > About Eclipse SDK and check the Version number.

Make sure you are using Java 5.0 or later

You can do that in Eclipse by:

  1. Select Help > About Eclipse SDK > Configuration Details. Scroll down to the parameter java.runtime.version - it should start with 1.5 or later (as an example the line may look like this java.runtime.version=1.6.0_03-b03)
  2. If it does not start with at least 1.5, you need to update your java environment first: you should find a version for your operating system here.


Download Buckminster with the Eclipse Update Manager (assumes Eclipse 3.4)

Buckminster comes with a number of optional features. In order to obtain SVN support and allow Buckminster to communicate with SVN providers you have a choice to either use the Buckminster Subversive OR Subclipse integration. NOTE that those to features are mutually exclusive.

The sections below describe the complete update steps for both choices.

Option 1: Buckminster with Subversive integration

  1. Select Help > Software Updates in the Eclipse IDE.
  2. Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
  3. Install the needed features:
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found here.
      3. In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
    • For Subversive:
      1. Select the core Subversive Team provider features.
      2. There may be other optional features for Subversive (i.e. Mylyn integration). Consult the Subversive site for information on those. They are not required for Buckminster.
      3. Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
  4. Proceed with Install.... Eclipse will then ask you to Review Licenses, and if you are happy with the terms of the license as displayed, accept them, and then do Finish.
  5. The Update Manager will indicate the download progress and then recommend that you restart your IDE.

Option 2: Buckminster with Subclipse integration

  1. Select Help > Software Updates in the Eclipse IDE.
  2. Provide the update manager with the required information for the Buckminster and Subversive/Subclipse update sites:
    • Click on the tab labeled Available Software
    • The easiest way to get the information for the required update sites is to use the bookmark file we prepared:
      1. Download this Buckminster and Subclipse Update Manager Bookmarks XML file, and store it somewhere convenient(e.g. in a file called bookmarks.xml). This file tells the Eclipse Update Manager about both Buckminster and the Subclipse plugins required by Buckminster.
      2. Select Import Sites... and browse the bookmarks file. The update sites for Buckminster and Subclipse will then be added to the list of available sites.
    • Alternatively, you can enter the update sites individually by choosing Add Site ... and then enter a URL. This step has to be repeated for each site that you wish to add.
      1. Buckminster 3.4 update site: http://download.eclipse.org/tools/buckminster/updates
      2. Buckminster 3.7 update site: http://download.eclipse.org/tools/buckminster/updates-3.7
      3. Subclipse update site: http://subclipse.tigris.org/update_1.4.x (more information on Subclipse is available here)
  3. Install the needed features:
    • For Buckminster:
      1. Select all core Buckminster features.
      2. Select the optional features that you might need, but DO NOT SELECT THEM ALL. More information on the optional Buckminster features can be found here.
      3. In particular, DO NOT SELECT both the Subversive and the Subclipse integration feature.
    • For Subclipse:
      1. Select the core Subclipse features.
      2. Select the Subclipse Buckminster integration feature.
      3. There may be other optional features for Subclipse (i.e. Mylyn integration). Consult the Subclipse site for information on those. They are not required for Buckminster.
      4. Select the SVNKit or JavaHL connector (or both in case you want to alter between them). Please note that JavaHL is not pure Java and might require other software installed on your computer.
  4. Proceed with Install.... Eclipse will then ask you to Review Licenses, and if you are happy with the terms of the license as displayed, accept them, and then do Finish.
  5. The Update Manager will indicate the download progress and then recommend that you restart your IDE.

Wrapping up

To confirm that Buckminster has now been installed, check that the File > New > Other > has an entry for the Buckminster wizards; expanding the Buckminster box should show a number of available Buckminster wizards.

Hopefully your installation has proceeded smoothly. However, here are some thoughts if things don't work out:

  • If you have previously installed Buckminster, you may need to un-install it before re-installing it as above - otherwise the re-install may fail. The safest way to do this is to find the Eclipse installation directory on your machine, and remove anything that has buckminster in its name below the two folders plugins and features. Then restart your Eclipse IDE again and proceed to re-install Buckminster. (Note that this is required because the Eclipse Update Manager does not always do the right thing. This type of problem will go away with the newer Eclipse p2 based manager - and when using p2, it is a very bad idea to just delete things in the installation).
  • In update site selection step described above, it may be prudent of you to select all the sites which are displayed to you to include in your search: this will ensure that your version of the Eclipse IDE is completely up to date with all the functions and features of Eclipse which you are using (not just Buckminster alone).

Installation for Buckminster contributors

As a contributor you will first have to follow the instructions in Installation for Buckminster users. If you intend to contribute to Buckminster, or plan to extend Buckminster you will want to get hold of the latest Buckminster source. Naturally, you will use Buckminster to get itself and use the following Buckminster CQUERY to obtain it:

When resolving this query you MUST ensure that your Eclipse installation is 3.4 and contains the RCP delta pack.

  1. Go to http://download.eclipse.org/eclipse/downloads/.
  2. Select the latest release.
  3. Navigate to the RCP SDK section where you will find a download link for the "RCP delta pack" zip.
  4. Download and unpack into your Eclipse installation directory.
  5. Restart Eclipse and execute the buckminster-dev.cquery which should now happily resolve and materialize the latest Buckminster source into your workspace.


How can I Stay Updated?

The IDE installation is updated via the Eclipse Update Manager. When installing Buckminster as described above, you have already added the required information to receive updates via the Eclipse Update Manager/p2.

After the Installation

We suggest the next places you might want to take a look at are:

  • The Why Buckminster ? document gives a high level overview of the motivation for, and concepts in, Buckminster, without getting into details of any (XML) code fragments.
  • The Hello XML World Example (Buckminster) which illustrates in detail how a materialization can be done, and uses different types of components - Eclipse plugins and stand alone files.
  • The Introduction to Buckminster which gives some common usage scenarios, explaining how to materialize and consume software components; how to publish components to your colleagues and the wider community; and how to prepare virtual distributions ("distros") using Buckminster.