Skip to main content
Jump to: navigation, search

Difference between revisions of "Install and run the snapshot build"

(All-in-One package)
Line 1: Line 1:
This wiki page is used to explain how to install and use the latest snapshot build.
+
This wiki page is used to explain how to install and use the latest snapshot with Eclipse3.3.
 
Since the current 0.4.0 S-build (http://www.eclipse.org/stp/downloads/downloads.php) has some major problems,
 
Since the current 0.4.0 S-build (http://www.eclipse.org/stp/downloads/downloads.php) has some major problems,
 
we suggest to use the snapshot build instead.
 
we suggest to use the snapshot build instead.
Line 5: Line 5:
 
For user's convenience, i created a all-in-one package to download at the end of this wiki page.
 
For user's convenience, i created a all-in-one package to download at the end of this wiki page.
  
Johnson Ma (Apr 09, 2007)
+
(Last updated on Apr 16, 2007)
  
 
== Where to get stp build ==
 
== Where to get stp build ==
  
* STP snapshot build http://download.eclipse.org/stp/committers/drops/I-I200702281720-200702281720/
+
* STP snapshot from cvs
  
 
== Setup pre-requisites ==
 
== Setup pre-requisites ==
 +
* Eclipse 3.3 M6
 
=== Pre-requisites plugins ===
 
=== Pre-requisites plugins ===
 
==== Plugins from other Eclipse projects ====
 
==== Plugins from other Eclipse projects ====
*[http://download.eclipse.org/tools/emf/downloads/drops/2.2.0/R200606271057 Eclipse EMF-SDO-XSD SDK]
+
*dtp_1.0M3
*[http://download.eclipse.org/tools/gef/downloads/drops/R-3.2-200606270816/GEF-SDK-3.2.zip Eclipse GEF SDK]
+
*emf-sdk-xsd-SDK2.3.0M6
*[http://download.eclipse.org/tools/ve/downloads/drops/R-1.2-200606280938/JEM-SDK-1.2.zip Eclipse JEM SDK]
+
*emft-query-SDK-1.1M5
*[http://download.eclipse.org/webtools/downloads/drops/R1.5/R-1.5.0-200606281455/wtp-sdk-R-1.5.0-200606281455.zip Eclipse WTP SDK]
+
*emft-transaction-SDK-1.1M5
*[http://download.eclipse.org/modeling/gmf/downloads/drops/R-1.0.2-200610271200/GMF-runtime-1.0.2.zip Eclipse GMF Runtime]
+
*emft-validation-SDK-1.1M5
*[http://www.eclipse.org/downloads/download.php?file=/datatools/downloads/1.0/dtp-sdk_1.0_200612211.zip Eclipse DTP SDK]
+
*GMF-sdk-1.0.3
 +
*JEM-SDK-1.2
 +
*mtd-ocl-SDK-1.1M5
 +
*wtp-sdk-S-2.0M5
  
 
==== 3rd-party plugins ====
 
==== 3rd-party plugins ====
*Apache CXF plugin for JAX-WS development: http://people.apache.org/repo/m2-snapshot-repository/org/apache/cxf/cxf-eclipse3.1-plugin/2.0-incubator-RC-SNAPSHOT/cxf-eclipse3.1-plugin-2.0-incubator-RC-20070306.200920-6.zip
+
*Apache CXF plugin for JAX-WS development: http://people.apache.org/repo/m2-snapshot-repository/org/apache/cxf/cxf-eclipse3.1-plugin/2.0-incubator-RC-SNAPSHOT
 
*Apache Tuscany plugin for SCA development:
 
*Apache Tuscany plugin for SCA development:
 
http://www.eclipse.org/stp/sc/plugins/tuscany-eclipse-plugin-1.0-incubator-M2.zip
 
http://www.eclipse.org/stp/sc/plugins/tuscany-eclipse-plugin-1.0-incubator-M2.zip
Line 51: Line 55:
 
  * Need to install [http://people.apache.org/repo/m2-snapshot-repository/org/apache/cxf/cxf-distribution/2.0-incubator-RC-SNAPSHOT/cxf-distribution-2.0-incubator-RC-20070227.144747-7.zip CXF] runtime to test the JAX-WS functions.
 
  * Need to install [http://people.apache.org/repo/m2-snapshot-repository/org/apache/cxf/cxf-distribution/2.0-incubator-RC-SNAPSHOT/cxf-distribution-2.0-incubator-RC-20070227.144747-7.zip CXF] runtime to test the JAX-WS functions.
  
Three known issues:
+
Three known issues for the all-in-one package:
 
  * Can't set the JAX-WS runtime directory and soap12 binding from project's properties. But set from Preference page  works fine.
 
  * Can't set the JAX-WS runtime directory and soap12 binding from project's properties. But set from Preference page  works fine.
 
  * The Document/Lit/Bare doesn't work. This is caused by a [https://bugs.eclipse.org/bugs/show_bug.cgi?id=176783 bug] in Apache CXF runtime.
 
  * The Document/Lit/Bare doesn't work. This is caused by a [https://bugs.eclipse.org/bugs/show_bug.cgi?id=176783 bug] in Apache CXF runtime.
 
  So If you are following Tyler's article, please give @SoapBinding(Document/Literal/Wrapped) annotation on web service class.
 
  So If you are following Tyler's article, please give @SoapBinding(Document/Literal/Wrapped) annotation on web service class.
 
  * The HTTP/REST style client has problem, will give HTTP 500 error in the runtime. But the standalone client run from Eclipse works fine.
 
  * The HTTP/REST style client has problem, will give HTTP 500 error in the runtime. But the standalone client run from Eclipse works fine.

Revision as of 22:42, 15 April 2007

This wiki page is used to explain how to install and use the latest snapshot with Eclipse3.3. Since the current 0.4.0 S-build (http://www.eclipse.org/stp/downloads/downloads.php) has some major problems, we suggest to use the snapshot build instead.

For user's convenience, i created a all-in-one package to download at the end of this wiki page.

(Last updated on Apr 16, 2007)

Where to get stp build

  • STP snapshot from cvs

Setup pre-requisites

  • Eclipse 3.3 M6

Pre-requisites plugins

Plugins from other Eclipse projects

*dtp_1.0M3
*emf-sdk-xsd-SDK2.3.0M6
*emft-query-SDK-1.1M5
*emft-transaction-SDK-1.1M5
*emft-validation-SDK-1.1M5
*GMF-sdk-1.0.3
*JEM-SDK-1.2
*mtd-ocl-SDK-1.1M5
*wtp-sdk-S-2.0M5

3rd-party plugins

http://www.eclipse.org/stp/sc/plugins/tuscany-eclipse-plugin-1.0-incubator-M2.zip

Pre-requisites SOA runtime

Run it

Tyler Anderson wrote a good article about Use the Eclipse SOA Tools Platform plug-in to build and deploy a Web service

About the update sites

We are still working on those update sites:

  • Eclipse STP update site, coming soon...
  • Apache CXF update site, coming soon...
  • Apache Tuscany update site. ?

All-in-One package

You can download the STP all in one package from here:stp_all_in_one04092007.zip

Just copy all plugins from that package to your eclipse3.2 installation.

Please notice:

* We only support eclipse3.2 for now. 
* Please set the java compiler to jdk 1.5 in preference page (1.4 and 1.6 are not supported)
* Need to install CXF runtime to test the JAX-WS functions.

Three known issues for the all-in-one package:

* Can't set the JAX-WS runtime directory and soap12 binding from project's properties. But set from Preference page  works fine.
* The Document/Lit/Bare doesn't work. This is caused by a bug in Apache CXF runtime.
So If you are following Tyler's article, please give @SoapBinding(Document/Literal/Wrapped) annotation on web service class.
* The HTTP/REST style client has problem, will give HTTP 500 error in the runtime. But the standalone client run from Eclipse works fine.

Back to the top