Difference between revisions of "Implement Split File Editor Functionality for the Eclipse IDE"

From Eclipsepedia

Jump to: navigation, search
m (Releases)
(Issue Tracker)
Line 32: Line 32:
  
 
== Issue Tracker ==
 
== Issue Tracker ==
 +
 +
{| border="1" cellpadding="2"
 +
|-
 +
! Feature
 +
! Test Case
 +
! Multi Editor
 +
! Split Editor
 +
! New Editor Tab
 +
|-
 +
| Save
 +
| Select File-> Save from the main menu
 +
| works but invokes Save command twice
 +
| works
 +
| works
 +
|-
 +
| Save as
 +
| Select File-> Save As from the main menu
 +
| does not work
 +
| works
 +
| works
 +
|-
 +
| Star (*) in editor tab next to file name on modification
 +
| Make a change in the editor
 +
| does not mark editor tab as dirty with a * (star)
 +
| works
 +
| works
 +
|-
 +
| Mark occurrences (java)
 +
| enable mark occurrences and click over a java element (method/field/class name etc)
 +
| works but marks occurrences in both editors
 +
| not applicable (java editor not available)
 +
| works
 +
|-
 +
| Mark occurrences of different elements (java)
 +
| enable mark occurrences and click over different java elements in both editors
 +
| works but both elements are highlighted in both editors
 +
| not applicable (java editor not available)
 +
| works but both elements are highlighted in both editors (see [http://bugs.eclipse.org/64911 bug 64911])
 +
|-
 +
| Current line highlight within active focused editor
 +
| switch the focus (by mouse-clicking) between the two editors
 +
| works
 +
| does not appear in top editor and cursor is no longer visible in bottom editor after split
 +
| works
 +
|-
 +
| Navigation using back/forward buttons or Alt-LeftArrow/Alt-RightArrow
 +
| click within the one of the two editors; make a change; switch to another editor; use Go Back command (Alt-LeftArrow) to go back
 +
| does not always go back to the editor where the change was made
 +
| does not always go back to the editor where the change was made
 +
| does not always go back to the editor where the change was made
 +
|}

Revision as of 02:09, 24 June 2008

Contents

Releases

  • 2008-06-23. DOWNLOAD. 1st release of multi editor and split editor implementations. Instructions: Download the plugin jar and place in the dropins directory (compatible with Eclipse 3.4 RC4 or later).

Implementations

Multi Editor-based

Usage: Open a file in Eclipse, then select Window -> New Split Editor from the main menu to open a split editor of the file.

This implementation is based on Paul Webster's patch, which uses the existing multi-editor architecture in Eclipse.

  • Advantages
    • does not require custom work for different editor types (java/xml/etc)
    • works automatically with new custom editor types
  • Disadvantages
    • bound by the limitations of the multi-editor infrastructure

Custom Split Editor Implementation

Usage: Right-click on a file, select Open with -> Other... and select \[Split Text Editor\] from the list of editors.

This implementation is based on a custom editor implementation that dynamically creates a new StyledText control when a sash is dragged within the editor to split it.

  • Advantages
    • fully replaces existing editors and allows splitting the active editor in-place (as opposed to opening a split editor in a new tab)
    • easier activation via the mouse because there is no need to go to the window main menu or editor tab context menu.
  • Disadvantages
    • requires customization of every editor class that wants to support split editing (java/xml... etc)

Issue Tracker

Feature Test Case Multi Editor Split Editor New Editor Tab
Save Select File-> Save from the main menu works but invokes Save command twice works works
Save as Select File-> Save As from the main menu does not work works works
Star (*) in editor tab next to file name on modification Make a change in the editor does not mark editor tab as dirty with a * (star) works works
Mark occurrences (java) enable mark occurrences and click over a java element (method/field/class name etc) works but marks occurrences in both editors not applicable (java editor not available) works
Mark occurrences of different elements (java) enable mark occurrences and click over different java elements in both editors works but both elements are highlighted in both editors not applicable (java editor not available) works but both elements are highlighted in both editors (see bug 64911)
Current line highlight within active focused editor switch the focus (by mouse-clicking) between the two editors works does not appear in top editor and cursor is no longer visible in bottom editor after split works
Navigation using back/forward buttons or Alt-LeftArrow/Alt-RightArrow click within the one of the two editors; make a change; switch to another editor; use Go Back command (Alt-LeftArrow) to go back does not always go back to the editor where the change was made does not always go back to the editor where the change was made does not always go back to the editor where the change was made