ICU4J Usage in Eclipse

From Eclipsepedia

Revision as of 15:33, 19 April 2006 by Karice (Talk | contribs)

Jump to: navigation, search

Plug-ins in Eclipse SDK that Reference ICU4J

Plug-in Comments
org.eclipse.ant.ui
org.eclipse.compare
org.eclipse.core.filebuffers Only MessageFormat is used; should be able to remove dependency.
org.eclipse.core.variables
org.eclipse.debug.core
org.eclipse.debug.ui
org.eclipse.help
org.eclipse.help.base
org.eclipse.help.ui
org.eclipse.jdt.debug
org.eclipse.jdt.debug.ui
org.eclipse.jdt.launching
org.eclipse.jdt.ui
org.eclipse.jface.databinding
org.eclipse.jface.text
org.eclipse.ltk.core.refactoring
org.eclipse.ltk.ui.refactoring
org.eclipse.pde.build
org.eclipse.pde.runtime
org.eclipse.pde.ui
org.eclipse.search
org.eclipse.team.cvs.core
org.eclipse.team.cvs.ui
org.eclipse.team.ui
org.eclipse.text
org.eclipse.ui.browser
org.eclipse.ui.cheatsheets
org.eclipse.ui.console
org.eclipse.ui.editors
org.eclipse.ui.forms
org.eclipse.ui.ide
org.eclipse.ui.presentations.r21
org.eclipse.ui.views.properties.tabbed
org.eclipse.ui.win32
org.eclipse.ui.workbench
org.eclipse.ui.workbench.texteditor



Plug-ins that could use ICU4J but do not

Plug-in Reason
org.eclipse.ant.core ??
org.eclipse.core.expressions Removed references to affected classes
org.eclipse.core.jobs Removed references to affected classes
org.eclipse.core.runtime.compatibility Removed references to affected classes
org.eclipse.help.webapp. Plugin compiled using Ant script cannot resolve ICU imports using Import-Package
org.eclipse.jface Need to be able to use JFace standalone (with SWT)
org.eclipse.jdt.core Need jdt.core to compile against Foundation 1.0; ICU will not compile against this
org.eclipse.jdt.junit Since jdt.core not adopting, will not adopt in tools for consistency
org.eclipse.jdt.junit.runtime Since jdt.core not adopting, will not adopt in tools for consistency
org.eclipse.ui.externaltools ??
org.eclipse.update.configurator Can't use ICU, possible launch problem? Also, included in eRCP builds
org.eclipse.update.core Needs to compile against Foundation 1.0 ??
org.eclipse.update.scheduler Needs to compile against Foundation 1.0 ??
org.eclipse.update.ui Needs to compile against Foundation 1.0 ??