Difference between revisions of "IAM Environment"

From Eclipsepedia

Jump to: navigation, search
(Link back and category)
Line 5: Line 5:
 
== Development conventions ==
 
== Development conventions ==
 
See this page for [[IAM Development Conventions | development conventions]], such as style and standard headers.
 
See this page for [[IAM Development Conventions | development conventions]], such as style and standard headers.
 +
 +
== Setup your Execution Environment ==
 +
 +
IAM uses the J2SE-15 Execution Environment for its JRE Library references, launchers, and testing.
 +
 +
# Go check your Execution environment.
 +
#: '' Window > Preferences > Java > Installed JREs > Execution Environment > J2SE-1.5 '' and ensure that there is a compatible JRE present.  A "Perfect Match" would be better.
 +
#: [[Image:Iam-execution-environment-good.png]]
 +
# If you don't have a perfect match, add a Java 1.5 JRE to your 'Installed JREs' listing.  '' Window > Preferences > Java > Installed JREs ''
  
 
== Target platform ==
 
== Target platform ==

Revision as of 19:28, 5 December 2008

< To: IAM

Contents

IAM Development Environment

Follow these instructions to get your development environment up and running.

Development conventions

See this page for development conventions, such as style and standard headers.

Setup your Execution Environment

IAM uses the J2SE-15 Execution Environment for its JRE Library references, launchers, and testing.

  1. Go check your Execution environment.
    Window > Preferences > Java > Installed JREs > Execution Environment > J2SE-1.5 and ensure that there is a compatible JRE present. A "Perfect Match" would be better.
    Iam-execution-environment-good.png
  2. If you don't have a perfect match, add a Java 1.5 JRE to your 'Installed JREs' listing. Window > Preferences > Java > Installed JREs

Target platform

There is a wiki page with instructions for setting up the target platform for building IAM

Getting the source code

Instructions on this page.