Jump to: navigation, search

I41 Release Notes

Revision as of 15:11, 12 October 2011 by Nmehrega.cisco.com (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Summary:

Normal Defects: 17
Major Defects: 3
Enhancement: 2
Total: 22


Changes to Tigerstripe in Iteration 41:

Open Annotation view right after an annotation is added via context menu (Bugzilla 356990)
Annotation view is now automatically opened and given focus when user adds an annotation using an artifact's context menu.


Create annotations.png


Wrong display of Relationship Anchors (Bugzilla 358444)
Relationship anchors can be displayed in Tigerstripe Explorer when the feature is enabled under preferences. The anchors were not being displayed in an intuitive way. Considering the diagram below, please see the before and after snapshots of how relationship anchors were displayed in Tigerstripe Explorer:


Relationship anchors diagram.png

Before relationship anchors.png

After relationship anchors.png


Issues with adding annotations to relationship ends (Bugzilla 358685)
An Unhandled event loop exception would occur after adding an annotation to relationship ends.


Button enabled when it shouldn't be (Bugzilla 358052)
The OK button in the 'Attach Dangling Annotation' dialog was enabled even when nothing was selected.


Attach dangling annotation dialog.png


Changes in Association Property Editor are not persisted (Bugzilla 358048) (Bugzilla 357773) (Bugzilla 358050)
A number of defects were resolved in the Association Property dialog where some of the changes would not get persisted properly.


Association dialog.png


NPE when deleting referenced projects (Bugzilla 359336)
NullPointerException was thrown after deleting a referenced project.


Package presentation of referenced module is incorrect in hierarchical mode (Bugzilla 359786)
This was an issue where the package presentation of a referenced module was not displayed properly under hierarchical mode.


Annotation is not removed when corresponding attribute is deleted (Bugzilla 359813)
Deleting an Entity attribute, which had been annotated would not remove the corresponding annotation.


Missing information on attributes of TS modules (Bugzilla 359110)
This was a regression where information on attributes of TS modules were not displayed in artifact editors. See snapshot below for more details.


Module attribute info.png


Issues with opening an artifact in a TS module multiple times (Bugzilla 359107)
Opening an artifact in a TS module multiple times would open multiple editors.


NPE when running quick fix on annotations (Bugzilla 358986)
In certain cases, an NPE was thrown after running a quick fix on dangling annotations.


Exception on closed projects (Bugzilla 358982)
This was a regression where an exception was thrown right after starting Tigerstripe in a workspace that contained closed projects.


Method is not deleted from TS explorer (Bugzilla 359814)
Using the delete button in TS explorer would not allow artifact methods to be deleted.


Save operation does not work properly if annotation attribute is selected (Bugzilla 357094)
This was a corner case problem where selecting an annotation attribute and attempting to delete it would not delete the annotation.


ConcurrentModificationException when modifying annotations (Bugzilla 358985)
This was a race condition where a ConcurrentModificationException would occur after modifying annotations.


In some cases Tigerstripe dependencies does not pick up workspace projects (Bugzilla 359157)
Tigerstripe projects in the workspace should always take precedence over the model projects which have been deployed. This defect fixed an issue where in certain cases projects in the workspace would not be picked up instead of the deployed models.


Defect(s) marked as Won't Fix:
Bugzilla 232729 - Provide activity log
Bugzilla 346784 - TS blocks creating a package if a similar artefact name exists in the same directory
Bugzilla 358989 - [Annotation] Adding annotations now triggers a workspace build


Defect(s) marked as Duplicate:
Bugzilla 359853 - Resource Not Open Dialog on Workbench Start-up