Skip to main content
Jump to: navigation, search

Difference between revisions of "Hudson-ci/eclipse migration/Hudson Plugin Compatibility"

 
Line 4: Line 4:
 
</span>  
 
</span>  
  
 +
<br>
  
 
+
<br>
 
+
  
 
With the changes to the core code and 3rd party libraries an analysis of the compatibility of each plugin and any required actions is needed. This page is intended to document that work  
 
With the changes to the core code and 3rd party libraries an analysis of the compatibility of each plugin and any required actions is needed. This page is intended to document that work  
Line 18: Line 18:
 
| width="6%" | <div align="center">'''Tested in'''</div>  
 
| width="6%" | <div align="center">'''Tested in'''</div>  
 
| width="10%" | <div align="center">'''Tested by'''</div>  
 
| width="10%" | <div align="center">'''Tested by'''</div>  
| width="27%" | <div align="center">'''Result'''</div>
+
| width="27%" | <div align="center">'''Result'''</div>  
 
| width="27%" | <div align="center">'''Comments on test'''</div>  
 
| width="27%" | <div align="center">'''Comments on test'''</div>  
| width="25%" | <div align="center">'''Actions'''</div>
+
| width="25%" | <div align="center">'''Actions'''</div>
| width="14%" | <div align="center">'''Tier'''</div>
+
 
|-
 
|-
 
| Join plugin  
 
| Join plugin  
| 1.9  
+
| 1.9 + 1.13
 
| 3.0-M1  
 
| 3.0-M1  
 
| Henrik  
 
| Henrik  
| Works
+
| 1.9: Works <br /> 1.13: Works in simple cases but fails when used in combo with Parameterized Trigger Plugin
| jenkins version: 1.13  
+
| Only tested simple scenario, <br/> 1.13 is only in jenkins update site.
| &nbsp;
+
| ?
| &nbsp;
+
 
|-
 
|-
| &nbsp;
+
| Parameterized Trigger
| &nbsp;
+
| 2.4 / 2.13
| &nbsp;
+
| 3.0-M1
| &nbsp;
+
| Henrik
| &nbsp;
+
| 2.4: Works <br /> 2.13: Fails
| &nbsp;
+
| 0.2 is only in jenkins update site
| &nbsp;
+
| ?
 
|-
 
|-
| &nbsp;
+
| Safe restart
| &nbsp;
+
| 0.1 /0.2
| &nbsp;
+
| 3.0-M1
| &nbsp;
+
| Henrik
| &nbsp;
+
| 0.1: Works <br> 0.2: Fails, Jenkins dependent
| &nbsp;
+
| 0.2 is only in jenkins update site
| &nbsp;
+
| ?
|-
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
|-
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
|-
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
| &nbsp;
+
 
|-
 
|-
| &nbsp;
+
| Timestamper
| &nbsp;
+
| 1.2.1 /1.2.2
| &nbsp;
+
| 3.0-M1
| &nbsp;
+
| Henrik
| &nbsp;
+
| Works
| &nbsp;
+
| 1.2.2 is only in jenkins update site
| &nbsp;
+
| ?
 
|}
 
|}
  
<br>  
+
<br>
 
+
Tested in: the milestone release testing performed in, needs to be retested for each milestong
+

Latest revision as of 16:40, 27 March 2012

Hudson Continuous Integration Server
Website
Download
Community
Mailing ListForumsIRCmattermost
Issues
OpenHelp WantedBug Day
Contribute
Browse Source
Hudson-bust.png Analysis of plugin compatibility













With the changes to the core code and 3rd party libraries an analysis of the compatibility of each plugin and any required actions is needed. This page is intended to document that work


Plugin
Version
Tested in
Tested by
Result
Comments on test
Actions
Join plugin 1.9 + 1.13 3.0-M1 Henrik 1.9: Works
1.13: Works in simple cases but fails when used in combo with Parameterized Trigger Plugin
Only tested simple scenario,
1.13 is only in jenkins update site.
 ?
Parameterized Trigger 2.4 / 2.13 3.0-M1 Henrik 2.4: Works
2.13: Fails
0.2 is only in jenkins update site  ?
Safe restart 0.1 /0.2 3.0-M1 Henrik 0.1: Works
0.2: Fails, Jenkins dependent
0.2 is only in jenkins update site  ?
Timestamper 1.2.1 /1.2.2 3.0-M1 Henrik Works 1.2.2 is only in jenkins update site  ?


Back to the top