Jump to: navigation, search

Difference between revisions of "Hudson-ci/Using Hudson/Installing Hudson"

m (Prerequisites: typo)
 
(2 intermediate revisions by one other user not shown)
Line 1: Line 1:
 
{{Template:hudson|pageTitle=Installing Hudson}}  
 
{{Template:hudson|pageTitle=Installing Hudson}}  
 +
 +
== Distributions ==
 +
Hudson can be downloaded from both [http://www.eclipse.org/hudson/download.php eclipse.org] and [http://hudson-ci.org hudson-ci.org]. More information about the available distributions can be found [http://wiki.eclipse.org/Hudson-ci/development/releaseartifacts here].
 +
  
 
== Prerequisites  ==
 
== Prerequisites  ==
  
Hudson only needs a Java 6 or newer runtime. (And Internet connection at least for Windows install for Denmark mirror's distrib)
+
Hudson only needs a Java 6 or newer runtime. An internet connection will be required if you want to be able to install and auto-update plug-ins.
 +
 
  
 
== WAR file  ==
 
== WAR file  ==

Latest revision as of 19:17, 12 March 2013

Hudson Continuous Integration Server
Website
Download
Community
Mailing ListForumsIRC
Bugzilla
Open
Help Wanted
Bug Day
Contribute
Browse Source
Hudson-bust.png Installing Hudson











Distributions

Hudson can be downloaded from both eclipse.org and hudson-ci.org. More information about the available distributions can be found here.


Prerequisites

Hudson only needs a Java 6 or newer runtime. An internet connection will be required if you want to be able to install and auto-update plug-ins.


WAR file

After you download hudson.war, you can launch it by executing java -jar hudson.war. This is mostly useful for testing purposes. For production we recommend using native packages for simplified install or deployment in a servlet container that supports Servlet 2.4/JSP 2.0 or later, such as Glassfish, Tomcat 5, JBoss, Jetty 6, etc. See Containers for more about container-specific installation instruction.

Once the war file is exploded, run chmod 755 hudson in the exploded hudson/WEB-INF directory so that you can execute this shell script.

Unix/Linux Installation

The Hudson project provides native packages for various Linux distributions. These are the simplest way to run Hudson in production, since the packages set up user, service and all other configuration as well as integrate with the native upgrade mechanism of the operating system.

For other operating systems check out the following pages for help.

Alternatively, if you have a servlet container that supports Servlet 2.4/JSP 2.0, such as Glassfish v2, Tomcat 5 (or any later versions), you can run them as services, and deploy hudson.war as you would any other war file. Containers documentation is available if you choose this route.

Windows Installation

If you're running on Windows you might want to run Hudson as a service so it starts up automatically without requiring a user to log in. The easiest way is follow Installing Hudson as a Windows service. Alternatively, you can install a servlet container like GlassFish and Tomcat, which can run as a service by itself, and then deploy Hudson to it.

Since Hudson was written to work on unix-like platforms, some parts assume the presence of unix-utilities. It is advised to install these as well on Windows. Install UnxUtils (this includes a shell that seems to work with forward and backwards slashes and does globbing correctly), put it in the Windows PATH, and copy sh.exe to C:\bin\sh.exe (or whichever drive you use) to make shebang lines work. This should get you going.

If you're running on Windows you might want to run Hudson as a service so it starts up automatically without requiring a user to log in. One way is to first install Tomcat as a service and then deploy Hudson to it in the usual way. Another way is to use the Java Service Wrapper. However, there may be problems using the service wrapper, because the Main class in Hudson in the default namespace conflicts with the service wrapper main class. Deploying inside a service container (Tomcat, Jetty, etc.) is probably more straightforward, even for developers without experience with such containers.