How to Build DTP 0.7

From Eclipsepedia

Revision as of 18:25, 1 March 2006 by Jgraham (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

How to Build DTP 0.7

Back to DTP Main Page

Introduction

DTP 0.7 is built against the Eclipse 3.1 platform and the appropriate versions of EMF and GEF. You'll also need to have the DTP compatibility pack installed to build DTP 0.7, whether or not you will use it ultimately in Eclipse 3.2. The easiest way to install the compatibility pack is to download and add it to your Eclipse plugins folder, since the code in this layer changes (typically) when a new Eclipse 3.2 milestone build is released.

If you would like to build DTP 0.7 compatibility as well, you will need to do that first, before attempting to build the main DTP code line. Instructions for doing so can be found here.

Finally, you will need Apache Ant, version 1.6 or later.

Building DTP 0.7

  • Check out a copy of org.eclipse.datatools.build from CVS.