Difference between revisions of "Graphical Eclipse FAQs"

From Eclipsepedia

Jump to: navigation, search
(Eclipse Platform/Workspace: Add an FAQ entry about checking a process's command line command.)
(Added note for obtaining configuration details with Helios.)
 
(3 intermediate revisions by one user not shown)
Line 1: Line 1:
The '''Graphical Eclipse FAQs''' is a collection of FAQs that have been produced by the Eclipse community in hopes of helping guide users through frequently asked questions with the help of verbal instructions and graphical screenshots.
+
The '''Graphical Eclipse FAQs''' is a collection of [[Category:FAQ|FAQs]] that have been produced by the Eclipse community in hopes of helping guide users through frequently asked questions with the help of verbal instructions and graphical screenshots.
  
 
==Eclipse Platform/Workspace==
 
==Eclipse Platform/Workspace==
Line 7: Line 7:
 
[[Image:Help  Menu.jpg]]
 
[[Image:Help  Menu.jpg]]
  
2. Now in the opened about dialog, click on 'Configuration Details'.
+
2. Now in the opened about dialog, click on 'Configuration Details'.  Note that the following screen shots are for Galileo; for Helios distributions, you should instead click on the 'Installation Details' button and then select the 'Configuration' tab.
  
 
[[Image:Configuration Details 01.jpg]]
 
[[Image:Configuration Details 01.jpg]]
Line 29: Line 29:
 
[[Image:Annotations Preferences.jpg]]
 
[[Image:Annotations Preferences.jpg]]
  
===How do I switch my workspace?===
 
1. Go into the File menu and then go into the Switch Workspace submenu.
 
  
[[Image:Switch Workspace.jpg]]
 
  
 
===I have just installed a plug-in but I do not see any indication of it in my workspace. What do I do?===
 
===I have just installed a plug-in but I do not see any indication of it in my workspace. What do I do?===
Line 73: Line 70:
 
[[Image:Preferences.jpg]]
 
[[Image:Preferences.jpg]]
  
2. Now navigate to the Java compiler preferences page as below and then select your compiler compliance level. The same steps can be applied on a per-project basis.
+
2. Now navigate to the Java compiler preferences page as below and then select your compiler compliance level. The same steps can be applied on a per-project basis by accessing your project's properties page.
  
 
[[Image:Compiler Preferences.jpg]]
 
[[Image:Compiler Preferences.jpg]]

Latest revision as of 14:47, 13 August 2010

The Graphical Eclipse FAQs is a collection of that have been produced by the Eclipse community in hopes of helping guide users through frequently asked questions with the help of verbal instructions and graphical screenshots.

Contents

[edit] Eclipse Platform/Workspace

[edit] How do I find out which Java runtime environment is being used to run my Eclipse?

1. Go into the Help menu and then click on About Eclipse SDK.

Help Menu.jpg

2. Now in the opened about dialog, click on 'Configuration Details'. Note that the following screen shots are for Galileo; for Helios distributions, you should instead click on the 'Installation Details' button and then select the 'Configuration' tab.

Configuration Details 01.jpg

3. Now take a look at the java.vendor and java.version property.

Configuration Details.jpg

[edit] How do I show line numbers in the Eclipse text editor?

1. Right-click on the left margin of your text editor and then click on 'Show Line Numbers'.

Line Numbers.jpg

[edit] How do I change the colour of the highlighting marker that highlights all the occurrences of some element in the text editor?

1. Go into the Window menu and then click on Preferences.

Preferences.jpg

2. Now navigate to the 'Annotations' preference page as below and change the colour of the 'Occurrences' annotation type.

Annotations Preferences.jpg


[edit] I have just installed a plug-in but I do not see any indication of it in my workspace. What do I do?

1. Did you try restarting Eclipse with the -clean argument? The instructions provided here are for Windows users. For UNIX-based system users, the steps are similar and you should be able to follow along without any trouble. First, open your Start menu and then click on Run.

Windows Run.jpg

2. Type in 'cmd'.

Windows Command Prompt.jpg

3. Navigate to your Eclipse folder and then run Eclipse with the -clean argument appended to it.

Eclipse Clean.jpg

[edit] How do I not install a plug-in's extraneous dependency when I'm in the Update Manager?

1. Are you seeing a screen similar to the one where the plug-in you are installing is asking for some other plug-in?

FAQ Dependency Required.jpg

2. Expand the section by clicking on the arrow. Keep expanding until you see everything and then tick off the "additional dependencies" that you don't want.

FAQ Dependencies Removed.jpg

3. Now you can install the plug-in without installing other things.

[edit] How do I check for the command line invocation that Eclipse used to launch an application?

1. Open up the 'Debug' view and then open up the context menu on your process and access its properties.

FAQ Debug View.jpg

2. You can identify the command used from the properties dialog.

FAQ Debug Properties.jpg

[edit] JDT

[edit] How do I change the compiler compliance level for my workspace?

1. Open up the preferences dialog by going to the Window menu.

Preferences.jpg

2. Now navigate to the Java compiler preferences page as below and then select your compiler compliance level. The same steps can be applied on a per-project basis by accessing your project's properties page.

Compiler Preferences.jpg

[edit] How do I add arguments to the Java program I am running?

1. Open up the run dialog via the dropdown toolbar item.

Run Dialog.jpg

2. Select your Java Application launch configuration. Go into the 'Arguments' tab and then type in your arguments in that text field.

Java Program Args.jpg

[edit] How do I alter my package representation so that parent packages are housing child packages?

1. Click on the dropdown menu on the Package Explorer view. Go to the 'Package Representation' submenu and then click on 'Hierarchical'.

Package Representation 01.jpg

2. You should now see your packages presented in a tree like structure.

Package Representation 02.jpg

[edit] I clicked on something and now I can only see the method that I am currently editing. What do I do? Did I lose my entire file?

1. No, you must've clicked on the 'Show Selected Element Only' toolbar item. See below and unselect it.

Show Selected Element Only.gif

[edit] PDE

[edit] I get an unhandled event loop exception in my console. What gives?

1. Open up the run dialog via the dropdown toolbar item.

Run Dialog.jpg

2. Select your Eclipse Application launch configuration. Go into the 'Arguments' tab and then append '-consoleLog' as an argument and then try running your application again.

PDE Console Log.jpg