GEF/Developer FAQ

From Eclipsepedia

< GEF
Revision as of 14:26, 29 March 2006 by Sshaw (Talk | contribs)

Jump to: navigation, search

Contents

General

What is GEF

The Graphical Editing Framework is an open source framework dedicated to providing a rich, consistent graphical editing environment for applications on the Eclipse Platform.

Why should I use GEF?

GEF enables developers to easily create rich graphical editors within Eclipse. GEF has been used to build a variety of applications, including state diagrams, activity diagrams, class diagrams, GUI builders for AWT, Swing and SWT, and process flow editors. For more information on GEF features, please see the Project Overview.

What version of Eclipse do I need?

A given version of GEF requires the exact same version of the Eclipse Platform. For example, GEF 3.0.1 requires Eclipse 3.0.1.

How do I make a suggestion for this FAQ?

The best way to contribute to this FAQ is to post your suggestion to the GEF newsgroup with the subject prefixed by "[FAQ]". You may post just a question or both a question and answer.

Which operating systems does GEF support?

GEF is written in pure Java and should run on all operating systems officially supported by the Eclipse platform. It's primarily tested on Windows and Linux (GTK and Motif). See the readme file that came with your installation of GEF for specific versions.

How is GEF licensed?

GEF if licensed in accordance with the Eclipse Public License. Third party components built using GEF are made available under their own licenses.


Download and Install

How do I Install GEF?

Download the version of GEF that matches your installation of Eclipse. (The SDK download contains documentation and source, while the runtime download does not.) Exit Eclipse and unzip into the "eclipse" directory's parent directory. Restart Eclipse and verify that everything is installed. To do so, go to Help->About Eclipse Platform->Plug-in Details. Check the following entries:

Provider Plug-in name Eclipse.org Draw2d Eclipse.org Draw2d Documentation (SDK only) Eclipse.org Graphical Editing Framework Eclipse.org Graphical Editing Framework Documentation (SDK only) Eclipse.org Graphical Editing Framework SDK (SDK only)

The following directories should be present in your eclipse/plugins directory: (Note: Version numbers may differ according to download. This list assumes Eclipse build 2.1.0):

org.eclipse.draw2d.doc.isv_2.1.0 (SDK only) org.eclipse.draw2d_2.1.0 org.eclipse.gef.doc.isv_2.1.0 (SDK only) org.eclipse.gef.source_2.1.0 (SDK only) org.eclipse.gef_2.1.0

The following directories should be present in your eclipse/features directory: (Note: Version numbers may differ according to download. This list assumes Eclipse build 2.1.0):

org.eclipse.gef.source_2.1.0 (SDK only) org.eclipse.gef_2.1.0

Why isn't GEF showing up in Eclipse?

After installing GEF by extracting it to the necessary directories, it may be necessary to accept the changes within Eclipse. This can be accomplished by going to Help->Software Updates->Manage Configuration and right-clicking on Eclipse Platform. Select "Detected Changes..." from the menu and click Finish to complete the installation. This is the most common cause of the install not showing up in the aforementioned Plug-in Details view.

How do I Run the Logic Example?

Download the example that matches your version of GEF. Exit Eclipse and unzip into the eclipse directory. Restart Eclipse and verify it was installed by going to Help->About Eclipse Platform->Plug-in Details and checking for Logic GEF Example in the list. Next, create a simple Project. Then run the Logic Wizard. The wizard can be found at File->New->Other (Control+N), under the Examples heading. Select the simple project as the container in which the wizard will place the example document. The document should open automatically when you press Finish.

Where do I find the documentation?

The 3.1 documentation is now available online. Help menu-1.png

The latest documentation is available in the SDK download. After unzipping this build into your Eclipse installation directory, start Eclipse (and possibly restart after updating via the update manager), click on the Help menu and then Help Contents.

When the Help window opens, there will be a section called GEF and Draw2d Plug-in Developer Guide. Help toc.png

In this section, you'll find Developer Guides which contain high-level descriptions of GEF and Draw2d, as well as API References containing javadoc. Gef dev guide.png

How do I checkout GEF via CVS?

Open the CVS Repositories View using the Window menu. Right-click on the view and select "New" --> "Repository Location..." Enter the data shown here. Check out both the GEF and Draw2d plug-ins from the head stream for the most recent versions. File:FAQ CVS.gif