Difference between revisions of "GEF/Developer FAQ"

From Eclipsepedia

< GEF
Jump to: navigation, search
(Download and Install)
(Use the Eclipse Update Manager)
Line 52: Line 52:
 
=== Use the Eclipse Update Manager ===
 
=== Use the Eclipse Update Manager ===
 
1. Go to the Help / Software Updates / Find and Install..."
 
1. Go to the Help / Software Updates / Find and Install..."
 +
 
2. Choose the "Search for new features to install" option
 
2. Choose the "Search for new features to install" option
 +
 
3. Add one of the update sites below.
 
3. Add one of the update sites below.
  

Revision as of 16:03, 18 April 2006

Contents

General

What is GEF

The Graphical Editing Framework is an open source framework dedicated to providing a rich, consistent graphical editing environment for applications on the Eclipse Platform.

Why should I use GEF?

GEF enables developers to easily create rich graphical editors within Eclipse. GEF has been used to build a variety of applications, including state diagrams, activity diagrams, class diagrams, GUI builders for AWT, Swing and SWT, and process flow editors. For more information on GEF features, please see the Project Overview.

What version of Eclipse do I need?

A given version of GEF requires the exact same version of the Eclipse Platform. For example, GEF 3.0.1 requires Eclipse 3.0.1.

How do I make a suggestion for this FAQ?

This FAQ is hosted as a Wiki. Anyone can edit this page after creating an account.

Which operating systems does GEF support?

GEF is written in pure Java and should run on all operating systems officially supported by the Eclipse platform. It's primarily tested on Windows and Linux (GTK and Motif). See the readme file that came with your installation of GEF for specific versions.

How is GEF licensed?

GEF if licensed in accordance with the Eclipse Public License. Third party components built using GEF are made available under their own licenses.


Download and Install

How do I Install GEF?

Download the bits manually

Download the version of GEF that matches your installation of Eclipse. (The SDK download contains documentation and source, while the runtime download does not.) Exit Eclipse and unzip into the "eclipse" directory's parent directory. Restart Eclipse and verify that everything is installed. To do so, go to Help->About Eclipse Platform->Plug-in Details. Check the following entries:

Provider Plug-in name Eclipse.org Draw2d Eclipse.org Draw2d Documentation (SDK only) Eclipse.org Graphical Editing Framework Eclipse.org Graphical Editing Framework Documentation (SDK only) Eclipse.org Graphical Editing Framework SDK (SDK only)

The following directories should be present in your eclipse/plugins directory: (Note: Version numbers may differ according to download. This list assumes Eclipse build 2.1.0):

org.eclipse.draw2d.doc.isv_2.1.0 (SDK only) org.eclipse.draw2d_2.1.0 org.eclipse.gef.doc.isv_2.1.0 (SDK only) org.eclipse.gef.source_2.1.0 (SDK only) org.eclipse.gef_2.1.0

The following directories should be present in your eclipse/features directory: (Note: Version numbers may differ according to download. This list assumes Eclipse build 2.1.0):

org.eclipse.gef.source_2.1.0 (SDK only) org.eclipse.gef_2.1.0

Use the Eclipse Update Manager

1. Go to the Help / Software Updates / Find and Install..."

2. Choose the "Search for new features to install" option

3. Add one of the update sites below.

Release site: http://download.eclipse.org/tools/gef/releases/update-site/site.xml

Milestone site: http://download.eclipse.org/tools/gef/milestones/update-site/site.xml

Update site for integration builds: http://download.eclipse.org/tools/gef/updates/site-interim.xml

You could also take a look at the Callisto site which by design lines up all the components together for a particular milestone. http://download.eclipse.org/callisto/releases/

Why isn't GEF showing up in Eclipse?

After installing GEF by extracting it to the necessary directories, it may be necessary to accept the changes within Eclipse. This can be accomplished by going to Help->Software Updates->Manage Configuration and right-clicking on Eclipse Platform. Select "Detected Changes..." from the menu and click Finish to complete the installation. This is the most common cause of the install not showing up in the aforementioned Plug-in Details view.

How do I Run the Logic Example?

Download the example that matches your version of GEF. Exit Eclipse and unzip into the eclipse directory. Restart Eclipse and verify it was installed by going to Help->About Eclipse Platform->Plug-in Details and checking for Logic GEF Example in the list. Next, create a simple Project. Then run the Logic Wizard. The wizard can be found at File->New->Other (Control+N), under the Examples heading. Select the simple project as the container in which the wizard will place the example document. The document should open automatically when you press Finish.

Where do I find the documentation?

The 3.1 documentation is now available online. Help menu-1.png

The latest documentation is available in the SDK download. After unzipping this build into your Eclipse installation directory, start Eclipse (and possibly restart after updating via the update manager), click on the Help menu and then Help Contents.

When the Help window opens, there will be a section called GEF and Draw2d Plug-in Developer Guide. Help toc.png

In this section, you'll find Developer Guides which contain high-level descriptions of GEF and Draw2d, as well as API References containing javadoc. Gef dev guide.png

How do I checkout GEF via CVS?

Open the CVS Repositories View using the Window menu. Right-click on the view and select "New" --> "Repository Location..." Enter the data shown here. Check out both the GEF and Draw2d plug-ins from the head stream for the most recent versions. File:FAQ CVS.gif


Developer

When should I use GEF and when should I use just Draw2d?

The simple answer to this question lies in their names. Draw2d is for drawing. GEF (or Graphical Editing Framework) is for editing.

Draw2d is used for rendering and layout. If all you want is to display data, all you need is Draw2d. If, on the other hand, you want to be able to manipulate that data, you should use GEF. GEF adds important functionality for editing -- commands for changing your model, a palette and tools for selecting and manipulating the edit parts that represent your model, direct edit, accessibility support such as keyboard navigation, native drag and drop, and much more that I've probably missed.

There may be only a few of these functions that you need -- for instance, you may just want to add drag and drop support so that you can drag files from the navigator or a file explorer and drop them onto your application/view, but otherwise only need to display the dropped data and not manipulate it. This is where the line gets blurred. You'll need to weigh the advantages and disadvantages of both options. On the one hand, you could move to GEF, get a bunch of functionality that you don't need and increase the complexity of your code. Or you could stick with Draw2d and implement the functionality you need yourself, maintaining a much simpler implementation. For the above example, I would personally implement the drag and drop function myself and stick with Draw2d. However, you should also consider future needs. You may want more of these functions down the road and moving to GEF now may be helpful.

How do I redistribute GEF with my application?

First off, you should probably check out the Eclipse.org Legal FAQ, the CPL FAQ, and/or the CPL itself. More information forthcoming.

How do I ask questions?

Questions about the use of GEF in user projects that are not addressed in this FAQ should be posted to the GEF newsgroup. Questions and comments regarding the implementation of GEF itself should be posted to the GEF mailing list.

How do I report a bug or request a feature?

GEF, like the Eclipse project, uses Bugzilla as its bug and feature tracking system. Entering a bug\feature report is as simple as filling in a web form on the eclipse bugzilla page. The first time you enter a bug you will need to create a new bugzilla account for yourself by providing an email address and choosing a password. Before submitting a bug, please be sure to check the list of open GEF bugs and recently closed GEF bugs.

Can I develop a standalone GEF application without use of the Eclipse platform?

The official answer is No, this is not supported. The main reason involves the use of an Eclipse-specific file titled plugin.properties which GEF uses for string externalizations. However, since GEF is an open source project, modifications to the GEF codebase could potentially allow a GEF editor external to Eclipse.

How can I get started on my GEF-based editor?

The best place to investigate initially is the GEF documentation. This provides high-level concepts of GEF and Draw2d. There is also a sample GEF editor that can be downloaded at the GEF download page . The source code is made entirely available.


Coding

How do I do "X" when the User double-clicks?

Mouse events are handled by a Draw2D event dispatcher. When using GEF, a DomainEventDispatcher is used which allows heterogeneous handling of mouse events. Mouse presses in general can either be processed by a Figure, or by a Tool. A double-click is also a click, so the first event is a MouseDown, followed by a DoubleClick event. When a MouseDown is dispatched, the event dispatcher will continue to send events to either the Figure or Tool until the Mouse is released. So this means if the Tool processes MouseDown, it continues to get DoubleClick, dragging, and MouseUp. If a Figure consumes the MouseDown event, it will receive these events.

The GEF SelectionTool already processes double-click and will send a SelectionRequest to the target EditPart under the mouse of the type REQ_OPEN. The request is sent by calling EditPart.performRequest(Request). This is the preferred way to do something in response to double-clicks.

How do I find the location of the context menu?

Often, GEF clients want to know the location of the context menu so that, for instance, new parts can be created or pasted at that location. The context menu can be brought up via the keyboard (Shift+F10) and there's no guarantee that the mouse cursor will be over the editor (or even the active window) when the context menu comes up. Hence, we recommend to do this in a location-neutral manner. For instance, new parts can be added to the top-left visible corner of the selected container, or the location can be determined based on the location of the part that was copied.