Jump to: navigation, search

FAQ Where can I find that elusive .log file?

Revision as of 13:33, 14 March 2006 by Claffra (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Whenever it encounters a problem that does not warrant launching a dialog, Eclipse saves a report in the workspace log file. The log file can be looked at in four alternative ways.


  • Window > Show View > PDE Runtime > Error Log.
   This gives you a view with the contents of the .log file.</li>



   Help > About Eclipse Platform > Configuration Details. 
   This prints out a great number of details about the environment and also
   concatenates the .log file. Great for including in a bug report.</li>



   Locate the file yourself, see workspace/.metadata/.log.</li>



  • Start Eclipse using -consoleLog.

This will print the messages that normally go to the .log file in the enclosing shell/command window. </li>




See Also:

FAQ_How_do_I_use_the_platform_logging_facility?