Difference between revisions of "FAQ Where can I find that elusive .log file?"

From Eclipsepedia

Jump to: navigation, search
 
m
Line 1: Line 1:
Whenever it encounters a problem that does not warrant launching a dialog, Eclipse
+
Whenever it encounters a problem that does not warrant launching a dialog, Eclipse saves a report in the workspace log file. The log file can be looked at in four alternative ways.
saves a report in the workspace log file.  
+
The log file can be looked at in four alternative ways.
+
 
+
 
+
* ''' Window > Show View > PDE Runtime > Error Log'''.
+
    This gives you a view with the contents of the <tt>.log</tt> file.</li>
+
 
+
 
+
 
+
 
+
*
+
    '''Help &gt; About Eclipse Platform &gt; Configuration Details'''.
+
    This prints out a great number of details about the environment and also
+
    concatenates the <tt>.log</tt> file. Great for including in a bug report.</li>
+
 
+
 
+
 
+
 
+
*
+
    Locate the file yourself, see <tt>workspace/.metadata/.log</tt>.</li>
+
 
+
 
+
 
+
 
+
* Start Eclipse using <tt>-consoleLog</tt>.
+
This will print the messages that normally go to the <tt>.log</tt> file
+
in the enclosing shell/command window. </li>
+
 
+
  
 +
*''' Window &gt; Show View &gt; PDE Runtime &gt; Error Log'''.  This gives you a view with the contents of the <tt>.log</tt> file.</li>
  
 +
*'''Help &gt; About Eclipse Platform &gt; Configuration Details'''.  This prints out a great number of details about the environment and also  concatenates the <tt>.log</tt> file. Great for including in a bug report.
  
 +
*Locate the file yourself, see <tt>workspace/.metadata/.log</tt>.
  
 +
* Start Eclipse using <tt>-consoleLog</tt>. This will print the messages that normally go to the <tt>.log</tt> file in the enclosing shell/command window.
  
 
== See Also: ==
 
== See Also: ==
 +
*[[FAQ How do I use the platform logging facility?]]
  
 
+
{{Template:FAQ_Tagline}}
[[FAQ_How_do_I_use_the_platform_logging_facility%3F]]
+

Revision as of 22:48, 1 June 2006

Whenever it encounters a problem that does not warrant launching a dialog, Eclipse saves a report in the workspace log file. The log file can be looked at in four alternative ways.

  • Window > Show View > PDE Runtime > Error Log. This gives you a view with the contents of the .log file.</li>
  • Help > About Eclipse Platform > Configuration Details. This prints out a great number of details about the environment and also concatenates the .log file. Great for including in a bug report.
  • Locate the file yourself, see workspace/.metadata/.log.
  • Start Eclipse using -consoleLog. This will print the messages that normally go to the .log file in the enclosing shell/command window.

See Also:


This FAQ was originally published in Official Eclipse 3.0 FAQs. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the Eclipse Public License v1.0.