Difference between revisions of "FAQ My runtime workbench runs, but my plug-in does not show. Why?"

From Eclipsepedia

Jump to: navigation, search
 
Line 59: Line 59:
  
 
[[FAQ_What_causes_my_plug-in_to_build_but_not_to_load_in_a_runtime_workbench%3F]]
 
[[FAQ_What_causes_my_plug-in_to_build_but_not_to_load_in_a_runtime_workbench%3F]]
 +
 +
<hr><font size=-2>This FAQ was originally published in [http://www.eclipsefaq.org Official Eclipse 3.0 FAQs]. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the [http://www.eclipse.org/legal/epl-v10.html Eclipse Public License v1.0].</font>

Revision as of 16:12, 14 March 2006

FAQ_How_do_I_create_a_plug-in?contains instructions for writing plug-ins in Eclipse. FAQ_Why_doesn’t_my_plug-in_build_correctly?tells you what to do if your plug-in has problems building. FAQ_How_do_I_run_my_plug-in_in_another_instance_of_Eclipse? explains how to run a plug-in in another instance of Eclipse. Despite all these instructions, in some cases, your plug-in builds fine and the runtime workbench launches but your plug-in still does not show. Various configuration-related things could be wrong.


  • The plug-in may not be selected in the launch configuration.

(SeeFAQ_How_do_I_run_my_plug-in_in_another_instance_of_Eclipse? for instructions on how to select plug-ins.)</li>



  • Your plug-in may rely on other plug-ins not enabled in your

current launch configuration. Check the error log. (See[[FAQ_Where_can_I_find_that_elusive_%3Ctt%3E.log%3C%2Ftt%3E_file%3F]] for messages referring to your plug-in.)</li>



  • If your plug-in contributes an action to the toolbar

and it does not show or if a menu option does not appear, your plug-in may still be activated. The workbench does not automatically add toolbar and menu items to every perspective. Run Window > Customize Perspective and verify whether your contribution is enabled for the current perspective.</li>



Your plug-in may not show because it is not yet needed. If all your plug-in does is contribute a view, you may need to show it explicitly by using Window > Show View > Other.... If your plug-in contributes an editor for a particular type, you may need to configure the file association; see Window > Preferences > Workbench > File Associations.</li>



  • Your plug-in may throw an exception in its static initializer

or in its plug-in class instance initializer. Again, consult the log file for error messages involving your plug-in.</li>




See Also:

FAQ_What_causes_my_plug-in_to_build_but_not_to_load_in_a_runtime_workbench?


This FAQ was originally published in Official Eclipse 3.0 FAQs. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the Eclipse Public License v1.0.