Difference between revisions of "FAQ How do I upgrade Eclipse?"

From Eclipsepedia

Jump to: navigation, search
m
Line 27: Line 27:
  
 
<hr><font size=-2>This FAQ was originally published in [http://www.eclipsefaq.org Official Eclipse 3.0 FAQs]. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the [http://www.eclipse.org/legal/epl-v10.html Eclipse Public License v1.0].</font>
 
<hr><font size=-2>This FAQ was originally published in [http://www.eclipsefaq.org Official Eclipse 3.0 FAQs]. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the [http://www.eclipse.org/legal/epl-v10.html Eclipse Public License v1.0].</font>
 +
 +
[[Category:FAQ]]

Revision as of 19:04, 26 July 2007

Upgrading Existing Eclipse Features

Run the Update Manager, using

Help > Software Updates > Find and Install... 
  > Search for updates of the currently installed features

The Update Manager will visit the Update site(s) for all your installed features/plugins and offer updates if any exist.

However, as of Eclipse 3.2, it is NOT possible to upgrade the Eclipse platform itself, only its features. So, you could for example upgrade the CVS feature or the PDE feature from 3.2.0 to 3.2.1, but not eclipse.exe itself.

If you want to upgrade to stable stream releases or even nightly builds, you have to live on the edge. Download a new build from the Eclipse download Web site (http://www.eclipse.org/downloads) and unzip it in a new directory. We strongly recommend against unzipping over your existing Eclipse version as unexpected side effects may occur, including (but not limited to): nausea, vomitting, shortness of breath, corrupt installation.

Complete upgrade instructions are always included in the Eclipse readme_eclipse.html file included with every build in the readme directory.

Upgrading Other Features

Upgrading other features (like CDT, PDT, WTP...) can be done without the need to download a new platform binary, but because many projects align very closely (eg., the Eclipse 3.2 / Callisto or Eclipse 3.3 / Europa release trains) you will likely need to upgrade the Eclipse platform as well.

See Also:




This FAQ was originally published in Official Eclipse 3.0 FAQs. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the Eclipse Public License v1.0.