Jump to: navigation, search

FAQ How do I remove a plug-in?

Revision as of 13:57, 6 March 2013 by Robin.nibor.org (Talk | contribs)

You should not remove plug-ins from Eclipse. Plug-ins should be installed as features using the Update Manager. The same Update Manager can be used to disable plug-ins by disabling the feature they belong to. Run Help > About Eclipse > Installation Details, select the software you no longer want and click Uninstall. (On Macintosh it is Eclipse > About Eclipse > Installation Details.) In older versions, you might need to Run Help > Software Updates > Manage Configuration..., select the feature of interest, and disable it with the task shown in the right window.

When a feature is disabled, all its plug-ins will be disabled also. They are still available on disk, and they can be enabled at any time in the future.

To physically remove the feature and its plug-ins, you will have to manually remove the feature from the eclipse/features directory and its plug-ins from the eclipse/plugins directory. We advise extreme caution here. Remove the wrong ones, and you may have quite some trouble restoring your Eclipse to a stable state. Unless you care a lot about hard disk use, we recommend leaving the plug-ins where they are.

Note that when manually removing plugins as described above, some metadata is still cached by Eclipse, which can lead to problems later on. Running Eclipse with the -clean option can help with that, as it causes Eclipse to clean the cached metadata. See the Running Eclipse help page for details about this option.

Comments from the peanut gallery

What about rolling back to a previous version, repairing a corrupted plugin, or eliminating conflicting plugins? Aren't there legitimate use cases for wanting to safely remove a particular plugin?

Under Helios/3.6/STS it's impossible to remove plug-ins or disable features. You can disable a few plugins at startup via "Window > Preferences" from the menu under "General > Startup and Shutdown". Uncheck the items you don't want to run when you start Eclipse. This needs to be done for every workspace. To remove a plug-in you need to remove the JAR file from the "plugins" directory, located in your Eclipse installation directory.

Under Indigo/3.7 the "Help > About Eclipse > Installation Details > Installed Software tab > Uninstall..." option works. For some.

Under Helios I had none of the menu items mentioned above. I went to Help -> Install New Software... ; clicked the small blue hyperlink for What is "already installed"; and under the Installed Software tab, this gave me (contrary to the notes above) the option to uninstall things. I used it to uninstall PyDev, which was creating conflicts for me with Java development.


This FAQ was originally published in Official Eclipse 3.0 FAQs. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the Eclipse Public License v1.0.