Jump to: navigation, search

Difference between revisions of "FAQ How can I generate HTML and toc.xml files?"

 
Line 1: Line 1:
You can write the HTML files and the corresponding <tt>toc.xml</tt>  
+
You can develop <tt>toc.xml</tt> files using the Table of Contents Editor provided by PDE and UA. To create a new table of contents, simply select '''File &gt; New &gt; Other... &gt; User Assistance &gt; Help Table of Contents''' and choose a project and file name for your table of contents.
file by hand, which is painful. An alternative is to use DocBook for
+
those who swear by XML, style sheets, and XSLT. Perhaps the
+
simplest way is to use the <tt>toc.xml</tt> Explorer and HTML
+
editor included as samples with this book.
+
  
 +
As for the HTML files, you can write them by hand, which is painful. There are many alternatives, such as DocBook, for
 +
those who swear by XML, style sheets, and XSLT, or the HTML editor included as a sample with this book.
  
 
== See Also: ==
 
== See Also: ==

Revision as of 11:48, 9 August 2007

You can develop toc.xml files using the Table of Contents Editor provided by PDE and UA. To create a new table of contents, simply select File > New > Other... > User Assistance > Help Table of Contents and choose a project and file name for your table of contents.

As for the HTML files, you can write them by hand, which is painful. There are many alternatives, such as DocBook, for those who swear by XML, style sheets, and XSLT, or the HTML editor included as a sample with this book.

See Also:

DocBook (http://www.docbook.org)


This FAQ was originally published in Official Eclipse 3.0 FAQs. Copyright 2004, Pearson Education, Inc. All rights reserved. This text is made available here under the terms of the Eclipse Public License v1.0.