Jump to: navigation, search

Extending or Contributing to Buckminster

< To: Buckminster Project

If you are going to be working with Buckminster itself, writing your own extensions, or provide patches, you should first install Buckminster as described in The Definitive Guide. As Buckminster source is stored in a Git repository, you need to install the EGit and JGit features from the release train.

Initial clone of the repository

  1. Ensure that the Git Repositories view is visible. You should be able to find it under "Window" => "Show View" => "Other..." => "Git" if its not.
  2. Click on "Clone a Git repository"
  3. Paste the following URL into the URI field in the wizard that pops up
    git://git.eclipse.org/gitroot/buckminster/buckminster.git
  4. Click "Next>" twice, then "Finish"

Populating the workspace

Create the local clone and check out the releng project

  1. Expand "buckminster" => "Working Directory" in the Git Repositories view.
  2. Select "org.eclipse.buckminster.releng", right click, and then select "Import projects..."
  3. Click "Next>" in the list of projects. A page where only the selected project is visible shows up.
  4. Click "Finish"

Prepare an empty target platform

  1. Create a new general project named TP (or some name of your preference)
  2. Open "Window" => "Preferences" and expand "Plug-in Development"
  3. Select "Target Platform"
  4. Click "Add..."
  5. Click "Next>" (i.e. start with nothing)
  6. Enter TP in the Name: field
  7. Click "Add..."
  8. Select "Directory" and click "Next"
  9. Click on "Variables..."
  10. Scroll down and select "workspace_loc" and then type TP in the Argument: field.
  11. Click "OK" and then "Finish" and then "Finish" again.
  12. Set your new target definition active by checking it in the list of Target definitions: and click "OK"

Run the cquery to populate the workspace

  1. Expand the org.eclipse.buckminster.releng project and open the build.cquery file. It should open using the Buckminster cquery editor.
  2. Press "Resolve & Materialize" in the CQUERY editor that appears
  3. Buckminster will now fetch and build Buckminster from source.

Submitting a patch

  1. Make necessary changes
  2. Ideally, write a JUnit test case that test your change and add it to the set of JUnit tests in the corresponding test project
  3. Commit your changes to your local Buckminster clone
  4. Use EGit to create a patch for your commit. This can be done by viewing the repository history, right clicking a commit, and then select "Create Patch..."
  5. Submit this patch as an attachment to a bug in our Bugzilla