Jump to: navigation, search

Difference between revisions of "Equinox Resource Monitoring Demo"

(Sleak)
(Client)
 
(4 intermediate revisions by the same user not shown)
Line 5: Line 5:
 
** The server will start automatically.
 
** The server will start automatically.
 
* Create resources in the workspace.
 
* Create resources in the workspace.
** <em>File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders</em>
+
** <strong>File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders</strong>
** Type <code>org.eclipse.equinox.*</code> in the filter to get all the Equinox projects selected and choose <em>Add</em>
+
** Type <code>org.eclipse.core.*</code> in the filter to get all the Core projects selected and choose <strong>Add</strong>
 
** Finish.
 
** Finish.
** <em>Note:</em> The Equinox projects appear in the workspace
+
** <em>Note:</em> The Core projects appear in the workspace
 
* Look at a preference value.
 
* Look at a preference value.
** <em>Window -> Preferences -> General -> Workspace -> Build Automatically</em>
+
** <strong>Window -> Preferences -> General -> Workspace -> Build Automatically</strong>
 
** <em>Note:</em> the auto-build preference is set to be true.
 
** <em>Note:</em> the auto-build preference is set to be true.
 
** Close the Preferences window.
 
** Close the Preferences window.
Line 18: Line 18:
 
* Start the SDK.
 
* Start the SDK.
 
* Switch perspectives and create a connection to the server.
 
* Switch perspectives and create a connection to the server.
** <em>Window -> Open Perspective -> Other -> JMX Resource Management</em>
+
** <strong>Window -> Open Perspective -> Other -> JMX Resource Management</strong>
** <em>JMX Server -> Open Connection</em>
+
** <strong>JMX Server -> Open Connection</strong>
 
** Choose proper host, port and protocol. (default is <em>localhost</em>, <em>8118</em>, and <em>rmi</em>)
 
** Choose proper host, port and protocol. (default is <em>localhost</em>, <em>8118</em>, and <em>rmi</em>)
 
** OK.
 
** OK.
* <em>Note:</em> The <em>Contributions View</em> will be populated with the available contributions from the server.
+
* <em>Note:</em> The <strong>Contributions View</strong> will be populated with the available contributions from the server.
  
 
===Bundles===
 
===Bundles===
* In the <em>Contributions View</em>, expand the <em>Bundles</em> element.
+
* In the <strong>Contributions View</strong>, expand the <strong>Bundles</strong> element.
 
** <em>Note:</em> These are all the bundles that are installed on the server.
 
** <em>Note:</em> These are all the bundles that are installed on the server.
 
* Expand <code>org.eclipse.equinox.registry</code>.
 
* Expand <code>org.eclipse.equinox.registry</code>.
Line 32: Line 32:
 
** Expand the required bundles to show what it requires.
 
** Expand the required bundles to show what it requires.
 
*** Expand <code>org.eclipse.equinox.common</code> to show it is recursive.
 
*** Expand <code>org.eclipse.equinox.common</code> to show it is recursive.
** Expand <em>Services</em>.
+
** Expand <strong>Services</strong>.
 
*** <em>Note:</em> there are 3 different icons, one each for providing, using, and both.
 
*** <em>Note:</em> there are 3 different icons, one each for providing, using, and both.
  
 
===Extension Registry===
 
===Extension Registry===
* In the <em>Contributions View</em> expand the <em>Extension Points</em> element.
+
* In the <strong>Contributions View</strong> expand the <strong>Extension Points</strong> element.
 
** <em>Note:</em> All the extension points are listed.
 
** <em>Note:</em> All the extension points are listed.
 
* Navigate to the <code>org.eclipse.runtime.applications</code> extension point
 
* Navigate to the <code>org.eclipse.runtime.applications</code> extension point
Line 44: Line 44:
  
 
===Preferences===
 
===Preferences===
* In the <em>Contributions View</em> expand the <em>Preferences</em> element.
+
* In the <strong>Contributions View</strong> expand the <strong>Preferences</strong> element.
* Expand to <em>Preferences -> instance -> org.eclipse.core.resources</em>.
+
* Expand to <strong>Preferences -> instance -> org.eclipse.core.resources</strong>.
 
* Select the <code>org.eclipse.core.resources</code> node.
 
* Select the <code>org.eclipse.core.resources</code> node.
* In the <em>Operations</em> part of the editor, select the <code>put</code> operation.
+
* In the <strong>Operations</strong> part of the editor, select the <code>put</code> operation.
* In <em>Invocation View</em>, set the parameters to be the key <code>description.autobuilding</code> and the value <code>false</code>.
+
* In <strong>Invocation View</strong>, set the parameters to be the key <code>description.autobuilding</code> and the value <code>false</code>.
* Select the <em>Invoke</em> button.
+
* Select the <strong>Invoke</strong> button.
 
* Look at the preference on the server.
 
* Look at the preference on the server.
** On the server choose: <em>Window -> Preferences -> General -> Workspace</em>.
+
** On the server choose: <strong>Window -> Preferences -> General -> Workspace</strong>.
** <em>Note:</em> The <em>Build Automatically</em> preference is now unchecked.
+
** <em>Note:</em> The <strong>Build Automatically</strong> preference is now unchecked.
  
 
===Services===
 
===Services===
* In the <em>Contributions View</em> expand the <em>Services</em> element.
+
* In the <strong>Contributions View</strong> expand the <strong>Services</strong> element.
 
* Expand the <code>org.eclipse.core.runtime.IExtensionRegistry</code> element.
 
* Expand the <code>org.eclipse.core.runtime.IExtensionRegistry</code> element.
* Expand the <em>Bundles</em> element and see who is importing the service, exporting the service, and both.
+
* Expand the <strong>Bundles</strong> element and see who is importing the service, exporting the service, and both.
  
 
===Sleak===
 
===Sleak===
* In the <em>Contributions View</em> select the <em>Sleak</em> element.
+
* In the <strong>Contributions View</strong> select the <strong>Sleak</strong> element.
 
* <em>TODO:</em> This is currently broken and needs to be fixed.
 
* <em>TODO:</em> This is currently broken and needs to be fixed.
  
 
===VM===
 
===VM===
* In the <em>Contributions View</em> expand the <em>VM Stats</em> element.
+
* In the <strong>Contributions View</strong> expand the <strong>VM Stats</strong> element.
 
* <em>Note:</em> All the VM info is for the VM currently running the server.
 
* <em>Note:</em> All the VM info is for the VM currently running the server.
  
 
===Workspace Resources===
 
===Workspace Resources===
* In the <em>Contributions View</em> expand the <em>Workspace Resources</em> element.
+
* In the <strong>Contributions View</strong> expand the <strong>Workspace Resources</strong> element.
* <em>Note:</em> The Equinox projects that you previously imported into the server's workspace should be in the list.
+
* <em>Note:</em> The Core projects that you previously imported into the server's workspace should be in the list.
* Select the <code>org.eclipse.equinox.launcher.win32.win32.x86</code> fragment.
+
* Select the <code>org.eclipse.code.boot</code> project.
* In the editor, in the <em>Operations</em> part of the form, select the <code>delete</code> method.
+
* In the editor, in the <strong>Operations</strong> part of the form, select the <code>delete</code> method.
* Make the <em>Navigator View</em> from the server instance visible to the user.
+
* Make the <strong>Navigator View</strong> from the server instance visible to the user.
* In the <em>Invocation View</em> select the <em>Delete</em> button.
+
* In the <strong>Invocation View</strong> select the <strong>Delete</strong> button.
* <em>Note:</em> The launcher fragment project was deleted from the server's workspace.
+
* <em>Note:</em> The project was deleted from the server's workspace.
  
 
[[Category:Equinox]]
 
[[Category:Equinox]]

Latest revision as of 17:05, 2 March 2007

Server Setup

  • Install the server zip file into an Eclipse SDK (tested with build I0228-0930).
  • Note you can set port and protocol via System properties (but we won't).
  • Start the SDK.
    • The server will start automatically.
  • Create resources in the workspace.
    • File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders
    • Type org.eclipse.core.* in the filter to get all the Core projects selected and choose Add
    • Finish.
    • Note: The Core projects appear in the workspace
  • Look at a preference value.
    • Window -> Preferences -> General -> Workspace -> Build Automatically
    • Note: the auto-build preference is set to be true.
    • Close the Preferences window.

Client

  • Install the client zip file into an Eclipse SDK (tested with build I0228-0930).
  • Start the SDK.
  • Switch perspectives and create a connection to the server.
    • Window -> Open Perspective -> Other -> JMX Resource Management
    • JMX Server -> Open Connection
    • Choose proper host, port and protocol. (default is localhost, 8118, and rmi)
    • OK.
  • Note: The Contributions View will be populated with the available contributions from the server.

Bundles

  • In the Contributions View, expand the Bundles element.
    • Note: These are all the bundles that are installed on the server.
  • Expand org.eclipse.equinox.registry.
    • Note: The imported packages and required bundles are listed as well as the services.
    • Expand the imported packages to show what it requires.
    • Expand the required bundles to show what it requires.
      • Expand org.eclipse.equinox.common to show it is recursive.
    • Expand Services.
      • Note: there are 3 different icons, one each for providing, using, and both.

Extension Registry

  • In the Contributions View expand the Extension Points element.
    • Note: All the extension points are listed.
  • Navigate to the org.eclipse.runtime.applications extension point
    • Note: All of the available applications should be there, including the JMX server application and the IDE application.
  • TODO: Can we hook in Tom's demos here? click on an extension and start it remotely?
  • Future work: add extensions, namespaces, better grouping, and more methods.

Preferences

  • In the Contributions View expand the Preferences element.
  • Expand to Preferences -> instance -> org.eclipse.core.resources.
  • Select the org.eclipse.core.resources node.
  • In the Operations part of the editor, select the put operation.
  • In Invocation View, set the parameters to be the key description.autobuilding and the value false.
  • Select the Invoke button.
  • Look at the preference on the server.
    • On the server choose: Window -> Preferences -> General -> Workspace.
    • Note: The Build Automatically preference is now unchecked.

Services

  • In the Contributions View expand the Services element.
  • Expand the org.eclipse.core.runtime.IExtensionRegistry element.
  • Expand the Bundles element and see who is importing the service, exporting the service, and both.

Sleak

  • In the Contributions View select the Sleak element.
  • TODO: This is currently broken and needs to be fixed.

VM

  • In the Contributions View expand the VM Stats element.
  • Note: All the VM info is for the VM currently running the server.

Workspace Resources

  • In the Contributions View expand the Workspace Resources element.
  • Note: The Core projects that you previously imported into the server's workspace should be in the list.
  • Select the org.eclipse.code.boot project.
  • In the editor, in the Operations part of the form, select the delete method.
  • Make the Navigator View from the server instance visible to the user.
  • In the Invocation View select the Delete button.
  • Note: The project was deleted from the server's workspace.